BEFSX41 stoped routing!

Discussion in 'Cisco/Linksys Wireless Routers' started by k-larson, Sep 5, 2006.

  1. k-larson

    k-larson LI Guru Member

    Hi all I'm a newbie poster and am typing this a second time because my first submit of the thread timed out on me.:frown:

    I'm having a problem with my BEFSX41 router where it's slowed down terribly and now has stopped routing altogether. I have a single PC and a Vonage VoIP MTA (Motorola VT1005) on the LAN side of the router connected to a Linksys BEFCMU10 cable modem on Comcast HSI with 6000/384 speed "silver package" service. I've had this configuration for 3+ years with only an occasional drop from Comcast and a repeated router reboot problem 2 1/2 years ago that was fixed by a firmware flash to version 1.50.9

    About 3 days I noticed a very steep drop in traffic speed from LAN to WAN and WAN to LAN. So bad that my Vonage started acting very unpredicable and effectively useless for making call. Web browsing had also slowed to a crawl.

    Here's what's gone on so far. BTW, I'm a software/harware performance engineer so I pretty familiar entire system and how to troubleshoot. Using PingPlotter and several internet speed tool running on the PC I was able to isolate the problem to the router. I normally get 6Mbps downlink and ~350Kbps uplink speed on from the PC thru the router and cablemodem. After the slowdown, I measured ~200Kbps downlink and ~25Kbps uplink speed. Connecting the PC's NIC directly to the cablemodem, bypassing the router, I was again measureing full 6Mbps/350Kbps speed. With the router back in line PingPlotter revealed that 70-80% of outbound packets (LAN to WAN) were being dropped.

    I got on an online chat with Linksys support and the concensus amount 3 reps, one a Sr. Tech, was that it might be a known issue and that I needed a firmware flash to the current version. All that had been done so far was my troubleshooting and removing the router from the line so I could get enough speed to get in an online chat, most importantly no router changes other than a few power cycles I tried when trouble shooting.

    When I went to do the firmware flash yesterday I ran into more problems trying to put the router back in line. With router back in line between the PC and the cablemodem I couldn't get an IP addr at the PC from the router's DHCP server.

    Got on the phone with Linksys support. Here's how the call(s) went. :mad:

    Call 1 (20 min. in queue): After a 2.5 hour call to India with a pretty inexperienced call center Tech I got hang up when she got frustrated. In the 2.5 hours all she accomplised was about 20 useless tasks from her troubleshooting script, all thing I explained to her I had already done myself, but the she insisted on doing with me while on the phone. It as all the novice stuf like swap cables, got directly to the cable modem, run ipconfig, etc. IHO, the only thing of use she did was to power cycle the router and the cable modem when both were connected. Result still no IP from the router DHCP server, then the hang up.

    Call 2 ( 2 min in queue): Another call to India again with another inexperienced Tech that after 1 hour transfered me to a Sr. Tech who hung up on me within 5 minutes because I asked to explain to his thought process and why he was asking to do things. However, this Sr. Tech did acocomplish something. By lowering my NIC speed to 10Mbps full duplex I was able to get an IP addr from the router, but we then found in the router's status page that the router wasn't getting an IP from the ISP on the WAN side. When I asked him to explain what he wanted to do he hung up.

    Call 3 (35 min in queue): This time the call goes to Maylaysia where another inexperienced Tech at least noticed I was having problems with them and put me on hold for 20 min. for her supervisor to try to transfer me to another Sr. Tech. This time the Supervisor left me on hold for another 25-30 min before coming back to say the transfer buttons on her phone weren't working.:eek: She takes my number and promises a call back in 1 min.

    Call 4: Supervisor calls me supposedly from Sr. Tech's phone and finally I get a someone thats seem skilled, patient, and willing to explain his reasoning. Another 3 hours. We flashed the firmware to the most current version 1.52.10 (I was on 1.50.9.) with the hard reset, upgrade from admin page, reset, power cycle process. Same results each time according to the router's status page no IP on the WAN side from the ISP DHCP server. One of the latter times he put me on hold to go "confer with another tech" I ran a experiment on my own.:wink: I got the ISPs IP info by connecting the PC's NIC directly to the cablemodem and did an "ipconfig /renew" then took that and set the router to a static WAN IP with that info. Voila, router is routing again. However, PingPlotter is still showing 80-85% outbound packet drops and it stops working (100% drops) after about 5 min. He was shocked!:eek:
    We flashed the firmware 2 more times to try get the routing back, but no luck. It's same a before. LAN ports only work only at 10Mbps link speed and no routing with either dynamic or static WAN IP config. I suggested to the Sr. Tech that I thought the WAN port may also be not functioning at 100Mbps and that it needed to be set lower. He said he doesn't know a way to do that and the my router needs to be replaced.

    Please, I'm at my wit's end here!:mad:

    Any help, idea, or suggestion on how get routing working again and get the port speeds funcitoning at 100Mbps would be greatly appreciated.
  2. Guyfromhe

    Guyfromhe Network Guru Member

    Sounds like your router is broken, if it were a wrt54 you could get custom firmware and force the WAN port to 10 mbit but I don't believe any Linksys routers let you force a speed on any of the ports by default...

    It's very likely that is the issue on the WAN port it's negotiating 100 mbit but only running at 10... i've seen it happen before, so it's not at all impossible.

    You woiuld need more hardwrae to fix the problem so it's probably cheaper to just replace the router, talk to Linksys see if they'll warantee it.

    If not they may give you a good price on a new router through them if their tech says the router broke...

    You should be able to force your modem to run at 10 mbit, but that would have to be done by Comcast, and it's highly unlikely anyone there would know enough to get that done for you.
  3. d__l

    d__l Network Guru Member

    So the SX41 is three years old and this problem started out of the blue? It may have a physical problem such as a dried out or failing capacitor. I guess eventually if nothing else works, you can always pop it open and inspect them seeing as you are well out of warranty.

    Do you have good air ciculation with no heat source underneath the SX41? Heat is a common cause of speed problems with the SX41. They might even be more sensitive to heat if the caps are getting old.

    Have you tried inserting a hub (a true 10 mbps hub) between the modem and the SX41? The SX41's WAN port used to have problems negotiating the proper speeds and duplexes with certain Motorola cable modems. The hub trick would correct this speed mismatch. If the PHY chip on your WAN port has become a little sensitive on the required electrical parameters, the hub trick might work for you.

    I'm surprised 1.50.9 worked for you. That was a known crappy firmware version. 1.45.7 or 1.51.00 were considered far superior:,11329487 You might consider rolling back to either of those versions. If you do, long reset (hold the reset button in for 30 secs) back to factory defaults before AND after flashing. Also only use IE with the internal GUI-based flashing page.

    Fix link.
  4. k-larson

    k-larson LI Guru Member

    Got it limping along...

    Thanks for getting me thinking in another direction Guyfromhe. :)

    As I read your thoughts on not being able to step down the ethernet port on the cable modem to 10Mbps :hmm:, I came up with the idea of putting an old Linksys 10Mbps half duplex hub between the cablemodem and router. It's actually the equipment I used before I had the router. After digging it out of the old junk bin and crimping up a short Cat5 cable I power cycled everything in outside in order and the cablemodem came up with a WAN IP just fine, albeit running at 10Mbps half duplex. That's not too bad seeing as the Comcast service is only 6Mbps downlink and 350Kbps uplink anyway. That's much less than 10Mbps.

    My only big concern is now that my Vonage MTA, inside my firewall, is limited to a half duplex link. I quickly made a couple of call to folks I talk to regularly and a surprise to me is they all said the voice quality is better than they can remember my Vonage call being for a long time. I'm going to at least monitor the VoIP quality for a couple of days with a couple of online tools that measure latency, jitter, etc. and see how it works out.

    So it seems reasonable to conclude that the router had been having problems passing packets at 100Mbps for a long time and has probably been gradually dropping more and more packets until it hit the wall when set at 100Mbps and stopped working at that speed a few days ago.

    I'm going to give Linksys support one more go at this now that I know the router will at least limp along at 10Mbps and see what their Sr. Tech can come up with. Perhaps there's something firmware wise that can be done now, like a different version than I'm on not (1.52.10) or perhaps they can swap out the router.

    Anyway thanks for fresh view on the problem!!!:thumbup:
  5. Guyfromhe

    Guyfromhe Network Guru Member

    I wasn't sure if you had a 10 mbit hub thats why I said it would require additional hardware in my response... Good to hear you got it working...
    I doubt support can help you it really sounds like a hardware issue.
  6. k-larson

    k-larson LI Guru Member

    Another poster hits the nail on the head.

  7. k-larson

    k-larson LI Guru Member

    d__l rocks !!!

    Great minds think alike.:)

    d__l, you had the same idea I did while I was trying it out and replying to Guyfromhe. Too bad I didn't see your post before replying to his. Many thanks though, you've pretty much confirmed my concept of what's wrong. It's also a shame that the Techs at Linksys couldn't even come up with anything close to this idea. Their best was "go buy a new router". Perhaps they get incentives for driving new sales where they may not be needed. Frankly, from a profitablity perspective, I can't see how they afford to fund as much support as they do. I'm sure I burned thru any money they made off the < $100 price I paid for the router in the first place with multiple person hours on the phone with them.

    BTW, based on your comments regarding the capcitors aging, it sounds like you have a lot of HW experience with these routers. I wasn't familiar with any issues there nor the heat/speed problems, airflow, or speed negotiation problems with Motorola cable modems. All along my Motorola VoIP MTA (Vonage) has been inside the router on a LAN port though. However, because they are specifically made to do so, I have had the router stacked on the cablemodem. In addition the VoIP MTA sat on top of the router too. That was probably enough right there to bring out any heat sensitivities. Any thoughts on that? Any way to diagnose what circuitry might now be out of spec. and figure out what components to replace?

    Regarding firmware versions, I flashed the router to 1.50.9, again at the behest of the Linksys support, to resolve a problem I had with frequent and annoying self rebooting of the router back 2 1/2 years ago. No, problems with that firmware until now. I'll keep my eye out for any new issues with 1.52.10 and roll it back to an earlier version if needed. The only ones I have are 1.45.3, 1.50.9 and 1.52.10. Where can get 1.45.7 if needed? Oh, and just to reinforce what you said, I did know to do your recommended hard reset, flash, hard reset using only IE. Everyone reading this should make note of the flashing procees lest you brick your router.

    In fact, in hindsight, firmware may not even be a part of the real problem here/age if it all turns out to be heat related. I guess it's one of the only real things Linksys support Techs do to resolve issues for these routers, needed or not, kind of like the "If all you have is hammer, everything looks like a nail." syndrome.
  8. d__l

    d__l Network Guru Member

    I don't have any experience with cable modems and the SX41, but I've read enough complaints about the speed/duplex problem with the Surfboard 4100 modem (if I recall the model correctly) to know that it almost always required a hub to translate the speed properly.

    Maybe if you spread out the router so that it was over no heat source and air could circulate laterally from underneath and up and through the router freely, then your possible heat problem might be solved without having to resort to the hub. I know from personal experience that some units can handle up to at least 85 degrees F ambient as long as the circulation/convection through the router isn't blocked. That may involve adding leg extensions to increase free air flow from underneath the router. Others have reported that at about those temps with restricted air circulation (the router sitting on deep carpet or blocked in by other equipment), they would have throughput slowdowns.

    The only user replaceable components that I've heard about are the main electrolytic caps. A fellow bought a "dead" SX41 cheap off eBay and opened it up. The caps were either leaking or dried out and he replaced those and had a perfectly working router afterwards.

    1.45.7 and 1.51.00 can be found in the link I posted above. Had to fix the link as it was initially incorrect (stale clipboard contents). :( Here is a link to discussion about the merits of 1.52.9 which seems to be a fairly good version:,15331164

    Some of the older firmware versions had a hidden page that was supposed to allow the WAN port speed/duplex to be forced: I don't know how well it worked, if at all, as I never used it and there was probably a reason why it was a hidden feature. I know that it was available in 1.45.7, but some time after that (the 1.5x firmware versions) they removed that page.
  9. Guyfromhe

    Guyfromhe Network Guru Member

    The linksys techs probably don't expect that you have a 10 mbit hub just lying around and it's better to buy a working 100 mbit router than a 10 mbit hub to fix the problem which could shortly result in having to replace the router anyway. (in which case if they told you to buy a hub and you did and your router died the next day and you were stuck with a hub and had to buy a new router you'd be blaming Linksys support) also they may not have had many cases where heat was the cause or that they found out about... could also be crappy pay and shoddy training for the reasons you mentioned about support costs above...
    some people they loose money on, some people never call in and they make whatever support costs they added to the router.

    The routers are probably not a whole lot more than $5 or $10 a piece to mass prodouce.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice