BEFSX41 V2 Firmware upgrade error -FIX-

Discussion in 'Other Linksys Equipment' started by phulaeo, Jan 10, 2006.

  1. phulaeo

    phulaeo Guest

    I was about to post the following question, signed up to do it and everything, when I figured out what was wrong... so I thought I'd post it anyway in case other people can use what I did:

    Downloaded file name: befsx41_v1.50.18_code%2C1.bin
    Change filename to: befsx41_v1.50.18_code.bin

    It's just a guess, but my first thought is that the escaped character is being added by some oddball script fluke on Linksys' side... renaming the file worked like a charm. Since this is a common error, perhaps this is a widespread problem which Linksys should look into.

    Now, enjoy my confusion:

    It's a well-known error, so I feel like kind of a fool asking about it, but there doesn't seem to be an actual fix... I can't figure out what I'm doing wrong.

    Current firmware: 1.45.3
    New firmware: 1.50.18

    I'm using the 'upgrade firmware' link in the 'help' section of the router interface... the file it downloads is called 'befsx41_v1.50.18_code%2C1.bin' and throws an upgrade file pattern error when I attempt to upgrade with it.

    It's definitely a V2; I've triple checked the product number and double checked the link I'm going to for the firmware upgrade (redownloading the firmware also did not help).

    Any ideas would be appreciated!
  2. vhato

    vhato Network Guru Member

    I don't know how to solve your problem. Back in 2004 I upgraded to the 1.50.18 Firmware with no problem. On this site, in the downloads sections is the latest 1.52.3 Firmware from China. It hasn't made it to the American Linksys site yet, but it works great. I don't know what it fixed over the previous version, but it does add ALOT of QoS functions.

    One thing I did see is Full-Duplex is actually working. Before it was just enabling it on the NIC's, but not allowing the Bandwidth, now TCP and UDP Taffic have doubled in bandwidth. Before this upgrade my max was 93mpbs using Qcheck, now it is 216mbps. PC-PC Transfers are outrageous now.
  3. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    You want to stay as far away from any 1.50x versions as you can....horrible problems. 1.51x versions are marginally better. 1.52.3 is OK, still a few bugs in it....I've tried them all a few times, I have over a fleet of over a hundred of the sx41 routers out there...and I maintain them at the trusty old 1.45.7 firmware. Even new ones that I deploy..I still backflash them to 1.45.7.
  4. jaydubb

    jaydubb Network Guru Member

    Hey YeOldStoneCat, this is CrazyJW1971 from Speedguide...

    I noticed a new firmware on Linksys' site today. 1.52.9 is now available. I dont know if it's been tested by anyone as of yet. I might take a shot at it later today and give some feedback. If not, I will just go back to 1.45.7 :) !
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice