BEFVP41 v1 Firmware Confusion...??

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by UptimeJeff, Sep 28, 2006.

  1. UptimeJeff

    UptimeJeff Network Guru Member

    A client just purchased a BEFVP41 router, new in the box, and it turned out to be V1.

    The router status page shows firmware version 1.02.00

    When I check on the Linksys site, and look at the BEFVP41 V1, the latest firmware is from Sept 2003 and is listed as version 1.41.1
    When I look at the version history, it doesn't look like the V1 router went from 1.02.00 -> 1.41.1 (see history below)

    Putting my faith into what Linksys provided, I attempted to update the V1 router to 1.41.1. The router would not take this firmware.

    Is Linksys listing an incorrect firmware version for this router?
    What is the latest firmware for this router?
    Can anyone send it to me (

    The reason behind this...
    I'm not able to bring-up VPN connection with this router. My other locations have the V2 version, so I assume newer firmware could solve the issue. Any leads appreciated.

    Jeff Johnson

    Firmware Version History from Linksys site:
    BEFVP41 Firmware History
    v1.41.1 2003-9-4
    1. Update UPnP module.
    2. Renew MTU/MRU module.
    3. Support MSN 4.7/5.0 compatible
    4. Support Multiple PPTP Passthrough
    5. Support Multiple L2TP Passthrough
    6. Support X-Box Live Service (Firmware has not been Certified by Microsoft Xbox Live Logo Center)
    7. Fixed Port Forwarding and Port Triggering issue.
    8. User Interface: Returns the user to the previous screen automatically after pressing the "Apply" button.
    9. Change NTP server(do not use Fukuoka NTP server anymore)

    v1.40.4 2002-11-21
    1. Fixed system hang issue caused by gozila.cgi
    2. Fixed system reboot issue caused by long password
    3. Deny user to enable remote management when password is "admin".
    4. Fixed security holes if the packets include the string ".xml".
    5. Fixed a DDNS bug that sytem always send a query packet to server
    after pressing "Apply" button.
    6. Added "Remote Management Port"

    v1.40.3f 2002-09-19
    1. Fixed a bug that MAC filter can not work when all MAC address
    entries are occupied.
    2. Solved the problem that can not connect to HeartBeat server
    3. Solved the reset problem when VPN enabled, VPN keep-alive checked,
    Log enabled and logging IP doesn't exist.

    v1.40.3e 2002-07-17
    1. Added "Heart Beat Server" item on "Telstra BPA Cable Login"
    WAN Connection Type.
    2. Support DDNS

    v1.40.3d 2002-07-02
    1. On Setup screen, added a "Telstra BPA Cable Login" option on
    "WAN Connection Type" lists for Australia users use.
    2. On VPN screen, changed string "more..." to "Advanced" button
    3. On Advanced-IPSec screen, added a field "Username" for
    dynamic tunnel connection with SonicWall router.
    4. Solve the DHCP-client problem that causes DHCP-Renew failure
    5. Support NetMessanger v4.6
  2. TazUk

    TazUk Network Guru Member

    The BEFVP41 v1's came out many years ago so I wouldn't have expected a new one to still be in circulation. The firmware version listed on the Linksys website is correct for that model/version of router. My guess is it's not a v1 but actually a v2.
  3. UptimeJeff

    UptimeJeff Network Guru Member

    Perhaps hardware is v2??

    Maybe the hardware is version 2.0...
    The interface though, doesn't show it as 2.0 (as other linksys routers show 2.0 in the web interface).

    I'll have the client physically check the device for a version number (I'm 900 miles away from it)..

    Can anyone with a V2 confirm IF the web interface shows it as version 2.0??

  4. TazUk

    TazUk Network Guru Member

  5. UptimeJeff

    UptimeJeff Network Guru Member


    OK... It's even more confusing now..

    First, thanks for your screenshot of a V2, that helped.

    The router GUI, only says BEFVP41 (no version # listed)
    I had the client check the device, and it says BEFVP41 V2.1

    The firmware is version 1.02.00

    So maybe this is a newer hardware version, which Linksys hasn't even listed in their firmware download section????

    See attached screenshot of gui, it does not show a version at all- that's the confusing part.

    So maybe I should not be concerned with the latest GUI...
    But I can say that this version is not working when others version (v2) do function when connecting from Macs using VPNTracker or IPSecuritas (both are front ends to racoon on OS X, and they work great at several other locations).


    Attached Files:

  6. cory_jackson

    cory_jackson Addicted to LI Member

    It's no joke. Ver2.1 routers have been shipping with FW1.02.00. I know, Ihave 5 of them and they all have the same problems. Support thinks it's a beta but obviously it's been released to production. What's more support claims if I revert to a prior version it will void my warranty. And if I install a beta code it will void the warranty. Can you say Catch-22?
  7. DocLarge

    DocLarge Super Moderator Staff Member Member

    This is a way of getting you to buy the newer products. It's bad enough when the BEFVP41 was in ciruculation you couldn't get any proper tech support with, but now that it's not the "in" router anymore, you might as well us it to prop up cars in the front yard :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice