BEFW11S4 - firmware upgrade

Discussion in 'Other Linksys Equipment' started by scflyk, Apr 18, 2006.

  1. scflyk

    scflyk Guest

    Hello experts,

    I am having a BEFW11S4 (fw version, 1.50.14) and WUSB11v4. I have just performed a firmware upgrade to 1.52.02 for my BEFW11S4 and the upgrade were done successfully.

    However after the upgrade, my WUSB11s4 couldn't get connected anymore. Various settings have been tried on BEFW11S4 and WUSB11v4 just couldn't get connected. I have tried reseting my BEFW11S4 to factory default. After several attempts, I have decided to downgrade my BEFW11S4 back to ver 1.50.14. After the downgrade, my WUSB11v4 get connected again.

    My WUSB11v4 is connecting to desktop running Windows XP sp2, with driver version 3.110.513.2004.

    Any comment?

    Thanks in advanced.

  2. SeismicGuy

    SeismicGuy Guest

    I also need an expert for a similar problem. After flashing the BEFW11s4 V4 to the latest firmware, I had chronic problems with the wireless print server (it is a dlink 311p that is plugged into the parallel port of an HP printer and communicates wirelessly to the network via the Linksys router).

    After flashing the print server lost communications with the router several times--a power-cycle on the router would sometimes help. At other times, the printing would take forever, as if the information were being transmitted sporadically.

    I reflashed to the previous firmware and NO problems. I contacted Linksys tech support to see what might be happening with the new firmware and the wireless print server but they had no answers and no suggestions, other than to keep using the older firmware.

    Any "experts" out there with possible explanations?

  3. JimGoose

    JimGoose LI Guru Member

    Crappy firmware is the only explanation and I doubt Linksys will work on fixing it since it's probably not a major seller for them anymore.
  4. Dippo

    Dippo Network Guru Member

    I use the european version 1.50.13.
    That firmware seems to work quite well.

    The 1.52.02 version gave me nothing but problems.
    From what I have read, the 1.52.02 causes a lot of problems.
  5. Beftus

    Beftus Network Guru Member

    Firmware v1.52.02 gave me problems (lock-ups) too. I went back to v1.50.14 which was much more stable. Currently running v1.51.2 though I can't detect any differences to v1.50.14.

    It is IMO safe to assume that Linksys will not put a lot of effort in fixing the latest firmware revision for the BEFW11S4. It's a too old design by now and there's not much money (if any) to be made from it. The WRT54G is the big money maker at the moment. Which I'm likely to buy next month, a WRT54GL that is... :)
  6. dontdink

    dontdink Guest


    I, too, had problems after upgrading my befw11s4 to firmware ver. 1.52.02. You mentioned in your post that you "downgraded" to previous version (that's version 1.50.14 in my case, I believe). How exactly did you downgrade?

  7. Beftus

    Beftus Network Guru Member

    Just flash the previous firmware revision onto it.
  8. rjones

    rjones LI Guru Member

    BEFW11S4 Disconnect Firmware

    I have tried all the answers in all the threads and the only thing that will keep the BEFW11S4 from disconnecting is to revert back to firmware version 1.50.14.

    It is not published but you can get the older firmware from linksys at:

    Also download the installer at:

    Run the installer and point it to the downloaded .bin and your troubles will be over.

    No more disconnects, especially when downloading video. Thank you Linksys for not having the older firmware available where anyone can find it. Thank you Tech Support for not making this fix common knowledge. Admit it, version 1.50.20 is the cause of the disconnects.
  9. MauroM

    MauroM Guest

    Drivers for version 4?

    Where can I get the drivers for BEFS11S4 v. 4? They are not on the linksys website, and I can't find them. Thanks!
  10. kufi

    kufi Network Guru Member

    hi all,

    i've a befs11s4 v2.. and it's latest fw supports only WEP. What are the differencies between v2 and v4 ? Is it totally impossible, that i can use v4 firmware at my v2 ?

    update: i google my problem, and looks like, v4 is different hardware, unfortunatelly :(
  11. Landrover

    Landrover Guest


    As you can see it has taken me almost a year to find my way here and finally resolve the disconnect problems caused by v1.50.20. Followed your advice and rolled back to 1.50.14 and no longer have disconnects/hangs etc. during streaming video.

    What really is annoying is that it was Linksys Support that told me to upgrade to 1.50.20 when I called them in relation to a completely different problem with an adapter card in an older laptop.

    Anyways thanks again; although I know it's probably time to upgrade this older BEFW11S4 it serves my home networking needs quite nicely.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice