Belkin F7D4301 v1 - Tomato Options?

Discussion in 'Tomato Firmware' started by JBunselmeyer, Nov 23, 2013.

  1. JBunselmeyer

    JBunselmeyer Reformed Router Member

    I just picked up a Belkin F7D4301 v1 to replace my aging Linksys WRT54GL.

    What options to I have for Tomato? I've asked in the AdvancedTomato thread but haven't heard back. Since AdvancedTomato is based on Shibby can I use it? I prefer the GUI of it I think so if it's an option I'd like to try it first.

    Anyone using this specific router have suggestions on other mods that are the most stable for this specific router?

    Also, is there an "factory image" I can download before flashing any custom firmware so that I can restore it in the necessity of warranty replacement, etc.?

    Last edited: Nov 23, 2013
  2. salar

    salar Serious Server Member

    You can use tomato v 1.28 by a shibby latest 114 build. They are under Asus RTN builds.

    Be careful, you first need to flash a ddwrt mini.bin. search for it. You will find a detailed step by step procedure.

    Sent from my GT-S5670 using Tapatalk 2
    Last edited: Nov 24, 2013
  3. JBunselmeyer

    JBunselmeyer Reformed Router Member

    Perfect. Thank you!

    Sent from my Nexus 5 using Tapatalk
  4. jerrm

    jerrm Network Guru Member


    DO NOT bother loading a DD-WRT or Tomato .bin image on the 4301/8301, it is wasted effort. You can directly load a standard Tomato .trx image from the regular Belkin GUI (or the CFE mini server). We never bother with the CFE at all on the 4301/8301 and load the target tomato .trx image directly from the regular Belkin GUI.

    This is different from the 3301/3302/4302/7301/7302/8302 which do require a tailed .bin image for the initial flash. For those routers, we use Toastman's model specific mini .bin images for the initial flash. Not a particular endorsement of Toastman over Shibby or dd-wrt, just we first used Toastman, and keep an old set of his .bins around for the initial flash on these models before we move on to the current Toastman/Shibby/Victek version.
    Last edited: Nov 25, 2013
    salar likes this.
  5. asammar

    asammar Network Guru Member

    Just a word of caution on using RT-N builds with this router. I bricked a couple of 4301 devices when attempting to load them with RT-N builds (both Shibby's and Toastman's). RT builds work fine and, for some reason, they show both radios. This was back in Aug/Sep so the newer RT-N builds might be fine.

    I would suggest trying an RT build first and if it works (and shows both radios) then just stay with it. As jerrm mentioned, you can flash directly from the Belkin GUI.

    Good luck, and let us know how it goes.
  6. jerrm

    jerrm Network Guru Member

    All I've used are RT-N builds. I know I've loaded every Shibby build since 108 on a 4301. Most Shibby builds for the last 18 months or so. A few Toastmans through that period too, but not as extensive.

    The other Belkin routers do need RT only for Shibby 114/115. Not sure why yet.
  7. salar

    salar Serious Server Member

    I have a Belkin F7D3302 as well as a Belkin F7D4301, both of which were running on shibby RT-N builds till build 112. But when I upgraded to 114, F7D3302 could not accept it while F7D4301 is working fine. Shibby has noticed it, hope the next builds will be OK for F7D3302 as well.

    Sent from my TouchPad using Tapatalk
  8. JBunselmeyer

    JBunselmeyer Reformed Router Member

    OK. I should have some time the next few days to move from the stock Belkin firmware to AdvancedTomato.

    jerrm, you mentioned to me that from the AT search page I choose RT-N16 and then any of the builds less then 8MB should work. I know the RT-N16 has 32MB flash while the Belkin has 8MB. Do you mean 8MB

    Are you just meaning the actual .trx file is under 8MB? So in this case any of the bottom 3 (BT-VPN, Big-VPN or VPN)? And since this is the 4301 it's really as simple as just directly flashing the .trx I download in the Belkin GUI and then doing an NVRAM erase/reset? No need to worry about static IP, etc?

    Lastly, on the off chance I would ever need to return for warranty or anything is it just a matter of downloading the Belkin firmware and re-flashing it?
  9. jerrm

    jerrm Network Guru Member

    Should be that simple, but it's been a long time since I tested.
  10. JBunselmeyer

    JBunselmeyer Reformed Router Member

    Just flashed the latest AdvancedTomato with zero problems and loving it. Thanks for all of the help guys!

    Sent from my Nexus 5 using Tapatalk
  11. David Lawrence

    David Lawrence Reformed Router Member

    I just got a Belkin Share Max F7D4301 and I've never installed Tomato or DD-WRT on any device. Where can I find a detailed step-by-step install instruction for this router?
  12. zsero

    zsero Reformed Router Member

  13. ghoffman

    ghoffman LI Guru Member

    i use tomato-F7D4301-1.28.9013MIPSR2-RAF-V1.2e.trx from victek. works great.
  14. redsandvb

    redsandvb Network Guru Member

    I have an older version, 112, but yeah...that would be the one I'd use. I also have a belkin 8301, but from my understanding it's the same router as the 4301. One more thing, I'm using the Belkin as a wireless bridge and not my main router...not that it matters in this case.
  15. redsandvb

    redsandvb Network Guru Member

    Download the .trx file above, linked to by zsero. Or another build by Toastman, etc...
    Open the router's setup GUI, the pdf manual for my 8301 said http://router or
    Look for the section to upgrade the software (sorry, I forgot what it's called).
    When it asks you for the file, browse to the .trx you downloaded and select it.
    Tell it to upgrade (whatever the button's labeled, sorry I forgot)
    Let it do it's thing for about ~10 minutes, I forgot how long it takes.
    If asked for login/passwd enter admin/admin. I don't remember if you need to go to, but that'll be the new router / setup GUI's address by default.
    In the Tomato GUI (Shibby build) go to Administration--Configuration--Restore Default Configuration--select Erase all data in NVRAM memory (thorough). Click OK
    Wait another ~5 or 10 minutes.
    After that I also Rebooted it.
    Then setup your wireless settings, security, etc...
  16. r4nd0m

    r4nd0m Reformed Router Member

    I have Shibby's latest RT (Toastman's RT-N was very unresponsive so I flashed DD-WRT mini -> mega per instructions and promptly bricked it after the last 30-30-30. I was able to use jtag to rescue).

    Everything is rock solid but only problem is speeds are slow. LAN speeds seem slower than wireless.
    Can any of you run some tests to check your LAN and WAN speeds? ISP should be 30mbps but only getting 20 on wlan and 16-17 on lan. Also please post which version of firmware you are using.
  17. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    From my tests on Shibby v116, RT works very good but only in acces mode, if you need other modes, stick to RT-N... I use it in Wireless Ethernet Bridge so for me there is no other choice other than RT-N version, wich is rock stable.
  18. its0ry

    its0ry Reformed Router Member

  19. its0ry

    its0ry Reformed Router Member

    I tried and failed to load Tomato, but did succeeded in loading dd-wrt, as documented in here. In particular, I downloaded tomato-K26USB-1.28.RT-N5x-MIPSR2-116-VPN.trx (Shibby's build) and tried to load directly from the Belkin GUI, as recommended above. That failed with:

    Upgrade file is not the correct type or version for this device. Upgrade failed. Please obtain the correct file and try again​

    I also tried to load it from dd-wrt mini, but got the message "Upgrade failed". Oh well.
  20. jerrm

    jerrm Network Guru Member

    Are you sure it was a 4301/8301? That message is what I would expect from a 3301/3302/4302/7301/7302/8302. I've done a dozen or more 4301/8301s going directly to a standard .trx.
  21. its0ry

    its0ry Reformed Router Member

    Yup. Not only is that what the device itself says, DD-WRT also identifies it as "Belkin F7D4301 / F7D8301 v1"
  22. s44

    s44 Networkin' Nut Member

    I just flashed one directly to Victek from the stock web interface.

    Edit: didn't 30/30/30, just a full NVRAM clear after the Victek-flashed GUI finally became accessible.
    Last edited: Feb 18, 2014
  23. quihong

    quihong Networkin' Nut Member

  24. salar

    salar Serious Server Member

    I have flashed shibby RT-N 116 and it seems ok, though I haven't seen the performance.

    Sent from my Lenovo A820 using Tapatalk
  25. satuday

    satuday Serious Server Member

    i tried a few different build with F7D4301, all seems to have problem with 2 of the lan port. any one else have this problem? any fix?
  26. mw333

    mw333 Networkin' Nut Member

    Not sure what you mean (2 of the lan port). The only "issue" that I've come across is the vendor did not wire up the Ethernet ports the way I expected, e.g. in the switchport (logical) order.
  27. satuday

    satuday Serious Server Member

    the 2 Ethernet port close to the usb ports, they dont work. always no connection on anything i plug in to those ports.
  28. Retronite

    Retronite Networkin' Nut Member

    We're they working with the original Belkin stock firmware before you upgraded to Tomato RAF?

    I have 2 x Belkin F7D4301 routers, one has Tomato and the other with the stock firmware. Both uses all the ports perfectly. Belkin has labelled up the ports on the router incorrectly though. 1 to 4, top to bottom printed on the casing but they're actually 4 to 1 top to bottom printed on the actual board. Bear that in mind.

    I am getting a bit of instability with Tomato RAF at the moment as it randomly resets itself, more so when I access the GUI on Tomato. The syslogs also seem to get erased so not entirely sure what is causing it. Not yet tested whether it's a hardware or firmware issue. Will update my findings when I manage to get round to it.
  29. stillsober

    stillsober Reformed Router Member

    Just moved my voip phone with the bottom lan, can call ok. shibby 1.28. tried just connected one lan at a time? I only have the voip phone connected so i cant test multiple lan at once
  30. Xegot

    Xegot Network Newbie Member

    Anyone tried the new Shibby build 117 RT-N build (fixes heartbleed) on the F7D4301?
    If it works okay which exact firmware file did you use?

  31. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    Yes it works... Here is the Nocat version link
  32. salar

    salar Serious Server Member

    Hi Mihai !
    Does the new Shibby build 117 RT-N build works on Belkin F7D3302 router ?
  33. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    Belkin F7D4302 Belkin Play N600:

    K26RT-N haven't tested yet but there is no one in Tomato Anon using it and there was no fix applied regarding that, Shibby said that he is still investigating...
    I still use v112RT-N.
    K26 117 works with the problems I already mentioned... (sadly not suitable for my connection) Wireless Ethernet Bridge makes Virtual Wireless not accesible! I've seen something remotely similar in a bug that is fixed ONLY in RT-N, so it's possible that v118 or V119 whatever comes next for MIPS would allow that!

    Belkin F7D4301 Belkin Play Max N600:
    I use K26RT-N Nocat it works like a charm!
  34. stillsober

    stillsober Reformed Router Member

    should I be worried about heartbleed if I'm not hosting anything? i.e. nothing's accessible from wlan side
  35. Nlhaines

    Nlhaines Network Newbie Member

    I just picked one of these up. The only features I care about are VPN. Which build should I be flashing? Sorry for the noobish question, but I'm a bit overwhelmed by all the builds/options.
  36. Nlhaines

    Nlhaines Network Newbie Member

    I flashed the Nocat version that Mihai suggested and it is great! Now if I can just get my dlink 860L to work as a repeater or bridge I'll be all set.
  37. Mojonba

    Mojonba Network Guru Member

    Jerrm is right. I flashed the latest Toastman build from the CFE and it worked perfectly. Remember to use Internet Explorer and not Firefox.
  38. tonygod

    tonygod Network Newbie Member

    Just reporting in that I had success installing Shibby's v124 build on a Belkin Play N600 F7D4302 v1. After a bunch of searching around, I found this thread and then poked around on and eventually found a build that worked on this router. Note that this build is in a "Belkin (Untested)" folder, so I expect there are bugs. I have been running for a day with no issues that I have noticed so far.

    Link: tomato-F7D4302-1.28.RT-N5x-MIPSR2-124-Mini.bin

    It was just an upgrade from within the Belkin admin GUI and it even kept all of the router's previous configuration settings. Much better than stock firmware!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice