Belkin F9K1102: Tomato bring-up

Discussion in 'Tomato Firmware' started by mdmower, Jan 29, 2015.

  1. mdmower

    mdmower Connected Client Member

    The original first message of this thread, when tomato was not yet ported, can be found at the bottom of this post. Tomato is now operational on the F9K1102 (v1 and v3 only), so I've changed the first post to reflect this.

    Tomato has been ported to the Belkin N600 DB Wireless N+ (F9K1102 v1 and v3 only). A screenshot is attached to this post. Unfortunately, stability has been an issue; frequent reboots have been reported by several users. This project is on hiatus as I have not been able to resolve these issues myself. Other experienced developers are encouraged to pick up from where I left off (see source links below).


    (downloads removed due to instability) - firmware images are in folders named after the branch from which they were built. They are versioned by date in the filename: 1.28.YYYYMMDD
    Compilation options for most recent firmware image:
    1. Flash the firmware image through the stock firmware web interface.
    2. A slowly flashing blue light is illuminated during the boot process, then both blue and orange lights simultaneously flash before all lights turn off. A moment or two later, either a steady orange light (if no WAN connected) or an active purple light (if WAN connected) appears. The LAN and WiFi networks should be available shortly after.
    3. [Toastman-based only] DHCP is not enabled by default, so configure your computer with IP address, subnet mask, and gateway Then you should be able to connect to the router.
    4. Open the web interface: The default username and password are admin
    5. Navigate to Administration > Configuration, and under Restore Default Configuration choose Erase all data in NVRAM memory (thorough). The router will automatically reboot after clearing nvram.
    6. Once the router has finished booting, you should be all set.
    Known issues
    1. [shibby-based] Some users report frequent reboots to the point of the router being unusable. In some instances, settings have even been lost. This doesn't seem to be universal though -- I still need to narrow down what may be causing this to happen.
    2. [Toastman-based] Only one wireless radio is enabled for now. I haven't looked at how multiple radios are enabled in the Toastman-RT-N branch yet.
    Source code

    I have been working with the tomato-shibby-RT-AC and Toastman-RT-N branches at My changes are on GitHub: Each download has a corresponding tag.

    Additional information

    Stock firmware serial console output: F9K1102v1 and F9K1102v3
    Stock firmware nvram dump: F9K1102v1 and F9K1102v3

    Original thread starter, from Jan 28, 2015:

    I am trying to bring-up tomato on the F9K1102v3. I familiarized myself with the changes that went into another router I own, the F7D3301, and it seems like there's not too much to configure. It looks like I need to know a few variables from the nvram though (boardtype, boardrev, boardnum, vlan1ports, vlan2ports). Unfortunately, I cannot figure out how to telnet into this router while it's running stock. Are there any tips on how to do this? Or is JTAG necessary?

    Attached Files:

    Last edited: Apr 1, 2015
    Traace, filipedonato, z3ntu0 and 4 others like this.
  2. Mr.CTT

    Mr.CTT Serious Server Member

    I would assume JTAG is the only way Via stock to do that.
    I did find this in my google search

    some useful stuff

    same only more (may be specific enough for you to use)

    people trying to learn more about this model

    probably 90% useless DDWRT posts

    DDWRT's and OpenWRT's hardware lists do not say anything about this model man. Im betting poping it open is your best chance

    I hope that helps you out some man
    Last edited: Jan 29, 2015
  3. mstombs

    mstombs Network Guru Member

    Get serial console working first - the board in the FCC photos appears to show a 4-pin header already fitted. 3.3V serial console very useful for router development.
  4. mdmower

    mdmower Connected Client Member

    Thanks for the tips. I put in a GPL software request with Belkin for the source corresponding to firmware 3.04.06. Hopefully I can glean some info from there (assuming they get back to me). I may have been a bit naive in thinking this could be done without opening the case.

    There's quite a bit of info on the F9K1102v1 (including nvram dump) which appears very similar in the FCC photos:
    So it may be worth trying to use v1 as a source of info for now.
  5. Mr.CTT

    Mr.CTT Serious Server Member

    I think that they both use different processors if i remember correctly. I have a WNDR3400v1 here that shares much of the same hardware as the v2, but the v2 firmware would not load onto the v1 using JTAG Serial. Based on that, I do not think that you will be able to do what you want the way you are attempting to do it. I believe you will need to do a significant amount of modification to someones firmware.

    When i searched I tried looking under DDWRT, Open WRT, Shibby, and Hyzoom's router lists. It was not listed so i am fairly certain noone supports it but i could be wrong.
  6. mdmower

    mdmower Connected Client Member

    I had reasonable success with this last night. I bought an inexpensive usb-tty device and updated the F9K1102v3 wiki with stock firmware serial console output (and nvram dump). The differences between F9K1102v1 and F9K1102v3 are insignificant; a single build should work fine on both variants.

    Tomato is up and running, but there are still a few to-do items:
    1. buttons (reset, wps) don't work yet -- Based on the stock nvram dump, I'm pretty sure I just have to set reset_mask and ses_mask to the gpios for reset and wps, respectively (will try this when I return home tonight):
      reset_mask = 1 << 3;
      ses_mask = 1 << 7;
    2. (non-issue) leds appear to work, and I'm baffled as to why they do without any configuration in led.c. I still want to test a bit more to make sure they are behaving as expected.
    3. 5G wireless doesn't work yet --
      a. requires a revert of update/add new 3G modem modules to be able to compile with USBAP=y (I've seen this discussed in another thread, so not specific to this router)
      b. I've made some preliminary changes to set wl1_hwaddr, lan_ifnames, landevs, and wl1_ifname during init, but still haven't managed to make eth2 available.
    Anyways, this has been a fun little bring-up so far.
    Traace likes this.
  7. shibby20

    shibby20 Network Guru Member

    Congrats :)
  8. Mr.CTT

    Mr.CTT Serious Server Member

    Nice, I'm glad you got it working. Keep updating as you go, if you get it working i am sure there is a couple people out there that would love have this on theirs, but that is up to you if you are willing to hand out your work.
  9. mdmower

    mdmower Connected Client Member

    As is the case with bugs, when you fix one, you introduce two.

    Setting the ses_mask for the wps button works fine, but I have not yet managed to find a working reset button configuration. Setting reset_mask = 1 << 3; just causes bootloops. Running gpio poll doesn't show any activity when reset is pressed.

    I have both 2.4GHz and 5GHz radios up and running simultaneously now. The mac addresses for all of the hardware devices needed fixing though. I'm not sure if et0macaddr is typically supposed to be retained when flashing from stock to tomato, but in any case it isn't correct during init. Perhaps this is due to Belkin using dashes instead of colons to separate characters in et0macaddr and sb/1/macaddr. So, I wrote a little function to pull the mac address from /dev/mtd0 and now I have correctly set mac addresses during init, in increasing order, for lan, wan, wlan0, wlan1. But all is not rosy, as I've somehow lost the ability to network with the router over lan ports (connecting via either wlan0 or wlan1 works though).

    Those interested can take a peek at my work-in-progress commit.

    EDIT: Oh, I may have misinterpreted the necessity of the break on L684 of release/src/router/rc/init.c. I suppose that might actually need to fall-through for those routers. I previously had F9K1102 added to that list, and I wonder if the LAN issues stem from me never setting vlan2hwname=et0 during init.... more to try when I return home tonight.
    Last edited: Feb 4, 2015
  10. mstombs

    mstombs Network Guru Member

    Your nvram dump says

    which I recall is generally used by Broadcom CFE bootloader - rather stupidly in my opinion because it is a reason why the reset button sometimes doesn't work when nvram corrupted!

    Don't know the relationship to reset_mask though...
  11. mdmower

    mdmower Connected Client Member

    @shibby20 - I have this up and running pretty well now. Is there a chance this could be merged?

    Add Belkin F9K1102 (v1/v3) support - obviously you don't want to pull the revert of update/add new 3G modem modules on which it depends, but I kind of need that revert to compile dualband support.

    The outstanding issues are described in the commit message. Repeated here:
    1) After wiping nvram and rebooting, a subsequent reboot is necessary for LAN to be setup correctly
    2) Reset button does not work

    I've tested LAN, WLAN 2.4GHz + WLAN 5GHz with and without WPA2 Personal security, OpenVPN, and USB Storage. All are working well.

    The WPS button works fine, but reset does not. While I could see gpio 7 changing states when I toggled the WPS button (using gpio poll), I could not find any gpios changing state when reset was pressed. I even extended the gpio program to poll out to gpio 32 (as opposed to the current limitation of 20), and still did not see anything.

    The LED works perfectly fine without any configuration. Technically, I can control the LAN/WLAN activity LED with gpio 5, but it is not required in router/shared/led.c to work correctly.

    EDIT: See Post 1 for firmware image.
    Last edited: Feb 6, 2015
    Traace likes this.
  12. Rajiv Mishra

    Rajiv Mishra Network Newbie Member

  13. mdmower

    mdmower Connected Client Member

    WPS and Reset buttons fixed. They will be functional in release 20150207, which will be posted later tonight.
  14. Mr.CTT

    Mr.CTT Serious Server Member

    congrats man. I wish i could help out more, but I can barely keep up with my networking stuff. One of these days, i would really like to do what your doing. Kudos.
  15. shibby20

    shibby20 Network Guru Member

    sure :)
  16. mdmower

    mdmower Connected Client Member

    I just posted 1.28.20150207MIPSR2MDMower. Both the buttons issue and the requirement of two reboots for LAN to be setup correctly are resolved. Now it's up to others to tell me what's broken.

    @shibby20 - if you've already pulled in my changes, please re-sync . I know there are a number of commits specific to just one router, so feel free to squash them if you prefer.
    shibby20 likes this.
  17. Thiago Tognoli

    Thiago Tognoli Network Newbie Member

    mdmower ,

    I tested the 1.28.20150207MIPSR2MDMower firmware on my F9K1102 v3 and he was very unstable. after changing the ip BR0 restarted several times to be able to access the router, and the IP has not changed.
    I appreciate your work, but I believe that there remains some details to have it working properly.
    I ended up returning to stock firmware if you need to get help available.
  18. mdmower

    mdmower Connected Client Member

    Just to be sure the image I posted is okay, I flashed stock firmware, ran factory reset, then flashed the image I posted. It worked just fine. There's a couple things you might try/consider:
    1. Use Firefox with all add-ons disabled to flash the firmware
    2. Stock firmware sets the router's IP as Tomato uses If you leave the network cable plugged in, then your computer may not re-negotiate a new IP address after Tomato boots. So, after flashing Tomato and waiting a long time for the router to settle (steady orange light if nothing is hooked up in the WAN port), you can do one of the following:
      - disconnect the network cable, wait 10 seconds, then reconnect
      - disable the network adapter on your computer, wait 10 seconds, then re-enable the adapter
    If it still causes trouble, then it may be that the hard-coded MAC on /dev/mtd0 is not at a universal location. You can check this pretty easily.
    1. Do whatever you need to do so that you can reach the router's web config (
    2. On the Overview > Status page, there should be several MAC addresses listed. If any of them begin with 00:90:4c, then the MAC is not being picked up correctly.
    3. IF this is the case, you can try this testing firmware image [source] (be sure to check the box to clear nvram after flashing).
    Last edited: Feb 16, 2015
  19. Thiago Tognoli

    Thiago Tognoli Network Newbie Member

    Thanks, I'll try later and I report to you.
    One thing I missed was the minidlna and nfs, would not be possible to firmaware with both?
  20. Thiago Tognoli

    Thiago Tognoli Network Newbie Member

    Yes, my mac is:
    WAN (hide)
    MAC Address 00:90:4C:01...

    But neither the test firmware link solved, I went back to stock firmware, thank you and look new instructions or updates
  21. mdmower

    mdmower Connected Client Member

    Something really doesn't seem right here. That test firmware was pretty robust in searching for a MAC.
    1. What stock firmware version are you coming from?
    2. Did you take my advice to flash using Firefox with all add-ons disabled?
    I'd really like to see what's distinct in your router. Can I get a copy of the bootloader?
    1. Install the the most recent tomato firmware I linked for you
    2. Navigate to Administration > Debug and click "Download CFE"
    3. Provide me a with a link to the file (you can PM me if you prefer)
  22. Thiago Tognoli

    Thiago Tognoli Network Newbie Member

    Yes, I followed all instructions. I installed the firmware tomato-K26USB-1.28.20150209MIPSR2MDMower-F9K1102-64K.
    Last edited: Feb 11, 2015
  23. mdmower

    mdmower Connected Client Member

    I couldn't really understand your reply. Punctuation could help.

    I uploaded a newer firmware (20150210) which improves MAC addresses verification. The only thing I can imagine is affecting your device is if any of boardtype, boardnum, or boardrev are detected differently than the router I have on hand. To diagnose this, I need cfe.bin from your router.
  24. Thiago Tognoli

    Thiago Tognoli Network Newbie Member

    I installed the tomato-K26USB-1.28.20150210MIPSR2MDMower-F9K1102-64K firmware, but remains unstable, my Mac is still 00: 90: 4C: 01 ...

    I sent in PM the CFE.

  25. mdmower

    mdmower Connected Client Member

    Thanks for sharing your bootloader. It helped a lot. I found a common address in our bootloaders where the MAC is stored (different from what I was using before). I hope this resolves the issue for good. I was also able to confirm that boardrev, boardnum, and boardtype are all correct.

    I've enabled NFS and MEDIASRV in the newest firmware (1.28.20150211MIPSR2MDMower). They increase the size quite a bit, so I can't guarantee they'll always be available if tomato grows in the future, but for now they fit.
  26. Thiago Tognoli

    Thiago Tognoli Network Newbie Member

    Mac for wan and lan worked properly, but for wireless eth1 and eth2 initially came with the MAC 00: 90: 4C, after I erase all NVRAM all MAC work fine.
    However, after I change the br0 network to and save, the router becomes unstable, I had to disconnect and reconnect the power, then he worked in the new ip for a few seconds and stopped working, disconnecting and reconnecting the power back he returns to the IP, and remains unstable after disconnecting and reconnecting the cable it works for a few seconds and lazy loop working.
    I believe it is on the right track, but still can not run your firmware.
    Thank you so far, and hope to continue helping with whatever you need.
  27. mdmower

    mdmower Connected Client Member

    Can you say a bit more about your usage scenario? Or the steps that you're taking in your configuration?

    Under Basic > Network, I changed the router's IP to and the DHCP addresses to - After saving, I disconnected from the router, waited about 10 seconds, then re-connected to get a new IP. The router hasn't shown any instability.

    Are you maybe changing Advanced > Routing, without putting the router's IP on the same subnet? After changing the router's IP at Basic > Network, it automatically adjusted the subnet at Advanced > Routing for me. Screenshots attached.

    Attached Files:

    Last edited: Feb 12, 2015
  28. mdmower

    mdmower Connected Client Member

  29. Thiago Tognoli

    Thiago Tognoli Network Newbie Member

    I changed only the br0, as in your first image, not changed routing. The strange thing is that after become unstable with the new IP, and disconnect and connect the cable the original IP back.
  30. JustinFreid

    JustinFreid Network Newbie Member

    Hi mdmower - thank you for your work and for making my friend's Belkin N600 useable.

    Please let me know if there's anyway I can help.

    Thanks again.
  31. godmachine81

    godmachine81 Network Newbie Member

    Glad to find this post, was linked to it from my fellow friends in ##slackware . I own the v2 of the f9k1102 is there a working tomato release for it yet? I understand that currently only v1 and v3 are supported right? If there is anything I can do to help compile a custom firmware for v2 please let me know. I am experienced with this type of thing just not with tomato in particular so I might be able to provide some help since I'm actually seeking an alternative to the stock firmware and I own the same device I'm seeking the firmware for. Please reply here and if you IRC come on over to ##slackware on freenode or PM godmachine81 either one. Thanks guys!
  32. mdmower

    mdmower Connected Client Member

    F9K1102v2 uses a Realtek processor and lan/wlan chips which, as far as I know, TomatoUSB does not support.
  33. SuperDuper

    SuperDuper New Member Member

    I've got a 1102v3 and it is very unstable with the tomato-K26USB-1.28.20150213MIPSR2MDMower-F9K1102-64K.trx firmware. Even after resetting nvram and returning to defaults, it just doesn't want to work.

    Here are the issues I've noticed:

    It often resets back to it's defaults randomly, resetting it to
    It refuses to enable any ethernet ports unless it has a working internet connection on the wan port, and instead restarts in a loop over and over until a working internet connection is found.
    It freezes often, refusing to respond when accessing it via the web or via telnet
    after resetting nvram, it restarts but doesn't work unless you unplug it and plug it back in.

    I've changed my modem's lan ip to so the router could have 1.1 but that didn't work.
    I changed the router lan ip to that worked a little better but it still froze and sometimes reset on it's own.

    Thanks for the effort but it's still very unstable and unusable at this point.
  34. mstombs

    mstombs Network Guru Member

    @SuperDuper that won't work well with any router - change the modem or router network ie modem to, otherwise router gets confused about how to separate lan and wan!
  35. maxxhaxx

    maxxhaxx New Member Member


    Flashed this onto my f9k1192v3 today, followed instructions (cleared nvram) then configured (basic settings, pppoe on WAN port, wifi ssid,WPA2 security & mac address based access restrictions for the kids devices for at night time).

    was working flawlessly, but after about 3 hours it dropped connection then restarted, was still ok but then after 47 minutes it dropped out again, after a few minutes it reconnected then only lasted a few minutes.

    After it finally came back up it lost all settings and i had to reconfigure the router. Funnily enough while i was typing this in it dropped connection again, but kept the settings. will check again in the morning but it seems this firmware has some stability issues.
  36. maxxhaxx

    maxxhaxx New Member Member


    after further testing i had to go back to the belkin firmware. it got to the point where the router was rebooting itself every 30 minutes (give or take a few minutes)
  37. SuperDuper

    SuperDuper New Member Member

    @mstombs, Would you explain your beef with using a /30? I mean I could do as you suggest and it would work, but you would be wasting most of the entire /24 address space. That doesn't seem like an optimal idea. I think I'd rather stick to my /30 and /25 to minimize that loss. Why would you want to waste all of that addressable space? Or is there a firmware bug in tomato that I'm not aware of? Any properly working router should have no problems being configured in this manner.

    It appears that maxxhaxx is having the same problems I am, I have returned to the crappy belkin firmware as well :(

  38. mstombs

    mstombs Network Guru Member

    I do not understand what you are saying with regards to netmasks - are you not using "nat gateway" mode on the router?
  39. mdmower

    mdmower Connected Client Member

    Whelp, these reports of frequent reboots don't sound good. I'll have to see if something in particular is triggering it, as I haven't experienced the same. Admittedly, I'm not using this router often, so my testing has been limited.

    In the meantime, I ported the changes to @Toastman's branch: Toastman-RT-N. A firmware image has been uploaded and source code is posted (see first post). Let me know if you have better luck with stability.

    A few notes about the Toastman-RT-N build:
    1. DHCP is not enabled by default in Toastman-RT-N, so manually set your IP, subnet mask, and gateway to connect to the router after flashing
    2. If you're coming from the shibby-RT-AC build, the 'erase nvram after flashing' option isn't 100% reliable. Definitely run factory reset with nvram erase after flashing this build.
    3. Only one of the wireless radios is enabled for now. I haven't yet looked at how he handles multiple radios.
  40. mdmower

    mdmower Connected Client Member

    Hmm, I concede, there are some real issues here. With the most recent Toastman-RT-N-based build I posted, the LAN ports closest and farthest from the WAN port are basically unusable, causing almost instantaneous reboot-loops when populated. Interestingly, I had reasonable stability with the 2nd port from WAN (didn't test 3rd port down). I find myself with too many projects these days... sigh. Will try to revisit this though.

    EDIT: I suspect the issues described here can probably be rectified with vlan port ording change. I'll check this tonight.

    EDIT 2: Unfortunately, stability has been an issue with my releases; frequent reboots have been reported by several users. This project is on hiatus as I have not been able to resolve these issues myself. Other experienced developers are encouraged to pick up from where I left off (see source links in OP).
    Last edited: Apr 1, 2015
  41. Humberto Fioravante Ferro

    Humberto Fioravante Ferro New Member Member

    just to let you know: my router Belkin N600DB (F9K1102 v3) was just flashed with your firmware and it is working fine (no reboots). I replaced the original firmware so that I could access a VPN provider and then start streaming from abroad, which was not possible with the original settings. So far so good - thanks for making your hard work available to us, mdmower!
    Greetings from Brazil!
    Humberto Fioravante Ferro
  42. greytear

    greytear New Member Member

    Thank You so much for your effort.
    I recently flashed a Belkin f9k1102as v1 with the latest image file (20150213), following the instructions on your first post. I must admit i was getting a little worried when i flashed it for the first time (bricking the router, etc). It flashed OK and I got some stability issues: the reboots rerported from some users. I flashed it again, cleared the NVRAM thoroughly, and crossed fingers. Apperently everything is OK.....except....

    I bought this router second hand. Even with stock firmware i was getting some connection losses (wired connection). So, i tried your build, to see if this could be a firmware issue. But i'm still getting some drops, and connectivity issues.

    Checked all cables, and everything is good. Could you please give me a hand on this?
    BTW, the log files have some very annoying lines:

    May 8 13:38:50 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:50 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:50 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:50 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:51 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:51 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:51 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:51 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:51 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:51 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:52 unknown user.warn kernel: printk: 449 messages suppressed.
    May 8 13:38:52 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:38:54 unknown cron.err crond[514]: time disparity of 23851417 minutes detected
    May 8 13:38:57 unknown user.warn kernel: printk: 444 messages suppressed.
    May 8 13:38:57 unknown user.warn kernel: nf_conntrack: table full, dropping packet.
    May 8 13:39:02 unknown user.warn kernel: printk: 475 messages suppressed.

    Do you know what this is about?
    Best Regards,
  43. r80xcore

    r80xcore New Member Member


    I own a F9K1102v1 that i recently installed your version of Tomato on.

    I believe that the reboots are caused by overheating of the CPU. This even happens with the stock firmware from time to time, especially when i stream in my home network from 5GHZ to 2.4GHZ wireless.

    My AD/HD told me to pull this open and I installed a heatsink on the CPU and now it never reboots with tomato installed. I even overclocked it to 580Mhz. Gonna slap on a even bigger heatsink and a fan next week and try to get it over 600Mhz just for fun.
    In Tomato it still says 530Mhz but when i SSH "nvram get clkfreq" i get 580Mhz.

    This firmware rocks and i think you should try to install a heatsink and then continue the development!

    Thank you for all your hard work!

    EDIT: it seems that I'm not able to overclock at all. Further testing shows that clkfreq don't change anything. After reading it also seems that broadcom changed the stable frequency for bcm5357 to 480mhz. I would like to be able to overclock/underclock. Does anyone know how I can make it work?
    Last edited: Mar 6, 2016
  44. fruitman

    fruitman New Member Member

    That's great! But I can't try that since the download links were removed unfortunately. Hopefully he will re upload them!
  45. Roy gallo

    Roy gallo Network Newbie Member

    Just tracked down this version today and props to you for the release. I got the router for 7 bucks at goodwill and was unable to make it a repeater til today. Many thanks. Would there be any more current releases other than 0211
  46. Roy gallo

    Roy gallo Network Newbie Member

    Sorry here's the version 1.28.20150213 MIPSR2MDMower K26 USB F9K1102-64K. So far nothing negative to report
  47. Rmcoelhos

    Rmcoelhos Reformed Router Member

    Hi Roy gallo, thanks for your report. Where did you download the firmware file from? Are you using the USB port to share either an HD or an USB printer?
  48. Roy gallo

    Roy gallo Network Newbie Member

    Ive used the usb port just to verify it was functional but that's it. My printer is wifi and works fine. Here's the link . its in this thread all you had to do was read. Hopefully mdmower has compiled some newer versions but the versions at that link are rock solid. No overheating or reboots. Have fun
  49. Rmcoelhos

    Rmcoelhos Reformed Router Member

    Hi Roy gallo,
    You are right, the link is in this thread, but since there were reports of instability and Fruitman mentioning that the links were removed, I thought you had yet another link or perhaps a different version. Anyway, thanks again for your help!
  50. Roy gallo

    Roy gallo Network Newbie Member

    Yeah I was reading this. That didn't come out the right way sorry about that
  51. Roy gallo

    Roy gallo Network Newbie Member

    update: tomato-K26USB-1.28.20150213MIPSR2MDMower-F9K1102-64K.trx
    after running it for about a month now the only problem is it reboots once or twice a day for no apparent reason. Since it doesn't do too much ive learned to accept it. It would be super nice if there was an updated firmware produced even with the current problem. hint hint. cheers to the mdmower man for his work
  52. Roy gallo

    Roy gallo Network Newbie Member

    further update : popped a small muffy in there over the chipsets and reboots are a thing of the past. been rock solid since thursday.
  53. Roy gallo

    Roy gallo Network Newbie Member

    I compiled 20150328 and installed it. There doesnt seem to be a 5 ghz branch though. Was wondering if that was done by design or something went wrong?
  54. Rmcoelhos

    Rmcoelhos Reformed Router Member

    Hi @roy-gallo, thanks for your reports. Looking at the 20150328 source file size I see that it is almost half the size from the previous packages (287MB vs 469MB). Maybe this latest package doesn't include some files that were not modified from previous version and that you can leverage on this newer version (i.e. you can extract all files from the previous version to a folder then extract the 20150328 version over it overwriting only the modified files). This is just my guess, I have never compiled a firmware before, so please don't get my comments as a true statement, again is just a guess.
  55. Roy gallo

    Roy gallo Network Newbie Member

    yeah that kind of got by me. guess it was a wip. Processor on it is very flaky and it started to constantly reboot so I put it on the shelf. had a lot of promise but I guess it won't be receiving any more updates. shame though would've loved to see it fully functional. one day ill try to learn how to work on firmware ;)
  56. ssssss

    ssssss New Member Member

    Hi there. I'm a newbie with not much experience in third-party firmware. I'm confused on what version of the firmware I should be downloading off the Shibby or Toastman sites. I'm trying to turn this router into a bridge/extender. Advice?
  57. gus8313

    gus8313 New Member Member

    Techie007 and t0m@t0 like this.
  58. dakotahorse24

    dakotahorse24 New Member Member

    So, I want to make sure. The main reason I am looking for 3rd party firmware, is that we are on a satellite connection limited to 10gb a month, and we keep going over. I am looking to be able to track and see where the Hog is. Will this help with that?
  59. Rmcoelhos

    Rmcoelhos Reformed Router Member

    Hi Gus8313,

    Thanks for your update! Can you confirm to us what are the benefits of adding this line to the code? Is it only related to the support of 3G sticks or does it also affect the Printer and Storage sharing?

  60. t0m@t0

    t0m@t0 New Member Member

    Hi! I was using DD-WRT until I broke the antenna on my old d-link..

    i was given a Belkin F9K1102v1 , couldn't find any DD-WRT for it--so after I found this thread, it became my first Tomato, and i'm glad because i really like Tomato now :)

    Maybe time to get new router [a new Tomato], though the tomato-K26USB-1.28.20150213MIPSR2Gus-F9K1102-64K.trx [see link above, in Gus's thread] has been working quite well--I do seem to have to reboot, or at least 'renew' the WAN IP sometimes, but i've played with the settings a bit and it seems to be getting better..

    I'm just wondering, any chance of an update/upgrade?
  61. Trilyan

    Trilyan New Member Member

    I think the router reboots because it gets too hot.

    I have put a floor fan beside it and it remained active with full bandwith for quite long hours.

    Took the fan out and had some random freezes.

    Any chance of undervolt with tomato?

    I got a cheap deal for 3 of this babies... gotta find some use for them now xD
    Last edited: Dec 20, 2017
  62. Techie007

    Techie007 Networkin' Nut Member

    I ended up with one of these routers (F9K1102v3), and figured it would be no problem for me to glue a heatsink onto a chip if needed--I've had to do it before! Anyway, at the moment, without any modifications, it seems quite stable with one exception: If I plug a device into port #4, the router always resets to factory default NVRAM and reboots when I unplug the device (or the connected device is turned off).
    That's when I noticed something: The LEDs are not working normally with the Tomato firmware. Normally, the LEDs are rather static, indicating WPS readiness, connectivity to the Internet, power state, and so on. However, on the Tomato firmware the LEDs are as follows:
    • Small/Blue: WAN conn/act
    • Small/Orange: 2G act
    • Large/Blue: LAN1 conn/act
    • Large/Orange: LAN2 conn/act
    That leaves LAN3, LAN4 and 5G without visible LEDs. Keep in mind that this router was never designed to have individual LAN connection/action LEDs in the first place. Is it possible that the faulty logic in led.c could be hitting a "reset NVRAM" register when turning out the LAN4 LED?

    I'm running Windows and don't know how to compile this firmware myself. Does anyone here want to test my theory by disabling the LEDs? Or are there commands I could execute during operation that would disable the LEDs? @mdmower @Roy gallo @gus8313
    filipedonato likes this.
  63. z3ntu0

    z3ntu0 New Member Member

    I've compiled a new version today using the latest code from the tomato-shibby-RT-AC branch. It's available at --I can't post links yet as my account is too new and I don't have enough posts yet ; to find get it go to my github profile (username z3ntu on github), repository name tomato, click on releases and you find it there-- along with the source code I used to build.
    Unfortunately the build doesn't contain NFS and USBAP compared to the build from @mdmower. It also doesn't contain
    USBEXTRAS which is apparently used for 3G sticks (according to @gus8313) as I don't have one to test it with. The functionality I am using is still working in my limited time running it. Have fun!
  64. filipedonato

    filipedonato Connected Client Member

    I did not find it. It's still available?
  65. Techie007

    Techie007 Networkin' Nut Member

    Yes it is. Visit and click the Releases heading to download the firmware.

    @z3ntu0 Thank you for the release... I'll test it in a few days when I have more time.
    filipedonato likes this.
  66. filipedonato

    filipedonato Connected Client Member

    My God, I was reading this topic that is unique on the internet and I was thinking that there were no more hopes.
    We have a CUSTOM TOMATO FIRMWARE for the Belkin N600 on January 13, 2018.
    Techie007 likes this.
  67. jgb123

    jgb123 New Member Member

    I have the v3. With tomato-K26USB-1.28.20180113MIPSR2-z3ntu0-F9K1102-64K.trx I'm not seeing eth2, but I am with tomato-K26USB-1.28.20150213MIPSR2Gus-F9K1102-64K.trx .
  68. filipedonato

    filipedonato Connected Client Member

    I installed this week the newer version of Z3NTU
    I took advantage of it and opened the router to put a heatsink on the chip, it really warms up a lot.
    But the custom firmware did not like it because I use the 5.8G network a lot and also wanted the guest wifi to watch the connected clients. Beyond USB.
    So I went back to the original firmware, just doing the flash normally.
  69. Roy gallo

    Roy gallo Network Newbie Member

    holy crap i cant believe this really happened. ill be testing it this week lol. big thanks to the z3ntu0 man
  70. Roy gallo

    Roy gallo Network Newbie Member

    well gus' image is rock solid but the router reboots still, probably still overheating, was able to get a download speed on 5ghz of about 80Mbit not to shabby, onto the z3ntu0 build and see what happens with that will post results in a cpl days
  71. Roy gallo

    Roy gallo Network Newbie Member

    well that didnt take long. lol i flashed it 3 times and wiped the nvram, 5ghz radio is gone. anyone have any insights
  72. filipedonato

    filipedonato Connected Client Member

    It's because they have not been able to activate the 5G radio yet.
  73. Roy gallo

    Roy gallo Network Newbie Member

    Gus' firmware seems stable enough. Ive put a heatsink on the processor that gave me 16hrs then the reboots started again. Mark this one in the books as the little router that couldnt. Too bad i get better transfer rates with this one over my other n600 routers
  74. Monk E. Boy

    Monk E. Boy Network Guru Member

    If you have to put a heatsink on it you might be able to underclock it to get the heat down, though then you could run into timing issues.
  75. Roy gallo

    Roy gallo Network Newbie Member

    appreciate the input but i packed it away and am officially giving up on it. moving on to a looped netgear r8500 from ebay to entertain myself. ;)
  76. kwmkwm

    kwmkwm New Member Member

    I get a boot-loop when anything is plugged into port 1 (or 4 depending on how you number them). The other ports work, but the device becomes unusable when port 1 is connected. using
    Last edited: Feb 15, 2018
  77. jgb123

    jgb123 New Member Member

    Release 1.28.20180226MIPSR2jethrogb
    I also can't post URLs...
    github -- jethrogb -- tomato -- releases -- tag -- 1.28.20180226MIPSR2jethrogb

    - Fix 5GHz radio
    - Enable USBEXTRAS

    Known issues:
    - Using LAN4 causes the software to reset
    - Stability is still an issue, but I think it's more stable than 1.28.20150213MIPSR2Gus
    Techie007 likes this.
  78. filipedonato

    filipedonato Connected Client Member

    I am very happy, it is a great progress.
    I've already downloaded, I'll test and say the mistakes if I find one this week.
  79. filipedonato

    filipedonato Connected Client Member

    I installed the latest update.

    *The router does not randomly restart.
    *It's great to have 5G and usb working.
    *View CPU consumption and free ram memory is great.
    *Being able to create more than one SSID is another very good function.

    *LAN 4 really has problems. If you connect to it, the router will restart.
    *ADVANCED-WIRELESS-Wireless Settings (eth2) - If you change some settings, the 5G network starts operating at 2.4G. To return to normal, you need to disable and enable the 5G network.

    I recommend the installation
    Techie007 likes this.
  80. pedro311

    pedro311 Networkin' Nut Member

    Last edited: May 1, 2018
  81. alcuin

    alcuin Network Newbie Member

    Hi, thank you for trying to build for Belkin F9K1102. Unfortunately, when trying to flash, I get an error "File is too big to fit in MTD". According to wikidevi for Belkin_F9K1102_v1, the proper mtd sizes are:

    # cat /proc/mtd
    dev: size erasesize name
    mtd0: 00030000 00010000 "boot"
    mtd1: 007c0000 00010000 "linux"
    mtd2: 00643250 00010000 "rootfs"
    mtd3: 00010000 00010000 "nvram"

    I am currently running tomato-K26USB-1.28.20180226MIPSR2jethrogb-F9K1102-64K.trx which is 8,097,792 bytes. Let me know if you need any other logs, thanks.
    Last edited: May 1, 2018
  82. pedro311

    pedro311 Networkin' Nut Member

    OK, thanks for testing.
    In that case, I have to remove something from that target.
    I'll let you know ;)
  83. pedro311

    pedro311 Networkin' Nut Member

    Just uploaded another versions:
    1. with no pptpd,
    2. with no pptpd + mediaserver,
    3. with no mediaserver.

    Please let me know which fits.
  84. alcuin

    alcuin Network Newbie Member

    freshtomato-K26USB_RT-N5x-MIPSR2-2018.1.066-beta-F9K1102-64K_no_pptpd.trx did not fit.
    freshtomato-K26USB_RT-N5x-MIPSR2-2018.1.066-beta-F9K1102-64K_no_mediaserver.trx flashed successfully.
    Did not try freshtomato-K26USB_RT-N5x-MIPSR2-2018.1.066-beta-F9K1102-64K_no_pptpd_and_mediaserver.trx.

    Thank you for the update.

    status page
    Name TomatoUSB
    Model Belkin N600 DB Wireless N+
    Chipset Broadcom BCM5357 chip rev 1 pkg 8
    CPU Frequency 530MHz
    Flash Size 8MB

    about page
    FreshTomato Firmware 2018.1.066 MIPSR2-beta K26 USB F9K1102-64K

    USB support integration and GUI,
    IPv6 support,
    Linux kernel and Broadcom Wireless Driver updates,
    support for additional router models, dual-band and Wireless-N mode.
    Copyright (C) 2008-2011 Fedor Kozhevnikov, Ray Van Tassle, Wes Campaigne
    Techie007 likes this.
  85. pedro311

    pedro311 Networkin' Nut Member

    Thanks, so I'll have to remove mediaserver on next builds.
  86. filipedonato

    filipedonato Connected Client Member


    Is stable?
    In the last post I did, after a few days the router rebooted again but it was very little and I ended up returning to the original Belkin firmware.
  87. pedro311

    pedro311 Networkin' Nut Member

    I can't tell you, because I don't own that router.
    That why I ask for tests.
    This is the "1.28.20180226MIPSR2jethrogb" version, with updates like in the CHANGELOG for other MIPS devices.
  88. filipedonato

    filipedonato Connected Client Member

    Results from "freshtomato-K26USB_RT-N5x-MIPSR2-2018.1.066-beta-F9K1102-64K_no_mediaserver"

    *DHCP now recognizes without having to manually;

    *Connection 4 still causes the router to restart to factory default;

    *Tomato recognizes my Pen Drive, I can access it through my computer, but I can not on Smart TV;

    *I can not tell if it is having a random reboot since I installed it a short time ago.

    *LEDs are the same

    *Apparently, it keeps restarting for some reason. To see the uptime, it was two hours the last time I saw him. It's now 40 minutes now. That is, rebooted for some reason.

    *My Router is Version 3
    Last edited: May 2, 2018
  89. alcuin

    alcuin Network Newbie Member

    My router is version 1. I'm at 23 hours uptime so far.
  90. filipedonato

    filipedonato Connected Client Member

    Here every two hours and a few minutes, the router restarts itself. Is it a bug related to LAN4.
  91. pedro311

    pedro311 Networkin' Nut Member

    So the solution is not to use LAN4...
  92. filipedonato

    filipedonato Connected Client Member

    I do not use LAN4, I'll try to describe the problem:
    There is no cable connected to LAN4. But, before the router restarts, if I open the TOMATO page, it will appear as if some cable is connected on LAN4. After about 10 seconds, the router restarts. This happens every two hours approximately.
  93. pedro311

    pedro311 Networkin' Nut Member

    Now I understand, thanks.
    But from what I see, for some people the router works with this soft for quite a long time, even more than a day?
  94. filipedonato

    filipedonato Connected Client Member

    TOMATO has great functions. But this BUG continues. Every two hours my router restarts. Unfortunately I will have to go back to Belkin software tomorrow.
  95. alcuin

    alcuin Network Newbie Member

    Maybe that's a v3 issue or even a hardware fault. Mine does not say anything is attached to lan4.
  96. Techie007

    Techie007 Networkin' Nut Member

    Just worth considering... I believe the Tomato code running the LEDs is hitting a register that causes the router to clear NVRAM and reboot. That's why when something is plugged into port 4, the router reboots, because it's trying to activate the LAN4 LED, but there's only three LEDs total on that router and so it hits a software reset register. Who knows, it may literally be software-pressing the reset switch!
  97. jgb123

    jgb123 New Member Member

    I think the "frequent reboots" and the "LAN4" issue are separate. I have the v3 and have experienced frequent reboots on all builds I've tried so far, without using LAN4. I haven't tried pedro311's build.

    Others in this thread have suggested the frequent reboots are temperature-related, which seems reasonable because the reboots seem to come more frequently with heavy Internet use. I did install a heat sink, but it doesn't really help.
  98. filipedonato

    filipedonato Connected Client Member

    The problem is not the heat.
    Mine also has a heatsink, which helps a lot. But in TOMATO itself you can see that the processing load does not even reach 1%, in my case.

    Okay, Lan 4 is easily solved by not connecting anything to the port. But the random reboot happens every two hours and a few minutes, and that's pretty weird.
    At night, when no one uses the internet, I open the TOMATO panel in the morning and see that the router has gone up to 4 hours without rebooting.
  99. Rmcoelhos

    Rmcoelhos Reformed Router Member

    Hi All,
    I would agree with Filipedonato, seems like it is not related to heat. Mine also has heatsink and even working with the case opened, the reboots still occur (since the original firmware).
    Maybe the CPU frequency could be the culprity. There are some reports on the Internet that this CPU cannot run at full speed (some router manufactors even slow the CPU down by default). Do we have a way to slow down the CPU (and Memory) frequency?
  100. unraised

    unraised New Member Member

    I have two related devices with almost identical hardware to the F9K1105v1: the Belkin F9K1102v1 and Belkin f7d4550v1. I rebuilt FreshTomato-MIPS from master, and it flashes successfully on these devices, boots, and runs with 2.4/5gh working, but I'm experiencing the same instability as others on this thread (random reboots, issues with using LAN 4, etc.)

    Thanks to the developers for initial bring up. I have devices in hand and can compile new builds; I'm wondering if anyone has any suggestions for what the issue might be so I can start troubleshooting. I think it's software related, because the latest openwrt on these devices is rock-solid (albeit without wifi working, which is why I'm sticking with FreshTomato).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice