Bellsouth PPPoE issues

Discussion in 'HyperWRT Firmware' started by dagnasty, Mar 6, 2006.

  1. dagnasty

    dagnasty Network Guru Member

    So I've been holding off asking for help to try every possible alternative to solving the problem I have with my wrt54g losing PPPoE connection during heavy traffic. (relative to defined bandwidth of 256/128)

    So here's the problem.

    The router dials in PPPoE just fine, but when I start downloading or uploading through bittorrent or even visiting a website that sends a lot of traffic ( in sattelite view). The weird thing is, I can download a file via HTTP for hours without troubles, but when I do something that uses multiple connections for data (?) such as bittorrent, download managers which split files into multiple streams, or visiting a web page with a lot of seperate large images I lose PPPoE until router redials (minimum of 20 seconds) and the router is assigned another IP. (dynamic)

    What I've tried.

    Latest stock firmware.
    Using just the dsl modem without the router to see if it's not the router causing the troubles.
    Manually inputting the MTU of 1492.
    Slapping the monitor.
    Punching the cat.

    None of which worked.

    Obviously, I could use the dsl modem as the PPPoE dialer and let the router hand out IPs and work as a firewall, but the problem with that is the modem will have firewall enabled by default with no option to change it when it's set to dial PPPoE and not work as bridged ethernet. I most definately want to use the wrt54g as a firewall. I absolultely cannot work with the modem's NAT interface.

    Will the router output the PPPoE error to the remote logger? (Wallwatcher)

    WRT54G - 3.1
    Firmware Version : v4.70.8, Hyperwrt 2.1b1 + Thibor14

    Does anyone else using PPPoE have this same problem?
  2. Thibor

    Thibor Super Moderator Staff Member Member

    i use pppoe in the setup you've described and use it in the same way as you. unfortunately i don't suffer the same errors as you. you could try resetting to factory defaults and setting it up manually to clear out any junk nvram variables, that might help. also, if using stock fw didn't help, that would perhaps suggest a hardware error.
  3. dagnasty

    dagnasty Network Guru Member

    But with Bellsouth? I THINK i remember reading something somewhere about bellsouth pppoe and wrt54g having compatilbility issues.
  4. dagnasty

    dagnasty Network Guru Member

  5. sealteam

    sealteam Guest


    If this helps any I set-up many Link-sys routers &
    Bell South combos and the only conflict I've encountered
    is with the IP of the router..........the last 3 digits need
    to be changed............other than that no problems!

  6. dagnasty

    dagnasty Network Guru Member

    How would the router's IP (as long as it's different than the modem's) have any effect on the PPPoE connection?

    It just doesn't make any sense to me.
  7. dagnasty

    dagnasty Network Guru Member

    I changed the IP for organizational reasons. Maybe it's purely coincidence, or just something that doesn't compute with me, but it hasn't disconnected for 2 hours under heavy traffic.

    Can someone PLEASE explain this to me.
  8. lemonade

    lemonade Network Guru Member

    i have the same issue here, just upgraded from tofu 13c to thibor yesterday, clear nvram, reset to factory....
    i experience random drop on pppoe side... this pissed me off, as i am playing counter strike....
    really looking forward for a solution to this. by the way i am using SBC dsl, i have been using sbc dsl for 4 straight years.

    added: just checked, may be it has something to do with "Connect on Demand", as i set it to 30 before, it reconnect pppoe every 30 minutes, and then when i set it to 1 minute, it reconnect every 1 minute...
  9. dagnasty

    dagnasty Network Guru Member

    OK. After realizing that the DSL modem supports DMZ, I solved the problem by DMZing the router. No problems whatsoever. Happen to get better latency when letting the modem do the pppoe dialing anyway. Can reach modem interface as well. That's a plus.

    With DMZ enabled you will be bypassing the firewall on the modem.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice