Beta firmware for the NSLU2 v23R72

Discussion in 'Cisco/Linksys Network Storage Devices' started by Toxic, Apr 4, 2006.

  1. Toxic

    Toxic Administrator Staff Member

    I have a newer version here than the v63 that linksys show.. there is a UI binary also included in the zip file but no changelog. this is a beta.
  2. slocaus

    slocaus Network Guru Member

    anyone tried this?

    Ok, I flashed the NSLU2_V23R73.bin file and all seems well. I'm not sure about the NSLU2_UI-EN_R202.bin file. Should it be flashed before (oops) ar after? I'm planning to convert to Unslung Linux and run this thing as a cups server for my laptop, but thought I would tinker with the stock firmare a bit.
  3. slocaus

    slocaus Network Guru Member


    After flashing the main file, going back to the updgrade screen gives a button to upgrade the UI. duh.... :eek:
  4. Avenger20

    Avenger20 Network Guru Member

    Looks big. Anyone noticed any new features? Can't unfortunatly test it as my only nslu2 is running openslug.
  5. frusti

    frusti Network Guru Member

    I just installed R72 an made some tests.
    I did have one ext3 disk on port one and one ext3 disk on port two. Both formatted by the nslu2.

    I just pluged a hub into port 2 (yes port 2) an attached an ext3 (one of my two nslu2 hard disks, a ntfs and a fat32 disk into the hub.
    On port one I pluged in the second ext3 disk.

    So the result was that the nslu2 recognized all 4 hard disks !!!

    I did not have an sucess with the hub on port 1.

    So it looks like linksys changed the disk behaviour completely between R63 and R72.
  6. frusti

    frusti Network Guru Member

    Ext3 on the hub on port two works only some times. I do not know yet from what this depends. Fat32 and NTFS on the hub on port two works perfect
  7. shivasdream

    shivasdream Guest

    Hi !

    I have unpacked the firm, it seems that there is a build in Itunes-Server! Found a file "mtdaap.conf" in /etc, the server Port is 3689. There is also build-in "Telnet.cgi", seems that they grant Telnet-Access again. The Root-Folder for the Itunes is /usr/local/mt-daap, it should be accessible by telnet. I can´t test it because i own a "FNS-1000" from Level-One, which Hardware is like the NSLU but has an IDE-Controller on Board. Still working on Modification for FNS-1000, Personal-Webserver is running on it until now. If you want to unpack use "slugtool" on Linux.

    Greetz from Germany

  8. ytsejam

    ytsejam Network Guru Member

    Multiple disks on a hub did not work for me. I'm using this hub: What type of hub are you using frusti?
  9. jphorn

    jphorn Guest

    I found some interesting strings in the package
    Since I've not installed this yet (couldn't see anyting in the UI related to these strings, so will wait), I'd like to know if it's possible to rename the HDD labels instead of the weird HDD1_1_1 etc labels we have now.
  10. Pout

    Pout Network Guru Member

    Hi I was just wondering what the verdict on thsi new firmware. is it worth an install.
  11. Syncer

    Syncer LI Guru Member

    Can anyone that has tried/installed the firmware tell me if there is any support that allows the NSLU2's time to be sync'd to and NTP server?

    How about the suggested telnet access, anyone been able to use it? Or, does it require 'root' login, such that you'd have to access the hard drives and edit the password file as discussed at Hacking the NSLU2 at Tom's Hardware

    Lastly, shivasdream can you share how you go about unpacking the firmware ... what tools you use? I can look at the .bin file with a HEX viewer, but that is about as far I can make it.

  12. denony

    denony LI Guru Member

    Hello :)

    Is there more information about the new version ?

    Is it provide UPnp sever, and is it working well ?

    If I upload 2.3R72 in my NSLU2 from 2.3RA5, then If I don’t like this version (or it it is unstable), can I go back with 2.3RA5 (ou 2.3R63) and load Unlslug 6.8 ?

    Thank you

  13. kevanj

    kevanj LI Guru Member

    OK...flashed with this firmware, and it *seems* to have done wonders for the stability of my SLUG...I also flashed the UI, but that does not seem to have made any changes to the user interface at all. No new links or buttons for any of the 'goodies' previously mentioned...
  14. camstone

    camstone LI Guru Member

    Hey, this is great. Took a couple of tries to reflash through firefox for some reason - but once it took, it took. Upgraded to new UI through the same admin setup. Seems allow me all the functionality of before. Access speeds on large disks appear to be up a bit as well. (My disk 1 =160 gig, disk 2 = 500gig, both EXT3 formatted) Not sure what new "UI" artifacts are in there, but regardless... it seems to be working well enough.

    Also for denony - Yes, even if you upgrade, you should be able to go to unslug and or back to previous versions. But right now... I don't think I'm going to need to. I might want to "unslug" to do some other things (like run a http server and the like) but for now, v72 looks pretty good to me.
  15. wkaml

    wkaml Network Guru Member

    NSLU2 Ext3 format seems to work after upgrading to V2.3R72

    Thanks for posting the firmware V2.3R72!!!

    I returned to this site to check for anything that would help me with the format issues I had. I have 2x Maxtor OneTouch II 300GB connected to the NSLU2 V2.3R63 and wanted to get them reformatted. Whenever I started the Ext3 format, I got an error message like "08/12 01:11:12 Disk 2: Format failed."
    After upgrading to V2.3R72 that format problem seems to be history.
    As far as I can tell, this seems to be the biggest change from R63 -> R72.
    The format is still running though...

    Thanks again for posting!
    Best regards,
  16. wkaml

    wkaml Network Guru Member

    Have you noticed that there are UI files with the extension DE, EN, and FR?
    DE=German (Deutsch)
    EN=English (Englisch)
    FR=French (Französisch)

    So, when you navigate to the "Upgrade" pane, you will see a new button called "Upgrade UI". You can select a different language version and - there you go.

    Made a big difference on my NSLU2 when I flashed "NSLU2_UI-DE_R02.bin"...

    Of course, English "smarties" will never notice...
  17. wrk24wheel

    wrk24wheel Guest

    Has anyone figured out if you can telnet into 72? The old /Management/telnet.cgi does not work.
  18. jksmurf

    jksmurf Network Guru Member

    I'd like very much to know this too please. I have a new NSLU2 and all I want to do is telnet in to check the current clock speed, if it's still 133, then I'll whip off the resistor. But no telnet method seems to work. Previous posters have noted they took it away with R63. I don't have the .bin to put the earlier version back and I am a bit uncomfortable loading unslung just for the telnet access. Is there a way to access telnet now?

    I upgraded OK from R23 (on the Slug when I bought it). This thread helped with the Not Enough Space Error.

    But telnet access is missing for me. Shivasdream noted above that he found the telnet.cgi (but didn't say in which dir he found it.)

  19. jksmurf

    jksmurf Network Guru Member

    Telnet success ... but not with the v23R72 (sorry Syncer!).

    Well I took the (very) long way around, and learnt a bit about my (4 day old to me) slug on the way. I tried Redhat Linux about 10 years ago and had it going for 6 months, but have not touched any since, so this was all new for me.

    Stock was v23R29 originally but I (stupidly in hindsight) didn't look for the telnet-enable option originally. I had to use the EraseUtil included in the Linksys official v23R63 firmware download package as I got the "not enough space" message when upgrading v23R29=>v23R72.

    When I loaded v23R72 for a look-see, that's when I discovered the telnet GUI was a no go in R72.

    So I downloaded v23R29 to see if http:/SLUG_IP/Management/telnet.cgi was in there. It was not. Grrr.

    So to finally get Telnet going I loaded up uNSLUng_6.8 by doing a normal F/W Update from the Linksys GUI, enabled telnet and checked BOGOMIPS (133Hz as suspected) so I will do the alternative resistor mod at A22 (with a switch!) soon. (See the section A turbo-button alternative to removing R83).

    As I am not quite ready for uNSLUng (first I want it to just run simple backups!), I then loaded v23R72 back onto it. NOTE! You can't just update from uNSLUng by upgrading from the GUI like Linksys f/w. I followed the NSLU2 "easiest method" part of this guide, performing the reset trick and using the Sercomm Upgrade utility. I had to use a crossover cable direct to the NIC for that, as I couldn't get alternating green/red lights when plugged into my WRT54GS. The timing of letting go of the reset button was crucial, as one guy mentioned, "release as soon as it goes red". Think "maniac at the traffic lights" for this one.

    Along the way I also managed to telnet into Redboot (using the Accessing RedBoot from Windows instructions) to have a little look around, but I'm not confident enough to "go there" yet.

    btw, how difficult would it be for someone to modify v23R72 (or any other rev. that does not have it) to enable telnet as I'm sure some folks would be interested in JUST that capability. This archived thread was not conclusive.

    This How To details steps to enable telnet on R29 and the referring page specifically states "The R29 Linksys firmware does not have telnet builtin.". So I was barking up the wrong tree loading v23R29 to find telnet. This site notes "It seems that Linksys removed directory listing ability from the R25 firmware and telnet from R29.".

    The easiest way, if Telnet is all you want, is to load up R24 or R25, so I guess I should have been looking for v23R24 or v23R25, both of which DO have it enabled, and loading that (without taking the uNSLUng 6.8 detour...).

    I hope this convoluted post helps someone in future if for nothing else but the links.
  20. Syncer

    Syncer LI Guru Member

    Thanks for posting the telnet status of R72!!
  21. jksmurf

    jksmurf Network Guru Member


    Nope, not that either. :rolleyes: . Really wish Linsksys would add that in. Everytime it reboots doing a backup job, I have no idea how long it took... :confused:

    Example: I know the last bit took two hours ... but the first bit? Come on, Linksys fix this please.

    01/01 10:07:43 Backup: Job 'JkmBackup' ended.
    01/01 08:01:38 Backup: Job 'JkmBackup' started.
    08/25 23:58:32 Backup: Job 'JkmBackup' started.

  22. mistafro

    mistafro LI Guru Member

    So this has an iTunes server but it's not accessible because it's not added to the UI yet?
  23. Mark Voss

    Mark Voss LI Guru Member

    Sounds like it may have, although if you want an iTunes server on your slug now, just install the uNSLUng 6.8 beta firmware and then add mt-daapd.

    Works for me - I can access the iTunes library on every PC in the house as well as on my Roku Soundbridge.
  24. marshal

    marshal Network Guru Member

    I just upgraded.. work fine..

    but a little "glitch"..

    If i use the function "send email"... where do I put the SMTP to use??
  25. xkoukos

    xkoukos LI Guru Member

    i try to upgrade from 63 to 72 but it popup a message and says that
    ''Bad file name.....
  26. Boodah

    Boodah Network Guru Member

    Can someone repost the zip file of the firmware? The link in the first post isn't working. Thanks.
  27. Toxic

    Toxic Administrator Staff Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice