Big PPPoE Reconnection Problem

Discussion in 'Tomato Firmware' started by ndoo, Dec 22, 2006.

  1. ndoo

    ndoo LI Guru Member

    Hi, I've been using Tomato 0.9 through 1.10 for a while now.

    When Tomato restarts the PPPoE service after I make any changes on Basic > Network, it does not disconnect the PPPoE session but rather kills the PPPoE process.

    This causes my ADSL modem to continue the PPPoE session, meaning that Tomato cannot get a new PPPoE session unless I power-cycle my modem to end the "loose end" PPPoE session.

    Is it possible that the PPPoE session is disconnected gracefully before being killed :confused:? This would ease the pain of having to power-cycle my modem and wait 30 seconds for the ADSL line just because I change my wireless settings :angry:.

    P.S.: My modem is a Prolink 9000C, which is just another relabeled Conexant Hasbani ADSL modem. Do other ADSL PPPoE users face the same problem of the PPPoE session being left hanging?
  2. myersw

    myersw Network Guru Member

    No I do not have this problem. Running Tomato v1.017 (latest). Anything I do that causes the PPoE connection to "cycle" works fine. In fact I have less PPoE connection issues with Tomato then I did with Thibor 15c or DD-WRT v23/sp1.
    My provider is AT&T with a Speedstream 5360 modem.
    Sorry I have no suggestions.
  3. ndoo

    ndoo LI Guru Member

    Hmm the fault seems to lie in my modem. But still, it would be good and more "correct" to have Tomato disconnect the PPPoE session gracefully everytime it needs to kill and restart PPPoE.

    This modem is lousy but my ISP here uses it as a free modem, so... :confused:
  4. Davka

    Davka LI Guru Member

    Yeah, I have this problem too. When I click disconnect and then connect button it connects in 2 seconds.
    But when I change ie. WiFi channel it disconnects modem and connecting takes ~3 minutes!
  5. ndoo

    ndoo LI Guru Member

    Hmm then it is very true that Tomato (and most other firmwares I have tried too) does not end the PPPoE session gracefully.

    Request for fix in next update please :(

    @myersw: Maybe your modem is being nice to you and terminating the session on your behalf :)
  6. t0m80

    t0m80 LI Guru Member

    me too, have the same problem, 1-3 min and it's reconnected, don't have to power-cycle though
  7. ndoo

    ndoo LI Guru Member

    I usually power-cycle the modem to speed things up, but otherwise it takes 3 minutes.

    Request for fix :(
  8. Davka

    Davka LI Guru Member

    If you click Disconnect BEFORE you make changes (Basic menu or Wifi) then Tomato will quickly reconnect after these changes.
  9. ndoo

    ndoo LI Guru Member

    The problem is that Tomato is supposed to do that for me...
  10. digitalgeek

    digitalgeek Network Guru Member

    what modem are you guys using, cause I never have any problems with me speedstream 5360... dsl conection (the modem cost me $2 a month)
  11. ndoo

    ndoo LI Guru Member

    I'm using a Prolink 9000C. I think they only sell that in Singapore. It's just a Conexant Hasbani OEM.

    Anyway I think an ADSL router is expected not to terminate the session unless it's asked to, so I think your modem is being helpful by disconnecting for you.

    Besides, there would be no harm done to make PPPoE disconnect before killing.
  12. Davka

    Davka LI Guru Member

    DLink DSL-300G+
  13. myersw

    myersw Network Guru Member

    That is the same modem I have and I do not have any issues either. Speedstream 5360. Difference is it was part of the install package that was given free for signing up so I do not have to pay each month.
    Also, I was just checking and my provider has cycled my connection again. With DD-WRT or Thibor 15c this would require me to cycle the modem and router. With Tomato to router just reconnects. Same DSL service I have had for several years. Dates back to when there was Ameritech, then SBC and now AT&T.
  14. ndoo

    ndoo LI Guru Member

    But the thing is that problems still exist for some of our modems (t0m80) and if problems aren't fixed because they don't apply to some people Tomato will never improve.
  15. digitalgeek

    digitalgeek Network Guru Member

    IF you pm the author, he will work with you to reolve the problem... Ver 1.01 was a direct result of use problems reported by users.
  16. en1gma

    en1gma Guest

    just fyi, I had the same problem

    I tried two differing WRT54G's (actually a V2 and a GL) with the same issue.... random PPPoE disconnects and the router seemingly having a problem reconnecting.

    This was with a speedstream 5360 (on a 5086/800 dsl line with very good stats..... my current modem/router on the line is solid as a rock)

    the logs seemed to indicate a loss of connectivity and many retries before it restarted the pppoe process (sorry I didn't keep them and can't afford to play now as our long distance is voip so we need a stable connection)

    currently my neighbour has the modem on a trendnet router to the same ISP (only difference is about 25feet further from the exchange...). it seems to be running well there so I can only surmise that it is something with the firmware...
  17. namaste

    namaste LI Guru Member

    I have at&t dsl and i am running my modem(speed streem) in bridge mode. My router (WHR G54S) resets/reboot every 12 to 26 hrs at anytime. I dont know why its happening, and my connections dont go above 1000 at anytime. My totall free memory starts when router reboots is like 35 % and then goes to 28 % after some time. This problem is from firmware 1.07 to 1.10 including 1.11.
    Avg wireless connection are like 4 at anytime.
  18. Odin-60

    Odin-60 LI Guru Member

    Same situation here: When the PPPoE connection simply "dies",
    instead of being shut down gracefully, the PPPoE server will
    accept a new connection only after 3 minutes. Note that it
    depends on how the PPPoE server is configured; the modem has
    nothing to do with it.

    NB: "killall ppoecd" does lead to "graceful" termination of
    the connection. Ditto the scheduled reconnect in v 1.11. Just
    pulling the plug, in contrast, doesn't.
  19. namaste

    namaste LI Guru Member

    I agree with that but why does my router has to do reboot..??? My uptime never goes above 2 days at max.. and all reboots are random..
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice