Big problem with wrt54gs and ddwrt 23 b

Discussion in 'DD-WRT Firmware' started by reindeer, Nov 28, 2005.

  1. reindeer

    reindeer Network Guru Member


    I have flashed my wrt54gs router with ddwrt v23 beta "dd-wrt.v23_mini_generic" binary.

    Upgrade was successful but after the upgrade, the router didn't give me an dhcp address.

    So, i fixed a static ip address and accessed the router, then tried to flash again that firmware - still the same problem. Then i downloaded earlier version of ddwrt - no change. After that, i tried to upgrade to original linksys software, but on the middle of that process, the info is displayed "upgrade are failed".

    So.. are any ideas how to fix that problem?

    I hope that somebody can help and sorry for bad english.

    EDIT: I forgot to mention, that the wrt54gs version number is 4.
  2. DoC_DaR

    DoC_DaR Network Guru Member

    Always reset

    You did not mention doing a hard reset (holding the reset button at rear of router) after each flash. This is required and in the instructions for this router. The DD-WRT v23 b is compatable with the WRT-54GS v4. I would suggest using the STD file. I use it and love it. Good Luck.
  3. reindeer

    reindeer Network Guru Member

    Re: Always reset

    Thanks, but I did the hard reset.

    Yesterday, i finally solved that problem. So - i will write here a small tutorial, maybe it will help somebody, if he/she will be stucked on the same problem:

    So.. I gave up trying to get ddwrt running normally and flashed back to linksys original software via the tftp.

    Firstly download original linksys software, unpack it to your "C:" drive and rename it to "code.bin"

    1. Fix the static IP address:, subnet, and the gateway address

    2.In the properties of your lan card, change the speed to 10 Mb Full duplex.

    3. Go to run, type "cmd", type "ping -t" and hit enter. If the ping is ok (if it's not timed out), then you can go to next step

    4. Go to run, type "cmd", type "cd c:\", then type: "tftp -i PUT code.bin" but DON'T HIT ENTER YET!

    5. Now, hold down the reset button of your router for 30 seconds, after releasing it, wait one to two seconds and hit immediately enter button in that window, which was described in the step four.

    6. After ten seconds you will hopefully see message: "2876416 bytes in 10 seconds, 287641 bytes/s"

    7. Now wait for a while and you will see, that the ping is ok now and and you can launch the web configuration utilyty.

    8. Do a factory defaults and change back settings of your network card and tcp-ip properties.

    Voila - you have your linksys up and running again.
  4. 69mws

    69mws Network Guru Member

    Re: Always reset

    I don't have the problem of not getting anymore into the configuration-utility, but I'm not able to flash my WRT54GS V4 to anything else, since I have Hyper-WRT (Thibor's) running on it.

    I tried flashing with this tftp version that has a gui, but it didn't work for me, so maybe it works this way using your mentioned steps with the command line interface.

  5. gaster

    gaster Network Guru Member

    I thought I read somewhere that DNSmasq needs to be unchecked on some of the dd-wrt builds otherwise DHCP won't work. See if that is unchecked on the main setup page and if not give it a try.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice