BitTorrent problems with WAG354G? (UPnP & QoS)

Discussion in 'Other Linksys Equipment' started by yashukawa, Jun 16, 2006.

  1. yashukawa

    yashukawa Network Guru Member

    My WAG54G was just replaced with a WAG354G due to poor wireless performance. Now I'm happy with wireless but the rest is acting really poor. Its like I gave away a stable connection just for wireless.
    I use BitTorrent and I had no problems with my WAG54G...
    Now download speed drops significantly (I have 256K and used to download at 25-26KB/s) in a random fashion. I'm connected to many seeds but sometimes speed drops down to 0KB and waits like that!
    Also MSN keeps dropping when I use BitTorrent. This didn't happen at all when I had a WAG54G... Also when the speed hits 0KB, I have problems browsing the internet. Its like the modem just dies then resurrects.
    I'm using 1.01.05 firmware.
    I also tried playing with QoS options but looks like it makes things even worse.
    The line is just fine, it works normally when I use the USB modem.
    Oh and also uTorrent fails to communicate with uPnP and can not open a port itself. uPnP is enabled in the modem console. Sometimes it works though. So I open the port manually but it still stops downloading from time to time.

    Is this modem really crap and can't handle P2P applications like BitTorrent or am I doing something wrong?
  2. masterb

    masterb LI Guru Member

    I have no problems with my wag354g and bittorent. I am using the last Azureus, I have disabled the unPNP and setted the port forward for both tcp and udp...
    I suggest u to try azureus...
  3. yashukawa

    yashukawa Network Guru Member

    I think uPnP and QoS doesn't work as its supposed to on this model.
    uPnP is very random and won't always open a port. So I opened it manually as you said and it seems fine because I'm connectable.
    Now I realize that when I enable QoS, it sometimes kills the connection so that no data pass through. It can't even run DNS queries so I can't view sites for a while.

    These are my QoS settings:
    FTP - medium priority
    HTTP - high priority
    Telnet - low priority
    SMTP - medium priority
    POP3 - medium priority
    Specific Port 1863 for MSN at medium priority

    These settings normally work excellent, my download speed decreases to 40% when I surf web sites as high priority takes up the 60% of bw. When I have an activity on MSN, dl speeds drops again nicely. But from time to time the whole connection dies. Torrent speed drops down to 0KB/s, web sites won't load as its stuck at "looking up" and I think MSN also disconnects etc. When QoS is disabled, no problems.

    I will write an email to Linksys support about this issue...
  4. booly

    booly Network Guru Member

    Have you tried the 1.0.09 firmware ?
  5. Advis

    Advis Network Guru Member

    Ah interesting. Have you looked at your wireless TX rate in your card's control panel? I'm getting more or less the same issue with v1.01.09 firmware and I've noticed that the TX rate drops really really low, like down to 1 Mbps. Might be the cause i wonder?

    To be honest this router is really really poor. A lot of stuff seems to be broken or not implemented as promised in the spec (WPA2 seems to be touted on many product pages, but you can't enable it for example along with QoS and UPnP which appear to be broken). Not that my previous DI-614+ was any better. Thing that ticks me off is that Linksys support staff on the email support just give you 'we don't know of any plans for a new firmware to fix/add x feature'. Poor.
  6. yashukawa

    yashukawa Network Guru Member

    Yes, same thing happens with 1.01.09 :cry:
    Advis, the problem occurs on both wired and wireless connections. QoS is not that important, but I'd love to use that function without any problems, it would make life easier. :)
    Btw I will paste their first reply to my email (they replied in just 1 day):
    I tried all of these steps but the same problem repeated.

    So they sent me another reply which I haven't tried yet:
    I will test it in a couple of days even though I don't believe that it will work.
  7. darren68

    darren68 Network Guru Member

    Is that firmware 1.01.09 the latest for a wag354g. Where did you download it.
  8. yashukawa

    yashukawa Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice