Bizarre Asus RT-N16 overclocking issue

Discussion in 'Tomato Firmware' started by rhester72, Apr 8, 2010.

  1. rhester72

    rhester72 Network Guru Member

    I suspect the reason it's clocked from the factory at 480MHz has to do with more than just 'stability'.

    Try this:

    - Clock the router to the defaults (480/240/120) and commit to nvram
    - Reboot
    - From a wired host connected to the router, after the WAN is up, ping, see that you get ping responses
    - Clock the router to the full spec (532/266/133) and commit to nvram
    - Reboot
    - From a wired host connected to the router, after the WAN is up, ping, see that you get *NO* replies

    A few other odd things:

    - In most cases, even when the above ping test fails when overclocked, general web surfing still seems to work!
    - In some cases, when overclocked, you will see interesting messages in /var/log/messages about the router being unable to set up various iptables rules because the required chains don't exist (!). When this happens, no device attached to the router can get connectivity to the Internet (but DNS requests from the device work correctly), but yet the router itself seems to be able to (for instance, wgets from the router _work_!)

    It looks like a higher clock sets up some sort of bizarre race condition that prevents the IP stack from being set up properly/in the correct order, which may lead to some of the 'stability' issues people have been seeing (because the behavior post-reboot is not consistent). I don't see anything wrong with the actual behavior of the hardware when overclocked.


  2. mstombs

    mstombs Network Guru Member

    Anything interesting in the boot log on serial console? I wonder if it is related to the low bogomips this router gets - I suspect not all instructions run at full CPU speed.
  3. rotorbudd

    rotorbudd Addicted to LI Member

  4. rhester72

    rhester72 Network Guru Member

    I don't (yet) have a serial console hooked up, unfortunately. :/

  5. Toastman

    Toastman Super Moderator Staff Member Member

    Memory on RT-N16 is Samsung K4N51163QZ-HC25 2.5mS 400MHz DDR3 rated up to 85 degrees C. Anyone know what the WRT320N used?

    Data sheet:

    I agree with you, rhester72, it's very odd behaviour. At no time does the processor seem to stop running, as one might expect if overclocked too high, it just doesn't do what it is supposed to. Mine works for a short while, pings sometimes work, but sometimes not. Sometimes web GUI is not available but the rest of it seems OK. It routes, web is fast, then it may reboot or just hang after a while, I can usually get a couple of minutes uptime. All processes that work, work at the expected speed. At least that bit makes sense.

    Mine seems OK at 500MHz.

    It's interesting that Broadcom did downgrade its data sheets though, seems they know there is a problem somewhere. It would be nice if they came clean with the cause.
  6. HKPolice

    HKPolice Network Guru Member

    I just got an Asus RT-N16 and the first thing I did was yank off the cover. I was shocked at how LOOSE the heatsink was. A simple twist yanked it off to reveal cheap double sided tape underneath and ONLY TWO EDGES were making physical contact with the chip. ABOUT 90% OF THE CHIP SURFACE HAD NO PHYSICAL CONTACT WITH THE DOUBLE SIDED THERMAL TAPE.

    This is a brand new sealed in box router, not refurb.

    NO WONDER Asus had to downclock the CPU to 480Mhz. I'm sure with a proper heatsink + maybe fan and a solid 12v adapter (rewired from a good PC PSU is my plan) 533Mhz will be stable.
  7. HKPolice

    HKPolice Network Guru Member

    Update: I used thermal paste + superglue to attach a Zalman NB cooler:

    Heatsink gets warm even when idling. I overclocked to 533Mhz and tried transferring about 1.5GB of files from a usb drive to my PC via Samba network share and got about 6.7MB/s average. I telnet to the router and ran Top -d1 and verified that the CPU was maxing out at 99% usage on average. What surprised me is that the heatsink did not get any warmer during load.

    I copied the files over and over again to create as much heat as possible but the router so far is rock solid after about 30mins of continuous file transfers. I have not hooked it up to my main network for routing duties yet, but if it can take 100% CPU usage for prolonged periods without crashing/freezing then it could have something to do with Wifi/Wan port causing instability at 133Mhz backpane instead of the cpu/ram. I disabled wifi before running the tests.
  8. mstombs

    mstombs Network Guru Member

    This is to be expected in devices that do not have a real idle/ sleep/power saving mode, the hardware doesn't do much different when different instructions running. The heat generated is primarily a function of clockrate (much higher order than linear), you will find that laptops/desktops with power saving modes turn off devices and dynamically drop the clockrate.

    Your wireless observation is interesting, there must be differences in power supply load (and internal heating) dependent on what the wireless transmitters are doing, would be interested to know if this is an issue.
  9. Toastman

    Toastman Super Moderator Staff Member Member

    HKP. thanks for that info. It seems that the heatsink on your specimen probably makes it hotter, not cooler.

    There isn't really such a great benefit from clocking at 532, unlike overclocking the WRT54GL, where a 25% increase was quite noticeable - but I'm just curious to know what caused Broadcom to change their specification. Yours seems to work, Lost_Animal also runs/ran his at 532 I believe, although maybe that was on the router that died and was returned.

    Mine, in common with most, cannot run stable at 532 whatever you do with it. It will become unstable with no wireless in use at all, and even when not routing. The 480MHz default is very stable. NB - I did run it with a fan over the processor/memory/LAN chips to be absolutely certain that there was no overheat problem to cause erroneous conclusions while testing new firmware before release, but I am so fed up with the unreliability of these small fans, that I have removed it, since it made no difference anyway.

    I tried running off a 12v Lead Acid (gel) battery and it made no difference, the PSU's seem quite OK - there is no evidence that they are underrated - in fact they can supply far more current than they are supposed to.

    If anyone knows what is going on, it is probably Oleg, the ASUS guru, on the Russian forum. Perhaps he's posted something.

    EDIT - I thought it useful to add this in August 2010 - that almost all of the problems that people had experienced with the RT-N16 have been solved by the newest releases of Teddy Bear's firmware. There has been no mention for several months now of any of the so-called "overheating" problems and nobody has even mentioned fans or liquid nitrogen for a long time :)
  10. HKPolice

    HKPolice Network Guru Member

    My router has been up for almost 10hrs now without crashing, I left it idling overnight. I hooked the wan port to my network and am now using it to surf the net without any issues (double NATing). I left the wifi turned off though, will try enabling it in a few hours to see if it's the culprit.

    Also, how do I get the BogoMIPS reading from the router?

    What do the 3 load average numbers mean? I'm maxing out at around 1.71/1.36/0.76 during file transfers. Top jumps around from 0-3% idle so shouldn't the load averages be more like 0.99/0.98/0.97 ? How can the load average be higher than 1.00??

    I just touched the switch chip on the router and it's BURNING hot. Couldn't keep my finger on it for more than 2-3 seconds without it being painful. Will slap on a heatsink.
  11. rhester72

    rhester72 Network Guru Member

    You can see the bogomips rating via dmesg.

    Your load average is off-scale high - what are you doing with/to that thing? :) A load average of 1.0 means the CPU is fully committed - anything above that means you have processes waiting in the scheduler line starved for cycles.

  12. Catalin

    Catalin Addicted to LI Member

    If I understood right, a load average of 1.71 means that one process uses 71% of the CPU capacity... 3.89 means 3 processes that use 89% of the CPU...
  13. HKPolice

    HKPolice Network Guru Member

    I was only able to push that average load when transferring files from a USB flash drive to my PC via the router's NAS.

    Bogomips shows 264, whereas other broadcom routers have bogomips ratings identical to their clock freqencies... I have a feeling that broadcom did something sneaky and the CPU isn't really running at the full 532/480Mhz.

    I also have a WRTSL54GS, I remember using it as a NAS and getting around 5-6MB/s using the stock linksys firmware. That router was running at 264Mhz (BogoMIPS = 264) on an older broadcom CPU (can't remember the model off the top of my head). If the RT-N16 is really running at 532Mhz, it should be able to push closer to 10MB/s instead of maxing out at around 7.3MB/s, unless Kernel 2.6 has too much overhead or something...?

    I used the same USB stick on both routers, and it's capable of 20MB/s reads when connected directly to my PC.
  14. HKPolice

    HKPolice Network Guru Member

    I've been downloading off the internet through the router @ 532Mhz for the last ~40minutes at max speed of around 1.1MB/s (maxing out my connection) without any errors or lock ups.

    But I've made a SERIOUS bottleneck observation:

    The router seems to be limited to around 7.5MB/s combined throughput.

    Example: If I'm downloading files off the Router's NAS share, I'll get around 7.3-7.5MB/s. But if I'm downloading files from the internet AND the NAS share at the same time, the COMBINED throughput is STILL 7.3-7.5MB/s, with about 1.1MB/s from the internet and the NAS transfer slowing down to about 6.3MB/s.

    If I pause the internet download, the NAS transfer speed instantly goes back to 7.3-7.5MB/s with NO gap (I'm using NetMeter to graph real time transfer rates).

    Can anyone else please confirm this?? I know my PC setup is fine because I can copy files from another PC at 125MB/s (gigabit with 9k jumbo frames).
  15. mstombs

    mstombs Network Guru Member

    You also see BogoMips reported during boot on serial console, and you can read it using

    cat /proc/cpuinfo
    7.5 MB/s = 60 Mb/s, which is quite a bit higher than WRT54GL s can do, but not more than double in proportion to the alleged clockrate
  16. tomatofan

    tomatofan Addicted to LI Member

    No, not at all.
  17. HKPolice

    HKPolice Network Guru Member

    I'm 99% sure that my 532Mhz is stable now, but that 7.5MB/s bottleneck still annoys me :(

    It doesn't seem to be much faster than regular routers clocked at half this speed.
  18. HKPolice

    HKPolice Network Guru Member

    Did some more speedtests with the RT-N16 while downloading off net and the NAS @ the same time with the newest Build 48.

    Maxing out at around 6.5MB/s combined throughput, but if I DL off the NAS only, I max out at around 7.5MB/s. :confused:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice