Brick Revival Help!

Discussion in 'Cisco/Linksys Wireless Routers' started by anectine17, May 15, 2006.

  1. anectine17

    anectine17 Network Guru Member

    Greetings. I bought 2 WRT54G v.2's on ebay for next to nothing. They were advertised as "for parts only", but they did power up. I figured they'd be good de-bricking practice projects. Anyway, on one of the routers, I have had partial success, but am stuck now. I tried the manual resets, etc. with no success. So, I went to the "short pins 15 & 16 trick". Well, just like it was supposed to, when I put power to it with pins 15 and 16 shorted, I started getting successful pings. Next step was to tftp some firmware to it. I've tried both DD-WRT v. 23 mini, and the latest Linksys firmware with identical results. I enter a command prompt from Windows, tftp -i PUT nameoffile.bin and get a message that the tftp was successful. Hooray, I think!! But the router never reboots on its own. The power light keeps flashing, the DMZ light stays lit for a minute or so, then goes off for a few seconds, then back on...the LAN light that I'm hooked to stays lit with some flickering like it's communicating. Also, when I get the successful tftp, my LAN icon changes and says that the network is connnected. I am able to ping the router now, but still have a flashing power light. I've tried holding the reset for 30 seconds, I've tried holding it for 30 seconds, pulling the power while holding the reset for another 30 then reconnecting the power. No change. Where do I go from here? I'm new to this, and am NOT an electronics or computer wizard. I have some basic knowledge and can figure most anything out with some time and direction. I've ordered the parts to make a JTAG cable, and d/l'd hairydairymaid's utility and am reading up on JTAG'ing. This isn't critical as I have 2 functioning routers for my use, but I'm doing this as a hobby. I've got several dead or dying WRT54G and GS's either on hand or on their way and would like to fix as many as possible. Any suggestions on where to go with this router are much appreciated. In fact if someone can tell me how to get it up and running, I'll send you the router if you'll pay shipping. Also, any advice on JTAG'ing is greatly appreciated. Sorry for the long post. Thanks again.

  2. anectine17

    anectine17 Network Guru Member

    Surely someone has encountered this. I feel like I'm almost there with it but am missing something. Help me get it working and it's yours for the $5 it costs to ship!! COME ON!! Please!! :D
  3. grcore

    grcore Network Guru Member

    how long did you let it sit after tftp?

    tftp and let it go, it should reboot time I tftp'd and went to bed. the next day i had a working unit.
  4. anectine17

    anectine17 Network Guru Member

    Ahh......I'll try that. I only waited 2 or 3 minutes each time. I've been through it up to that point about 5 times now trying different firmware. It never occurred to me to wait longer. Thanks!!
  5. anectine17

    anectine17 Network Guru Member

    Well, I let it sit for about 2 hours after tftp and there was no change, no reboot. So I moved to another bricked v.2. It did the exact same thing. Responded to the pin 15-16 short, pings were successful, I tftp'd using the command prompt, got a message saying firmware upgrade was successful, but no reboot. So, I'm going to let this router sit for awhile and flash. This is weird stuff. Thanks for your help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice