Bricked Linksys WRTSL54GS with Shibby Tomato Build

Discussion in 'Tomato Firmware' started by AlterEgo, Mar 20, 2012.

  1. AlterEgo

    AlterEgo LI Guru Member


    I have searched quite enough already for similar scenarios however I need some help and guidance about how to proceed, as I am not a power user of linux CLI nor very inclined in hardware mods,CFE, Serial, JTAG and so on.

    I was using the tomato shibby build tomato-NDUSB-1.28.5x-083V-Big-VPN.trx on WRTSL54GS ver 1.1 correctly. However due to a power fluctuation the router started behaving abnormally, with all LAN connection, USB and DMZ leds lit and power LED blinking continuously.

    I have had this happen before so I simply did the "TFTP" method of loading a mini generic DD-WRT image , of course at this point the router was able to be ping at

    After loading the mini generic image i decided to swtich back to a newer build of shibby which as per the website was tomato-NDUSB-1.28.5x-087V-Big-VPN.trx , so from within the DD-WRT interface I went to the administration page and tried loading the newer shibby build image (of course I had to change the file extension to BIN).

    The image loaded and router flashed successfully. Not sure what went wrong, now the router is continuously in a restart loop with the power LED blinking again continuously and the linksys SES Amber/White light not lit.

    The router is not having a ping response on the standard IP, even for short while of time after a cold boot. Have tried it by having a command window continuously pinging the IP address.

    Already have tried the 30/30/30 reset switch trick which is still of no use. I cannot send the tftp image to the router anymore. Have tried plugging in all the 4 LAN ports to send the ping/recovery image.

    Can someone please guide me (preferably with pics is possible) which is now the most recommended method for doing any type of recovery. I am confused about using pin-shorting/serial/JTAG/CFE concepts, can anyone guide what sequence and what conditions they are used for and how to approach the most easiest commonly used method.

    Would appreciate all the help to recovery this old trusted piece of hardware.


  2. Aquafire

    Aquafire LI Guru Member

    Have tried the tftp method a number of times , even with a switch b/w PC and router to let the network connection stay alive, however nothing seems to respond.

    I am thinking that I would be able to add a serial console to it. However can anyone please guide me what to do after adding a serial console.

    Is there any guide on the steps to perform recovery via the serial interface. I can only see partial information in bits and pieces.

    Really need some expert help.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice