Bricked my WRT54GL with TomatoUSB K2.6

Discussion in 'Tomato Firmware' started by ppq-, Apr 22, 2011.

  1. ppq-

    ppq- Networkin' Nut Member


    i was curious about what's possible and what's not, so i tried to flash a K2.6 build of TomatoUSB (NoUSB Std). In here it says that my router supports K2.6 builds, so i felt optimistic... After bricking my router, i read in the dd-wrt wiki that it's necessary to modify the CFE in ordner to boot Linux 2.6 builds. :frown:

    However, after 30/30/30 hard resetting, flashing, hard resetting again and rebooting my router does nothing now. Except the Power LED, it's blinking all the time.

    I can't ping it, so i guess i can't use the TFTP method.

    I got a JTAG cable and soldered the 12pin header to the router's mainboard. On the net, i found *lots* of How-Tos and tutorials on how to debrick the WRT54GL using JTAG interface - but most of it is outdated, refers to unavailable tools or whatever. I'd like to use Linux tools to fix it since i don't have a working Windows on a pc with a parallel port atm.

    Does somebody have a tested and actual guide please? :)
  2. TexasFlood

    TexasFlood Network Guru Member

  3. mstombs

    mstombs Network Guru Member

    I know that dd-wrt had that restriction - but was not aware that TomatoUSB did.

    Are you really sure - you must use a static IP on your PC, sometimes a hub inbetween helps. If the leds are not cycling the router won't be in a reboot loop may only have a couple of seconds after power up to tftp.

    dd-wrt Tornado's tjtag includes Linux binaries (and easily compiled source code for last release version). On Ubuntu you need to unhook the printer driver before tjtag can use the parallel port using

    sudo rmmod lp
    which is easier than windows having to use the old quirky loaddrv and giveio.sys.

    Note it is possible the CFE hangs due to bad nvram vars, the reset switch GPIO is actually stored in nvram - so easy to see why that doesn't work! If it is this it takes 2s with a working JTAG connector to erase the nvram!
  4. fubdap

    fubdap LI Guru Member

    This may be a noob talking... aren't you better off buying a used router from ebay or something rather than dealing with JTAG?

  5. TexasFlood

    TexasFlood Network Guru Member

    You know that's a very good point. I thought about that when I first read your post but promptly forgot it by the time I finished replying. The router boot_wait window in which it listens for tftp and responds to pings is very small. Best case you'll probably only get 5 pings after powering it up. You might want review the DD-WRT Wiki TFTP flash page, it's pretty informative and comprehensive, if a bit long.
  6. ppq-

    ppq- Networkin' Nut Member


    thank you for your help, TexasFlood and mstombs. I read lots of docs, wiki pages and threads dealing with tjtag. It's pretty easy to use. :)

    I started pinging even before i plugged it in, so i think it was definitely f*****.

    Using tjtag with the /noewm option, i erased "nvram" to check if it already is sufficient - it wasn't, after rebooting and resetting nothing worked.
    So i erased "cfe" and "kernel" (after making backups), made a good CFE with the correct MAC using LoneWolf's CFE tool and flashed it.
    Then i was able to ping the router again. I flashed the newest original Linksys firmware - it worked directly. I reset everything again, flashed good old K2.4 TomatoUSB, rebooted and now it works fine :)
  7. dmb41crash

    dmb41crash Networkin' Nut Member

    The WRT54GL does support 2.6, but you MUST use the MIPSR1 NoUSB Std build. It sounds like you tried to load the MIPSR2 build, which promptly bricked the router. Here is the direct link to the correct version, which you can use if you manage to get the thing de-bricked:

    Not true with Tomato. NoUSB Std 2.6 MIPSR1 flashes, boots and runs just fine on the WRT54GL with no further modifications necessary.
  8. TexasFlood

    TexasFlood Network Guru Member

    yes, you tried to load a MIPSR2 build, that's what did it.
    If you look back at the TomatoUSB table it clearly states MIPSR1.
    I didn't realize this was the case with DD-WRT but after looking at the DD-WRT WRT54GL page, I see you're right. As mstombs and dmb41crash stated already, this is NOT a requirement with Tomato. I haven't run DD-WRT in a while nor have I had much interest in running kernel 2.6 builds on my older routers, just seems to consume more memory on routers that already lack memory.
  9. Beast

    Beast Network Guru Member

    I second that have run K26 builds on my WRTSL54GS with no problems. As above just make sure its a MIPSR1 build.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice