bricked wap54g V3

Discussion in 'Other Linksys Equipment' started by jjtu, Dec 1, 2005.

  1. jjtu

    jjtu Guest


    I tried to upgrade firmware (freya) but it seems that it is not compatible with this version of ap. So it totally bricked. Does anyone know the pins on flashrom that should be shorted that I could put new firmware with tftp.
  2. tomekp_123

    tomekp_123 Network Guru Member

    In Intel flash pin 15 AND 16 - unfortunatelly you have SST flash. I tried switch flash to read (reset) mode (as is described in SST website in product datasheet but not works:
    try connect serial console (you must have a interface on max 232), and press ctrl+c next to power on your router. It takes a CFE mode an now you can upload a new firmware from tftp serwer (you must write a command in router console).

    There is no freya firmware at this time to this equipment (v3).
  3. pavelkamburov

    pavelkamburov Network Guru Member

    you can repair whit jtag i try and its work, but the cfe is different about wrt54. if you have full flash the dont problem if you not fulll flash i can send for you but the MAc adrres is different
    pavel kamburov
  4. gd32475

    gd32475 Network Guru Member


    Apparently that answers my previous post (JTAG on WAP54G V3). What did you use (software, hardware, any paticulars?)
  5. FasTSloW

    FasTSloW Network Guru Member


    I have WAP54g v3 for wich I need full flash to try debrick with jtag
    I try with shorting pin15 to ground wich worked for me two last times but now I can not activate lan port and use tftp for upload frimware
    I conected serial port and run console but that not give wanted results i conected thru hyper terminal and see that boot file corupted and eth0 not exist message. I was put open wrt into my wap wich was working until I desided to change contry code (to get 12'th channel) in nvram and executeed nvram commit .

    sorry for my english
  6. FasTSloW

    FasTSloW Network Guru Member

    It is alive :cheering: !

    Thanks goes to Pavel :thumbup:

    I bring it to life by erasing nvram with jtag
    and then tftp orginal frim ware



    MR_KILLER Network Guru Member

    I kill my WAP54g. If you have full flash sent me please on: killer(at) I have only jtag, I dont have program to flashing, sent me this too if you have.
  8. dddave

    dddave Network Guru Member

    What software did you use to do this? Where can I find it at?


    MR_KILLER Network Guru Member

    I have flash, nvram, cfe and kernel. Now I need program to flashing. Please help me
  10. FasTSloW

    FasTSloW Network Guru Member

    To Killer

    I allready send it to you it is wrt54g.exe

    To DDDave

    Search for HairyDairyMaid_WRT54G_Debrick_Utility on OpenWRT site
  11. dddave

    dddave Network Guru Member

    Well, I've got the utility, and I got it running correctly. However, when I attempt to interface with the flash on the WAP, the program doesn't go any further than "Enabling Memory Writes" stage. Any idea why it would be doing this?
  12. FasTSloW

    FasTSloW Network Guru Member

    Well did you load giveio.sys with loaddrv.exe

    If is SST flash you must manualy select SST flash. There is only one listed and that was worked for me.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice