bricked wrt54g after upload dd-wrt v22 final ...

Discussion in 'DD-WRT Firmware' started by moko, Sep 26, 2005.

  1. moko

    moko Network Guru Member

    I have decide to change firmware from oryginal linksys 4.20.6 to dd-wrt v22 final.
    I have read several post described way how to do that and I tried to follow all important advices.
    Before I start doing it I reset to factory default the 4.20.6 firmware by http allowed function and start upgrading with dd-wrt.v22_wrt54g.bin
    But after wrt54g stoped answering for ping reqest > I'm waiting a while and restarting it by power off and on > nothing change then I press reset button located on back for about 30 seconds and repeated power off and on > nothing (power LED blinking)!
    I don't remamber how many times but I repeated above at least twice or more. Fortunately I found that wrt54g started answer for ping but without management access by http.
    So, I realized I bricked my toy > I tried to follow flashing procedure with oryginal linksys 3.03.6 (or something like that according to post describing unbricking wrt54g) > nothing!
    I tried to upload previouse 4.20.6 and last one 4.20.7 (by using auto installed package .exe from linksys) > nothing!!!
    And in next step I tried to upload dd-wrt.v22_basic_wrt54g.bin by tftp -> it improve the situation (power LED stop blinking), I can ping it, I can access to management by http but .... only till restart or reset to factory defaults. After that I am in previouse point when I have to flash againe (power LED start blinking after that).
    I repearted this several time and nothing change - I unbricked my toy but for temporary usage. I don't know any idea how fix it permanently, what is going on with my wrt54g and why it goes brick after each restarting?
    I'll be grateful for any advice - thanks in advance
  2. BrainSlayer

    BrainSlayer Network Guru Member

    which router revision to you have?
  3. moko

    moko Network Guru Member

    I have router ver 2.2 ...
  4. moko

    moko Network Guru Member

    Who can give me "friendly hand" with my problem ???
    Maybe someone have got the same problem with wrt54g hardware revision 2.2 or similar ...
    Please, don't live me alone :)
  5. BrainSlayer

    BrainSlayer Network Guru Member

    generally dd-wrt works on all router revisions. sometimes i got problems too with flashing from some linksys fw revisions. but all could be recovered with a 20 sek reset button push.
    push the button. plug in the power cable. keep it pushed 20 sek. then just leave it as it is. after max 2 min. the fw should be up.
    in v23 i found a bug in the startup procedure which can also happend in v22. so if you want you can also try the latest v23 (300905) version
  6. moko

    moko Network Guru Member

    I tried to follow your procedure several times > nothing change.
    It is strange but router is correct initiialized only after dd-wrt v22 is uploaded.
    If I tried to load by tftp oryginal linksys firmware ver 4.20.6 or 4.20.7 or dd-wrt_v23 it is succesful uploaded but initialization regulary went wrong and I couldn't connect via http (after failed initialization power LED is frequently blinking and dmz LED blinking slowly).
    Always before each upload I repeated your procedure "20second" !

    So, can you understand what happend with my router ???
    It seems it is ready at the moment only for dd-wrt_v22 :)
    Unfortunately I have to repeat uploading procedure and configuration each day after I switch it on :cry:

    Do you think that I should open it and short 15 and 16 pin of some chip according some post on forum?
    Can I hope it will improve my situation?
    Every advice can extend my hope ...
  7. greySkeg

    greySkeg Network Guru Member

    Whooah thanks - thought I'd bricked my WRT54GS for a bit when tried applying the latest beta. Great firmware to start on - I know. Wouldn't connect _at all_. Especially annoying since it was responding to ping requests.

    1x20sec button press and 2min wait while it worked out what was going on and I'm in - and in the updated firmware as well.

    All this after a 20min LiveChat to Linksys who told me the 54GS isn't actually an access point at all, and I needed a bridge anyway.

    Of course with my very limited networking knowledge I probably buggered up a load of settings - but we'll see.

    Appears to be working quite well at the moment. Now if we could only get a firmware update for the WAG354G to add power to the DSL line.

    Thanks for saving my router

  8. moko

    moko Network Guru Member

    I'm very happy that you have fixed your problem thanks procedur from BrianSlayer.

    In my problem nothing changed - day by day I'm more experienced with firmware uploading and configuration skills :)
    I tried to upload firmware with tftp as well as with management http interface > the result was the same :thumbdown:
    I have guarantee for WRT54G but I couldn't load oryginal firmware !!!

    It seems there are nobody who can understand what happend with my router :cry:
  9. Toxic

    Toxic Administrator Staff Member

    if you cannot fix your problem then is your router less than 3 years old? Linksys will replace your router inder RMA. I done this a few months ago.
  10. hohndel

    hohndel Network Guru Member

    I followed BrainSlayers instructions about a dozen times - and two of my WRT54GS (a V2.1 and a V3) both do not want to come back to life with it. I get a blinking power led and that's it. No ping response, tftp doesn't work, the Linksys update tool doesn't work. (interestingly enough something seems to be alive, as the MAC address shows up in the arp cache with as address - but I still can't ping it or anything).

    For one of them I broke the case open and did the "short pins 15/16 on the flash" - and it's back up. The other one isn't mine, so I don't really do that if there's a way around it. That one's the V3.

    Any other brilliant ideas that don't involve cracking open the seal?


  11. Toxic

    Toxic Administrator Staff Member

    Phone Linksys for an RMA and send it back for a replacement. simple but effective.
  12. west55

    west55 Network Guru Member

    EU frmware

    I brick my wrt54g v 3.1 by uploading v.22 r2 final.
    15-16 pin did`t help.
    I power it on, grounded pin 16 for a 1 sec. and it started pinging.
    Now i loaded orig. 4.20.7 exe ( it is like tftp )
    after that I flash again v.22 r2, and now it works.

    So the trick was pin 16 grounding !!

    Anyone know where I can download for wrt54g v3.1 original EU firmware ??
    I cant get VoIP working, and want try original firmware.
  13. kiilakas

    kiilakas Network Guru Member

  14. west55

    west55 Network Guru Member

    To kiilakas


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice