Bricked WRT54G v4

Discussion in 'Cisco/Linksys Wireless Routers' started by PigDestroyer, Oct 16, 2005.

  1. PigDestroyer

    PigDestroyer Network Guru Member

    Well I tried upgrading the firmware now it wont respond and the power light just keeps blinking. Ive the steps listed here:

    but when I try to ping the ip in the command prompt it times out.
    Most of the recovery methods ive read about are for older versions.

    Anyone know how to resore this thing??

  2. Toxic

    Toxic Administrator Staff Member

    you have tried turning the power off then back on?

    also try this press reset buttong for 30 Seconds.

    turn off power. turn on power but at same time hold the reset button in for about 20 Seconds.
  3. PigDestroyer

    PigDestroyer Network Guru Member

    Hi, thx for the response.

    Yes ive tried that and it is still flashing, I alsounplugged it before I went to bed and it still didnt work.Any other ideas?

  4. billbeau

    billbeau Network Guru Member

    Yeah i have had the same issue. Try this.

    Thjis will void your warrenty.

    Open up your router. The front blue peice just snaps off.
    Disconnect your antennas.
    Pull the board out
    attsach a network cable from your computer to one of the four ports on the router (not the Wan port!)

    Set your computer for an ip of and a net mask of

    find yourself a nice tftp program to upload a new firmware binary

    look for the dd wrt v23 mini

    Now your gona have to look for the flash chip on the board. It should be a intel chip

    short out pins 15 and 16 with a jewlers screwdriver.
    While shorted out plug in the power.
    This will allow you to upload a new flash firmware to

    Be ready to upload the firmware once you plug the power in. You only have like 3 seconds to do this. It may take a couple of tries but it does work on the V4 router. I have done it many times.
  5. PigDestroyer

    PigDestroyer Network Guru Member

    I see the intel chip but I dont see any chips marked 15 and 16,
    when you say short them do you mean place the screwdriver over the pins while the power is on? I havea TFTP program, could you give me a link to that firmware?
  6. billbeau

    billbeau Network Guru Member

    What I would do is use the firmware provided by Linksys first then use google for the mini firmware.

    The pins arnt marked. But pin 1 is on the side of the power connector closest to the power connector. Youl see some white dots every 5th pin. The 3rd white dot is 15. Unplug the router then shrt 15 and 16. While there shorted apply power. That will startup the tftp server in the router.

    Good luck

    You can also look up linksys revival on google or yahoo.
  7. PigDestroyer

    PigDestroyer Network Guru Member

    :cheer: NM It worked. Thx Billbeau

    I used firmware from linksys website.
    I couldnt find a screwdriver small enough so I used a paper clip.
    I was totally suprised when it started pinging, I didnt even think it would work.Now I can play PSP games online again.
  8. billbeau

    billbeau Network Guru Member

    Cool :cheering:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice