Bricked wrt54g2

Discussion in 'DD-WRT Firmware' started by dpeterson3, Nov 13, 2008.

  1. dpeterson3

    dpeterson3 Guest

    Hi all. I have a WRT54G2 here that I was trying to upgrade. I figured it is only a TFTP server, which I have used before. I tried to upload the prep file, but it would not load via TFTP, so I tried it from the web page. I have a router here now with a seemingly working DHCP server and nothing else. I can no longer login in and change settings. I can not use the TFTP server to finish the update. I can only seem to be able to ping the router and be assigned IP's. I have seen a few posts of people using JTag to de-brick their routers, but I have never used it, and they did not include a good how-to. I am at a loss. Any help would be greatly appricated.
  2. ad5mb

    ad5mb Addicted to LI Member

    The JTAG how-to is in a PDF file in the Hairy Dairymaid debrick utility. That is a zipped folder, so you have to download, unzip and read.

    If you're running windows, the formula is:

    • Plug JTAG cable into router
    • Plug JTAG cable into PC
    • Open Command Prompt
    • Type:
    • wrt54g -erase:nvram
    • Plug in router power and immediately hit enter

    That will clear your NVRAM. Your first step in the debricking process, might just be all you need to do.

    You have to do the plug in - enter routine to overcome a "watchdog timer" You have to do that every time you send a command.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice