Bricked WRT54GL - Successfully reFlashed with tftp, same issue

Discussion in 'Cisco/Linksys Wireless Routers' started by Treppiede, Feb 21, 2008.

  1. Treppiede

    Treppiede LI Guru Member

    I bricked my WRT54GL v1.1 while I was upgrading to the latest Linksys firmware v4.30.12.3 (by selecting v1.0 from Linksys' page as they are supposed to be interchangeable).

    The router's power LED blinks very quickly, no DHCP addresses are leased, WLAN down, LAN ports do light up when cable is plugged in. I proceeded to set static LAN IP, reset the router and pinged it successfully. I then went ahead and re-flashed the router using Linksys' TFTP utility which informed me that the flash had completed successfully.

    Nothing changed, router is still showing same symptoms as described above. Any advice?

    Thanks in advance!

  2. danix71

    danix71 LI Guru Member

    Reset the router 30 sec.
  3. Treppiede

    Treppiede LI Guru Member

    I did, no progress. I tried both resetting 30 seconds with router on as well as holding the reset button then plugging in router and keeping reset pressed for 30 seconds.

    Same issue. Any other advice?

    Thank you,

  4. Partizan

    Partizan Network Guru Member

    Try flashing a third party firmware (like Tomato), and then reflash with the official firmware.
  5. Treppiede

    Treppiede LI Guru Member

    Interesting... I will try it as soon as I get home. In the mean time, could you tell me why might this work? I am curious.

    Thank you for the help.

  6. Treppiede

    Treppiede LI Guru Member luck, same result. :frown:

    Any other advice?

  7. Treppiede

    Treppiede LI Guru Member


    Am I in the wrong sub-Forum perhaps?

    Please let me know if I should have posted this thread in another section.


  8. Toxic

    Toxic Administrator Staff Member

    what you have done from the initial post is correct, will the wrt54gl still respond to ping? if so try again. then leave the device for at least 5 mins. then try a reset for 30 seconds and let it bring itself back up. if you are able to ping it then you should be able to use the webgui. make sure you clear your web cache.
  9. Treppiede

    Treppiede LI Guru Member

    Toxic: looks like it worked.
    I suspect I wasn't pressing the reset button correctly, the object I was using might have been slipping. I tried again and it appears to be working now.

    It still works erratically though... is there any way that previous dd-wrt/tomato installs might have left ghost rules and/or functions in the memory? I am now running the latest Linksys fw. Any way I can perform a FULL reset and bring it 100% back to factory specs?


  10. Toxic

    Toxic Administrator Staff Member

    i have heard that some NVRAM settings have been left in when resetting the router by users, the only way then is to clear the nvram. not too sure of the exact command but it is in the forums somewhere.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice