Bricked WRT54GS v4

Discussion in 'Cisco/Linksys Wireless Routers' started by HaDAk, Aug 14, 2007.

  1. HaDAk

    HaDAk Guest

    Help me, you're my only hope.

    So. Here's what happened:
    I was running HyperWRT, and a friend suggested I try DD-WRT. I installed DD-WRT, and after a day, realized that it was unstable, and kept dropping my internet connection (and I couldn't ping the router.) I used the firmware upgrade utility in DD-WRT to upload a new copy of HyperWRT, and after the flash finished, the router was bricked: no ping reply, blinking power light... bricked. I managed to get it to reply to pings using the pin 16 to ground trick, and using the Linksys TFTP program, I managed to upload the official firmware. Unfortunately, after the upgrade finished, there was no status change on my router at all; I still had the blinking power light, and only responded to ping. I couldn't even telnet in. I had my computer set to a static IP address, using half duplex 10baseT. If I use the TFTP program to upload HyperWRT, it fails to erase the flash. TFTP from my command prompt brings up the graphical interface, and doesn't transfer from the command line itself. Also, I should note, I've tried this from both Windows, and a BSD box (OS X), and I've tried hard resetting the firmware by holding the reset button for 30 seconds, unplugging the router, continuing to hold the button for another 30 seconds, plugging it back in and holding the button for yet another 30 seconds, and then unplugging the router with the button released for ten seconds. I've tried every trick in the book, and can't seem to get this thing up and running. Anyone have any advice?
  2. nitro2

    nitro2 LI Guru Member

    bricked wrt.........

    Hi unfortunate linksys owner,

    I succesfully de-bricked my version 2.2 wrt54g yesterday.

    I bricked it by ALSO trying to get the 32 mb ram working under dd-wrt . ( and still don't know HOW to get that working !! although the 2.2 should have the correct hardware )

    So ended up with a fast blinking power led and nothing else .

    Q--> is the DMZ led active ?? ,..AND is one of your network led's active ??

    a fast blinking power led and nothing else is a corrupted bootloader
    a fast blinking power led AND dmz indicates corrupted kernel

    If tftp does not work , keep in mind you only have 2,5 seconds to get the programm to work , otherwise connection will be lost !!

    -- THAT is the reason why you should switch the boot-wait option always to ON --

    If this failes ;

    The best solution will be jtagging it , so re-flash the cfe.bin to it.

    First , the utility's allow you to erase the entire flash , so this will get rid of all errors .

    Then do a flash of the cfe.bin , which re-flashes the boot loader .

    After that , do a tftp flash of whatever kernel you like , don't forget to programm the cfe.bin before you flash it into the router.

    the utility's to do a jtag AND the way to make the header and cables are done by " hairydairymaid " , you kan find them in the download area.

    good luck

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice