Bricked WRTSL54GS

Discussion in 'Cisco/Linksys Wireless Routers' started by Mike239, Aug 25, 2006.

  1. Mike239

    Mike239 LI Guru Member

    I was switching the firmware on my WRTSL54GS from HyperWRT Thibor15c to the Linksys v2.00.5 firmware, when I got a timeout error in Firefox at the time the flash normally completes (I forgot to clear the NVRAM before flashing). After waiting several minutes more, I reset the router. Now, the router refuses to boot itself either after a reset or power off, and the power indicator just keeps flashing endlessly. In short, the thing is now a brick. Unless there's some sort of secret fail-safe option I don't know about, I figure my options are:

    - Debrick it by building a JTAG cable, opening the box and soldering a header onto the proper interface, and then re-programming whatever needs to be re-programmed,
    - Try returning it and claiming warranty, or
    - Spending another $100 on a new one.

    I have little soldering experience, but am willing to try the first option if I'm certain that a warranty claim is out of the question and I would otherwise have to buy another one.

    Any thoughts, comments, or help would be greatly appreciated!
  2. Toxic

    Toxic Administrator Staff Member

    I thought i had done this before but i found the WRTSL54GS did respond to ping on bootup.

    setup a staic IP on your wired pc. for this example i am guessing the ip address of the router is

    so setup Static ip address for the pc like so


    now using tftp (available from our downloads section) enter in the details including the new firmware you want to us.

    then turn the power off from the WRTSL54GS. now open up a command prompt and type

    ping -t

    now turn on power on the router, as soon as you do send the ping command. if you receive a ping back from the router, this may only last 5-10 seconds) you can then use tftp utility, and send the firmware withing this time frame window.

    load the tftp utility enter the deatils ip, password, select firmware. turn of/on router again, then upgrade (send the file)the routers firmware.

    hope this works.
  3. Bird333

    Bird333 Network Guru Member

    I only had like 1 second to unbrick mine. Timing was really critical.

    I use WinXP pro
    This is what worked for me.

    1. Set network card to 10meg half-duplex (may not be necessary)
    2. Manually set the NIC address to 192.168.1.* subnet, gateway (router default)
    3. Open command prompt and type in 'tftp -i PUT dd-wrt-mini.bin' DON'T hit enter yet.
    NOTE: use the bin that is specific to your router.
    4. Plug in the router's power, watch the LAN leds. Here is the timing part. When the led comes back on for the cable that you have plugged in, hit the enter button. You really have to anticipate when it is gonna light up so you can hit enter at the moment it lights.

    If you timed it right the firmware will load in a few seconds and then automatically reboot.

    You should have your router back.

    If you get this error 'error on server: code pattern incorrect', your timing was right but you used a firmware that was not specific to your router (i.e. the generic version).

    Good luck!
  4. Toxic

    Toxic Administrator Staff Member

    if your using dd-wrt make sure you have the wrtsl54gs version
  5. Mike239

    Mike239 LI Guru Member

    Well, I first tried what Simon suggested, and fortunately, the router was still responding to pings. I was able to use the TFTP tool to reflash it to v2.00.5 with no problems. The router is now de-bricked and operating normally!

    Thanks for all the help!
  6. Bird333

    Bird333 Network Guru Member

    Glad you got it working. Mine only responded to pings every now and then.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice