Bricking my WRT54Gv3 over and!

Discussion in 'DD-WRT Firmware' started by m00nstone, Dec 28, 2005.

  1. m00nstone

    m00nstone Network Guru Member

    I've flashed my WRT54Gv3 four times now (DD-WRT Firmware). Every flash has bricked it. I then have to recover using the 15-16 pin method.

    This is what I've done:

    1) reset it to factory defaults
    2) flash using DD-WRT Firmware (from web interface)
    3) Try to connect to it (I'm static

    I've tried the following firmware:

    Everytime I flash, I get "upgrade is successful", then I notice the power light is flashing rapidly, and I can't connect to the router at all.

    I'm a noob, am I completely stupid?
  2. matthiaz

    matthiaz Network Guru Member

    Leave it running after you flashed for like 5 mins. Then unplug and replug your router. That might work.
  3. m00nstone

    m00nstone Network Guru Member

    Still not working...

    Well, I tried that. Is anyone else having this problem?
  4. Couledouce

    Couledouce Network Guru Member

    No, but I don't have a v3...

    If it is happening systematically, surprise, surprise you are doing something wrong every time.

    So maybe you could try listing exactly in detail everything you do and somebody will notice some little insignificant detail that you have missed...

    Good luck.
  5. mazilo

    mazilo Network Guru Member

    I have done flashing my WRT54GS v3 with the GENERIC v2.3 DD-WRT mini through the Linksys GUI (webmenu) firmware upgrade. First before and after this upgrade, I reset my router. Then, I flashed the GENERIC v2.3 DD-WRT+VoIP through the DD-WRT GUI (webmenu) firmware upgrade, let the system sit there for about five minutes, and then do a reset. My WRT54GS v3 with DD-WRT+VoIP has been running since with one minor exception that the default configuration of SIPatH, acting as an Outbound Proxy server, seems to be unable to punch through the firewall of the DD-WRT. That said, my FWD lines configured on my WRTP54G connected to my WRT54GS with DD-WRT+VoIP only give a 1-way audio. I could do some port forwarding @WRT54GS router; however, that really defeats the purposes of having the SIPatH running on the router.

    I was told that ONLY the GENERIC version can be flashed using the GUI (webmenu) firmware upgrade. The rests must be flashed through the TFTP options; however, I spotted this post that said differently. I honestly can't and will not even bother to confirm its integrity. You sure can find out yourself if you are willing to take the risk. Feel free to report back here.
  6. bmr501

    bmr501 Network Guru Member

    bricking v3 router

    I also have a ver3 and it bricks every time the same firmware,I have tried other firmwares and they work fine,I followed all the instrutions there are and read all the posts but no go at five times,I gave up and went back to the stock for now .Sorry I meant the ver23 beta from ddwrt is giving me problems,my mistake.
  7. m00nstone

    m00nstone Network Guru Member


    I'm back to using stock as well.

    I just want to confirm. The first web flash is done from the stock firmware, after reseting to defaults...

    I agree, we must be doing something wrong..
  8. Sumi

    Sumi Network Guru Member

    Hi, I hope you're flashing it with a STATIC IP CABLE connection.. since flashing from wireless, or with DHCP... well it will not do the job:)

    however, with your computers network interface cards connection set to 10megabits with half duplex link priority, and after assigning a static internet protocoll address for it, such as, with a netmask of, and assuming, that you're using internet explorer, just to be sure (it works for me, please do not start an explorer flame now, maybe lynx would do the job as well:D lol), so after a factory reset, do a start > cmd, then do: ping, as if everything is fine, you should get a reply from the router. so after this, from your routers webpage, such as, try to upload the mini-generic firmware (wich you have unpacked first, so you have a blabla.bin file), then wait a couple of minutes, don't close the browser, no poweroff, no nothing (maybe going and having a tea is the best idea:)) you really should have your firmware update done. after this has succseeded, (no need to powercycle your router, never ever during this procedure), enter the web based configuration, and upload the std-generic firmware in your router, repeating the same steps above mentioned...

    hope you'll have fun:)

  9. mazilo

    mazilo Network Guru Member

    That's not true. I had flashed my WRT54GS v3 with a dynamic IP address @100Mbps and no problems at all. However, I must agree with you to avoid flashing using a WiFi connection.
  10. BeHappy

    BeHappy Network Guru Member

    Just to share my experience when upgrading from any 3.firmware versions on wrt54g/gs.
    Always use cmd - ping - in conjunction with firmware upgrading so you can determine the state of un-/success.
    Before upgrading does try a ping to your wrt54g/gs
    1. Reply from bytes=32 time=9ms TTL=100
    -> Please remark TTL=100. It does indicate that your router is in unstable state, typically with a wrong soft/hard reset or a middle state under debricking proces. It is not recommended to upgrade further with any 3.firmware. Your choice here is either trying a long hard reset or better up/downgrade it back with the right stock firmware

    2. Reply from bytes=32 time=9ms TTL=64
    -> Please remark TTL=64. It does indicate that your router is in stable state, here you go, imposible to fry your router with the following upgrading.
    Typically with DDWRT after the upgrading proces is successfully you must do a hard-reset before you get connection with the router. Ping it again to be sure the router is alive before you get panic and make some uwanted steps to brick/debrick you router. :sadbye:
  11. m00nstone

    m00nstone Network Guru Member

    stuff I've tried

    Ok, I had tried the 10mbit (half duplex) as well and same result. I've been using a static IP all along and I run a perpetual ping on (-t). I'm using Firefox 1.5.... Should I be using IE. Anyone care to comment...
  12. mazilo

    mazilo Network Guru Member

    I don't think you can make such a justification based on the above. I have a WRT54GS v3. with DD-WRT+VoIP v2.3 connected to the cable modem. My computer is connected to WRTP54G (with linksys stock firmware) and then to the WRT54GS, i.e. WRTP54G is in the middle between my main router, WRT54GS, and my computer. When I pinged my WRTP54G, here is what I got:
    Pinging with 32 bytes of data:
    Reply from bytes=32 time<1ms TTL=255
    Reply from bytes=32 time<1ms TTL=255
    Reply from bytes=32 time<1ms TTL=255
    Reply from bytes=32 time<1ms TTL=255
    Ping statistics for
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms
    When I pinged my WRT54GS, here is what I got:
    Pinging with 32 bytes of data:
    Reply from bytes=32 time=1ms TTL=63
    Reply from bytes=32 time=1ms TTL=63
    Reply from bytes=32 time=1ms TTL=63
    Reply from bytes=32 time=1ms TTL=63
    Ping statistics for
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 1ms, Average = 1ms
    R U telling me the TTL=255 from my computer to my WRTP54G is showing that my WRTP54G is at a breaking point, thus it is not fit for a firmware upgrade? It just happens there is no open firmware I can try to prove you wrong; however, if anyone out here has this WRTP54G, please prove me wrong and I will appreciate that. I sure would like to see what TTL you will get, too.
  13. BeHappy

    BeHappy Network Guru Member

    Here is not an issue who has right or not. Maybe it only works for me based on my serveral attemptions to up/downgrade and debrick my 2 units wrt54g/gs.

    The most important thing to note that there are 2 states you must be aware of
    1. Connection when the bootloader is up (interstate to do like tftp, debrick proces) and here is my ping with TTL=100
    2. Connection when the router is up (internet access, router configuration) and here is my ping with TTL=64

    Knowing your router will spare you a lot of trouble.
  14. matthiaz

    matthiaz Network Guru Member

    Nah, I'm flashing always DHCP with WiFi and never encountered an flashing problem. But I have a strong link with 100% no loss at all.
  15. NateHoy

    NateHoy Network Guru Member

    Actually, the WRTP54G is not fit to be a ROUTER, much less not fit to take a firmware upgrade, since (at least in my case) it's a locked, proprietary unit that is beholden to its Lord and Master, Vonage, and gets its firmware upgrades from them without telling me. ;)

    Seriously, I have one of them, and life is SO much better for me since I put a WRT54G w/ HyperWRT Tofu in front of it, and relegated the poor little WRTP54G to Vonage duty only. It's a fantastic VoIP device, despite its shortcomings as an actual router or wireless access point.

    Anyway, to your TTL question: The WRTP54G *always* pings with a TTL of 255, to my knowledge. That's the normal operation of that particular beast (note that I just pinged it from the WAN port, since I don't have anything plugged into it any more, but I think the LAN port also pings at TTL=255, and I've never seen another TTL value from it).
  16. mazilo

    mazilo Network Guru Member

    Re: bricking v3 router

    Is there a possibility the firmware you downloaded is corrupted? If so, then you may want to re-download the firmware. If no, then visually inspect which firmware is larger. If the DD-WRT firmware is larger and causes your WRT54GS v3 to brick, then there is a possibility your WRT54GS flash/RAM is corrupted. In this case, you will need a new one.
  17. m00nstone

    m00nstone Network Guru Member

    Seems fine...

    I can still flash and run the stock firmware without a problem, which would seem to indicate the flash is fine. Regarding the previous discussion on TTL on pings. Are you guys saying that ping stats could indicate a problem with the router prior to flashing? You lost me on that whole discussion.

    Anyway, here's my stats:

    Reply from bytes=32 time<1ms TTL=64

    They're about perfect...
  18. m00nstone

    m00nstone Network Guru Member

    One more thing..

    Is there any sense in flashing the generic mini after setting my NIC interface to 10mbit half-duplex?

    Here are all the details I can think of giving re: what I've been doing:

    1)at 100mbit full duplex, using static ip (wired) on /24
    2) using firefox 1.5
    3) first I reset my WRT54Gv3 to factory defaults using the web interface
    4) then I've flashed dd-wrt.v23_mini_generic.bin
    5) then I wait over five minutes without doing anything
    6) come back, power led flashing rapidly (bricked)
    7) click continue (still bricked)
    8) power cycle (bricked)

    Anything I might be leaving out? Questions... :(
  19. dellsweig

    dellsweig Network Guru Member

    Re: One more thing..

    Well, Last week my WRT54G V2 finally gave out during a flash. It would not come back - could not restore it by any method.

    I RMA's it with Linksys, Mr FedEx just brought me a brand new WRT54G V4 - shrink wrapped!! Care of Linksys

    Great Service

    I powered it up, web flashed in DD-WRT Final (Mini-generic)

    No Problem.

    Configured my client bridge - connected to my AP and it is up and running

    You must either have a bad image or there is something you are not telling us
  20. Longs

    Longs Network Guru Member

    My first post here, I wanted to use a WRT54G V4 as a wireless bridge. I ended up bricking it along the way and was able to recover it as follows:

    I had downloaded the latest Linksys firmware for my V4 from Linksys. I also had downloaded the latest dd-wrt mini and standard.

    I was accessing it through a PC with a static IP set and I used the 15-16 pin jump to get a response from the PING -t command as outlined in the recovery process.

    Without unpowering or disconnecting either the LAN cable or power, I used TFTP to immediately flash the WRT54G with the latest Linksys firmware.

    I then used the web interface at to flash with the dd-wrt generic mini version.

    That version allowed me to set the WRT54G into "Client-Bridged" mode and use it as a wireless ethernet bridge. Now it's connecting my son's XBOX in the basement to the internet through my Netgear router.
  21. BrainSlayer

    BrainSlayer Network Guru Member

    just to remind everyone to some points about upgrading

    for safe upgrading from the linksys fw, use always the mini generic firmware from web interface. everything else will brick your router since the linksys fw doesnt like binaries greater than 3 mb. this is a linksys bug, not mine.
    after upgrading once to mini, you can upgrade to std, vpn or voip. this information can be found too in the hwsupport.txt file on my web site or in the distributed zip files
  22. rev0lver

    rev0lver Network Guru Member

    Just read your post in time. Was just going to upgrade from official to std dd-wrt - but now will upgrade to mini first.

    *** BiG Thanks goes out to you BrainSlayer for all your hard work and dedication. ***
  23. sfernan

    sfernan Network Guru Member

    Do you recommend using the mini for V3 as well? or just V4?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice