Bug? remote host shows from

Discussion in 'Sveasoft Firmware' started by muki, Dec 29, 2004.

  1. muki

    muki Network Guru Member

    I have a static IP Linux server and a WIFI Laptop with DHCP IP. If I use the laptop to connect the Linux server through ssh, I find on the Linux server the laptop is shown from which is the router's IP address. Like this:
    root pts/0 Dec 28 22:29 (

    Actually my laptop has its own DHCP IP:
    Connection-specific DNS Suffix . :
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :

    I can't see this problem if I connect the server from my DHCP desktop.

    I tried to flash back to official Linksys firmware, I couldn't see this problem either.

    I am using Satori 4.0. The router is WRT54GS.

    Is this a bug?
  2. muki

    muki Network Guru Member

    I guess it is a bug.

    Here is the result of tracert from the DHCP XP client to the Linux server (server IP


    Tracing route to server[]
    over a maximum of 30 hops:

    1 2 ms 1 ms 1 ms server[]

    Trace complete.

    Here is the result of traceroute from the Linux server to the client:

    $ traceroute
    traceroute to, 30 hops max, 38 byte packets
    1 * * *
    2 * * *
    3 * * *
    4 * * *
    5 * * *
    6 * * *
    7 * * *
    8 * * *
    9 * * *

    PING is fine:

    $ ping
    PING ( 56(84) bytes of data.
    64 bytes from icmp_seq=0 ttl=128 time=2.56 ms
    64 bytes from icmp_seq=1 ttl=128 time=1.74 ms
    --- ping statistics ---
    2 packets transmitted, 2 received, 0% packet loss, time 1001ms
    rtt min/avg/max/mdev = 1.740/2.153/2.566/0.413 ms, pipe 2
  3. pkitester

    pkitester Network Guru Member

    I guess I don't get it. What is the bug?

    I'm guessing the bug is you haven't configured your linux machine correctly, and has nothing to do with the router.

    Try looking at "netstat -nr" output on the linux box and make sure it is correct.
  4. muki2

    muki2 Network Guru Member

    Thank you for reply. This is a Satori specific problem. I've tried the official Linksys firmware and HyperWRT. Neither can find this problem.

    Network mask on my Linux box has been set to a standard Class C network:

    netstat -nr
    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface U 0 0 0 eth0 U 0 0 0 eth0 UG 0 0 0 eth0

    The Linux server IP:
    My Laptop DHCP IP:
    Linksys Router IP:

    The Laptop uses Wireless G Intel PRO/Wireless 2200BG miniPCI card. My WLAN uses WPA security sheme.

    Connect from the Laptop to Linux server, using ssh or whatever, the latptop's source IP is always shown on the Linux box.

    The Linux box can't traceroute to the Laptop, though can Ping the laptop.

    Maybe something is wrong with my router.
  5. muki2

    muki2 Network Guru Member

    Just wrote a broadcast program. The broadcast packets sent out from the Laptop, can not be received by the Linux box. Obviously they are not in a same subnet/broadcast domain. Guess it is the firmware's implementation feature: WIFI and wire LAN are two different subnets.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice