Cable Modem Issue L2TP

Discussion in 'Tomato Firmware' started by snagar, Nov 21, 2007.

  1. snagar

    snagar LI Guru Member


    I have just flashed my Linksys GLv1.1 to the latest Tomato firmware.
    All was well, until I tried to browse the internet.
    I used my ISP dialer, and it seemed to connect.
    I then tried to reach google or other sites, but I always ended up with error.
    Since I did not had this issue with the original Linksys firmware, I understand it is something to do with the Tomato configurations.
    My Tomato configuration is set to default (DHCP).
    I checked the multicast under firewall (no idea if it is relevent).
    Oh, and I changed the look and fill to dark blue :wink:

    Is there anything I ned to do in order for my internet to work ?
    I have to remind again that my dialer seems to connect, no errors.

  2. snagar

    snagar LI Guru Member

    I have just tried again to connect and browse through the router.
    The cable connection is fine.

    Here is the log I took when I tried to reach one of the internet sites:

    I have no idea what this output means, but I hope you can help with.
  3. PeterT

    PeterT Network Guru Member

    From the title of this thread, I presume that your cable ISP uses L2TP. If so, change the Tomato settings from DHCP to L2TP and supply the required info (Username/Password/L2TP Server at a minimum). You might also have to override the MTU. This is all done from the http://<router_ip_address>/basic-network.asp page.

    Once this is done you should NOT have to use the dialer application from your PC; the router should be handing the L2TP connection with your ISP.
  4. snagar

    snagar LI Guru Member

    The issue that I have with the L2TP is that the ISP does not want to give me the IP address, only the name
    They told me that they will change the connection type to MPLS.

    Is this the only way to make my internet work ?
  5. amnon23e

    amnon23e LI Guru Member

    smile's ip is:

    use that as the l2tp server
  6. snagar

    snagar LI Guru Member

    Thanks for the IP.
    It worked that way with my L2TP connection settings.
    The problem is that after ~60min the connection dropped even though I had and IP.

    My ISP has resolved the issue by assigning me MPLS connection.
    So now the connection does not drop.

    Thanks for everything :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice