Can you help me fix my WAP54G?

Discussion in 'Networking Issues' started by BrummyGit, Oct 15, 2004.

  1. BrummyGit

    BrummyGit Network Guru Member

    A little while ago I tried to update my WAP54G to version 2.06. I have 2 of these and the first went fine - upgrade to 1.9 first, then upgrade to v2.06. My second unit failed on step 2 - upgrading to 2.06. All seemed to be OK, but after a reboot I now always get a constant power plus a red diag light.

    Linksys support had me pressing reset buttons for minutes at a time etc but were basically useless and at the end of the day and couldn't get me working again.

    Can anyone tell me how to revive it?


  2. Toxic

    Toxic Administrator Staff Member

    try reflashing the router with tftp.exe and the normal binary file as soon as you turn the power on the router at boot up before the self diagnostics is suppose to take place.
  3. BrummyGit

    BrummyGit Network Guru Member

    Is there some documentation on how to do that anywhere?

    Documentation, DOH! I can't believe that having worked in IT for about 20 years I ask for documentation :lol:
  4. BrummyGit

    BrummyGit Network Guru Member

    I have tried using the standard Windows XP TFTP.EXE to send the file in a standard linksys firmware upgrade to the router as suggested.

    I'm not sure if I am doing it correctly. The ethernet port looks alive and the lights show activity but the TFTP just times out.

    Can anyone give me a better steer on how to do this?

    Many thanks
  5. BrummyGit

    BrummyGit Network Guru Member

  6. Guyfromhe

    Guyfromhe Network Guru Member

  7. howser

    howser Network Guru Member

    Also -- and as a last resort you could always RMA it to Linksys. This is something that's certainly covered by their RMA process.
  8. Viperiontech

    Viperiontech Network Guru Member


    Rather than just reflashing, I would re-flash the unit with the ORIGINAL firmware that was installed when you bought the unit.

    After re-flashing with original firmware, unplug the unit for 5 minutes, hold the factory reset button in, plug it back in and you should be OK.

    Let us know how it works out for you.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice