Cannot access router via eternet ports, wireless works ok.

Discussion in 'Cisco/Linksys Wireless Routers' started by methaneb, Dec 24, 2006.

  1. methaneb

    methaneb LI Guru Member

    WRT54G v2 running DD-WRT v24 12/21/2006

    Background: I attempted to perform the SD card mod on my WRT, after finishing the job and booting the router, I was unable to access it from the ethernet ports. I tried to hard reset... same results. I removed all of the wiring from the board and removed all of the solder I could find... it does not appear that any pins on any chips are soldered together (the main concern being around RP3).

    First observation: Using my laptop (with both wireless and wired cards) I attempt to run a ping -t I then boot the router. When the router first powers on (in boot_wait mode) the pings succeed. When the firmware loads, the pings fail. I am unable to communicate with the router at all.

    My revelation: I noticed that after hard resetting the router, the ssid "dd-wrt" was visible on my wireless connection manager. Upon connection to the SSID, I can use the web manager, ping the router, telnet, ssh, the whole nine yards. When I disable the wireless and attempt the wired connection, the pings fail.

    This is what I have tried:

    -Every debrick guide I could find (except JTAG... have cable on order)
    -Connecting through all 4 LAN ports
    -Connecting WAN port to my WRT350N with DHCP enabled... WRT350N shows no sign of a device being connected or any DHCP leases.
    -Multiple hard resets
    -Flash to Linksys firmware (via TFTP through ethernet)
    -Flash to DD-WRT mini (TFTP via ethernet)
    -Upgrade to DD-WRT Standard (via web interface through wireless)
    -Disable internet connection and use WAN port as a LAN port
    -Set wired NIC to obtain address via DHCP (always fails)

    When I disable the wireless and attempt to ping the router, the Activity LED for that port flashes in sync with the ping attempts, but the router does not respond.

    I've searched the forums up and down and seen people with similar issues, tried what they were successful with and still haven't been able to revive the ports. Its odd because I can successfully ping the router via ethernet when it first boots, but not when the firmware is running. I get the same behavior regardless of which firmware I'm running (stock Linksys included).

    Anyone have any ideas?
  2. Yacurmana

    Yacurmana LI Guru Member

    Did you try to force the NIC at 10 Mbps half duplex ?

  3. u3gyxap

    u3gyxap Network Guru Member

    Try to see if you have any MAC addresses assigned to the LAN and WAN interfaces of the router. Try to change them via the nvram.
  4. Toxic

    Toxic Administrator Staff Member

    Is the router being added to the arp cache? open command prompt and type in

    arp -a

    if the router is not there try adding it to the arp cache then try again.


    arp -s 00-aa-00-62-c6-09 = Adds a static entry.
  5. methaneb

    methaneb LI Guru Member

    -NIC is set to 10mbps half duplex
    -All interfaces have MAC addresses assigned
    -In my laptop, I deleted all of the address from the arp cache, then connected it via ethernet to a LAN port. The arp cache on the laptop was then populated by the correct ethernet and mac address of the router's LAN ports (had the wireless card disabled to make sure I wasn't getting anything from that). Still not able to ping the router.
    -Re-enabled the wireless... then telnetted into the router... the only thing visible in the arp cache of the router is the IP and mac address of the wireless card.
  6. u3gyxap

    u3gyxap Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice