Cannot configure Linksys E2500 to use PPPoE

Discussion in 'Cisco/Linksys Wireless Routers' started by linxen, May 27, 2013.

  1. linxen

    linxen Reformed Router Member

    I am using the Ubuntu Linux 12.04 operating system and have a DSL internet connection. I have been able to use the Linksys E2500 router with Automatic Configuration – DHCP setting and my modem in PPPoE mode. But I would like to be able to use my router with the PPPoE connection setting so I can use a firmware like Tomato which has more advanced features like bandwidth logging.

    I was able to log into the configuration page of my SpeedTouch ST516 modem and set it to bridge mode according to the instructions here:

    I then tried to set up the router to use PPPoE according to the instructions here:
    I get the message "Can not get an IP address from PPPoE" when I try to set up the connection in step 4. Resetting the router does not help. I also tried running 'sudo service networking restart' and the 'sudo dhclient -r; sudo dhclient' in Ubuntu's terminal but still got the same message.

    I double checked that I used right login information and vpi from my ISP. I used the same info to configure the modem to PPPoE mode again so I can connect to the internet. I had to reset the modem back to factory defaults using the reset button at the back to access the modem configuration page after I disconnected the ethernet cable from the router and plugged it into the modem.

    Is there a possible bug with using PPPoE with this router? Is there anything else I can try besides what is stated in the instructions linked to above? Since there doesn't seem to be a version of Tomato for the E2500 I thought it's better to try to see if I can get PPPoE mode to work with the Linksys firmware first.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice