Cannot flash WRT54GSv4 Firmware

Discussion in 'DD-WRT Firmware' started by talknmime, Dec 6, 2005.

  1. talknmime

    talknmime Network Guru Member

    I have a WRT54GS v4.

    I went from Official Firmware 1.05.2 to dd-wrt.v23_mini_generic.

    After that I tried to upgrade to dd-wrt.v23_mini_wrt54gsv4 and it doesn't work. I just get 'Upgrade are failed.' Any ideas? I also cannot seem to revert back to the Official Linksys firmware. I get the same error. Is it not possible to go back?

    I'm a noob so please help.
  2. sded

    sded Network Guru Member

    What browser are you using? If not IE, give it a try. I have had similar problems with Opera9, have read of the same problems with Firefox.
  3. THILE

    THILE Network Guru Member

    Linksys WRT54G/GS (any version) flashing notes:

    for upgrading from original linksys firmware, please use the generic mini version
    and flash it from web interface.
    after this first flashing you can upgrade to any other distribution too. for webinterface
    flashing just use always the included generic binaries. the rest is only made for tftp upgrades.
  4. talknmime

    talknmime Network Guru Member

    Being a noob, I'm not familiar with TFTP. How do I do it? Can I do it through Windows? Is this how I would restore the original Linksys firmware?
  5. pewter

    pewter Network Guru Member


    first things first.
    you do have a pci-networkadapter or something, do you?
    it's really risky to update your firmware via wlan, you know.
    debricking the wrt is surely possible, but bricking it for the first time
    might give you a nasty turn.
    here is a howto i found on the internet.

    Firstly download the new firmwarefile unpack it to your c: drive and rename it to "code.bin"

    1. Fix the static IP address:, subnet, and the gateway address

    2.In the properties of your lan card, change the speed to 10 Mb Full duplex.

    3. Go to run, type "cmd", type "ping -t" and hit enter. If the ping is ok (if it's not timed out), then you can go to next step

    4. Go to run, type "cmd", type "cd c:\", then type: "tftp -i PUT code.bin" but DON'T HIT ENTER YET!

    5. Now, hold down the reset button of your router for 30 seconds, after releasing it, wait one to two seconds and hit immediately enter button in that window, which was described in the step four.

    6. After ten seconds you will hopefully see message: "2876416 bytes in 10 seconds, 287641 bytes/s"

    7. Now wait for a while and you will see, that the ping is ok now and and you can launch the web configuration utilyty.

    8. Do a factory defaults and change back settings of your network card and tcp-ip properties.

    works fine.

  6. 69mws

    69mws Network Guru Member

    Are you sure about full duplex? Most guides I stumbled upon were recommending 10 Mbit half duplex.

  7. pewter

    pewter Network Guru Member

    all i can say is, it worked more than one time for me.

  8. talknmime

    talknmime Network Guru Member

    Invalid Password??

    Thank you very much for the directions. However I am running into a snag. I get the error message "Invalid Password". I have gone into the web interface and changed the password so there is none but it still gives me that error.

    Any ideas?
  9. h122005

    h122005 Guest

    I recently had the same trouble, and I just list the steps that I have done in order to go back to the original linksys firmware.
    (I got the information in some forums...)

    1. Obtain tfpt GUI somewhere in the web. Get tftp GUI that allows you to specify the password.

    2. Reset your router (press reset button for about 30 seconds).
    3. Run tfpt GUI, fill out the information. Do not press the upgrade button yet.
    4. Press the reset button on the router while pulling out the power plug for a few seconds and plugging back the power, then release your reset button.
    5. As soon as you release the reset button, hit the upgrade button of tftp GUI.
    6. If the upgrade is not successful, you may need to do step #4 and #5 several times.
    7. If the upgrade is OK, press the reset router button for 30 seconds, unplug router power and then plug the router power again, you now should be back to the original linksys firmware.

    Let the people know if this works for you.
  10. pewter

    pewter Network Guru Member

    you get the 'wrong password' error if try the upload to late after you reconnected the router to the power supply.
    u have to get him while he is waiting for an emergency upload in 'boot_wait' state.
    it's afaik in default 0.5 sec for the gsv4. usually i have to try it
    sometimes before i can succsessfully upload too.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice