Cannot install Tomato Shibby on Linksys E1200v1

Discussion in 'Tomato Firmware' started by byoussin, Mar 4, 2016.

  1. byoussin

    byoussin New Member Member

    I have recently discovered that I need QoS on my Linksys E1200v1 since Skype calls are unstable due to my local network.

    I have tried to install Tomato Shibby on it, and failed.

    Below is the full description of my actions. This forum does not yet allow me to post links in any direct or indirect form and for this reason I have not been able to indicate the sources of my info and my downloads. If these links are necessary, please indicate and I shall try to post them in my responses.

    According to Tomato by Shibby Router List, Linksys E1200v1 is supported by Tomato Shibby version K26RT-N.

    I downloaded releases 133 and 110 from Tomato by Shibby K26RT-N for Linksys E series download pages,
    and tomato-E1200v1-NVRAM64K-1.28.RT-N5x-MIPSR2-110-Mini.bin

    I extracted the bin files from the zips.

    I did 30-30-30 reset on the router: pressed the reset button on its bottom with ballpoint pen for > 30 seconds, then unplugged the power supply cord from the router while still keeping the reset button pressed, and kept it pressed and unplugged it for another >30 seconds, then plugged the power supply while keeping the reset pressed, and kept it pressed for another >30 seconds.

    I waited for the router to come up and did Firmware Upgrade with one of the bin files. The router started upgrading but later reported "Upgrade failed".

    I waited for the router to come up again, did another 30-30-30 reset and tried Firmware Upgrade with another bin file, with the same result.

    I repeated the procedure (including 30-30-30) with the third bin file, with the same result.

    For some of the files, Upgrade failed was reported just after a few percent done while with others it progressed over 11%.

    After that I disconnected the second computer from the router (it was connected by a wire), checked that only one computer appeared in its DHCP table (the one from which I was trying upgrading it), and repeated the entire procedure with doing 30-30-30 for each of the three files. The result was the same.

    I would appreciate any help.
  2. txnative

    txnative Addicted to LI Member

    I probably would also tried using a different browser, next also use a static ip on your machine, disable windows firewall for the moment . I have read some users complained about the same problems in linksys forums with some positive and not so positive results, and some resorting to using tftp either windows or download tftp.exe and try to install the firmware again...
  3. byoussin

    byoussin New Member Member

    @txnative Many thanks for your answer. I see from it that my problem is that the file upload does not complete.

    I stopped all applications on my comp that used the same internet connection (as far as it is possible:p), and used another browser that did not have any other tabs open. Windows firewall is not applicable as I am using a Linux machine. The result was unfortunately the same.

    I tried tftp. I established tftp connection to the router successfully. However, which directory should I put the file? I need to specify it explicitly as tftp does not allow listing files and directories.

    Many thanks again.
  4. txnative

    txnative Addicted to LI Member

    You should be able to drag and drop the .bin file into the tftp use this or have you tried to use the tftp.exe you can download it within the same dd-wrt link? Which browser are you using?(Using Chrome usually works) Sorry for the late response hope the information helps.
  5. tvlz

    tvlz LI Guru Member

    The E1200v1 has only a 4MB flash, you need to use a firmware that has a max size of 3776K, otherwise it won't fit.
  6. byoussin

    byoussin New Member Member

    @txnative Many thanks for the link to dd-wrt site with directions for tftp upload!
    (I have not found them elsewhere.)

    Unfortunately, I have not succeeded: when the tftp transfer started, the indicators on the router blinked fast for a few seconds and then the lamp with (I) sign started to blink slowly and continued doing this for over 10 minutes (as much patience as I had to wait), and during this time router refused connections. Doing 30-30-30 after that restored the original firmware and the router came back.

    Giving up on this router - will have to get something else.
  7. byoussin

    byoussin New Member Member

    @tviz Yes, Shibby's files that I tried to upload, are of the correct size you indicated.
  8. txnative

    txnative Addicted to LI Member

    Yes, I can image that there is a problem with some routers not responding properly for firmware updating issues not sure were to go with that other than purchasing another router or going into the router soldering pins and using a usb serial to uploading firmware but that probably not what you are willing to do. Have you tried uploading dd-wrt before?
  9. byoussin

    byoussin New Member Member

    @txnative I have not tried to upload dd-wrt because none of the sites mentioned that it had QoS which was my interest.
    Anyway giving up on this. Thanks for your help
  10. txnative

    txnative Addicted to LI Member

    Well understood and i feel your pain. I for one need a working Qos in order to work out the bufferbloat and maintain an overall through put connection for my little network, mostly wifi related but two devices on lan, pc and PS3. Qos on dd-wrt for my router doesn't work out of the box but is configurable currently using a belkin f7d4302 and have a linksys e3200 and switch out from time to time for different purposes. Open source is great and you my find one has what one doesn't but it is great to have options and come to appreciate how hard these guys do what they do in order for us to have a choice.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice