cannot ping from putty to outside IP

Discussion in 'Tomato Firmware' started by JustinChase, Apr 16, 2014.

  1. JustinChase

    JustinChase Networkin' Nut Member

    I'm running Tomato Firmware v1.28.7503 MIPSR2Toastman-RT K26 USB VLAN-VPN-NOCAT on my e3000 router, and everything seems to work fine. That is until I discovered I am unable to wget an https: address from within Putty on a local machine. I get this message...

    wget: unable to resolve host address âdl.dropboxusercontent.comâ

    I tried to PING google servers and got no response...

    root@media:~# ping
    PING ( 56(84) bytes of data.
    --- ping statistics ---
    998 packets transmitted, 0 received, 100% packet loss, time 997006ms

    I then tried to PING from the router page to the same IP with no problems, so there seems to be some problem with the router forwarding the request to the oustide. I've looked thru the settings, but don't see any obvious stupid errors that I've made. I wonder if it's how I have my internal IP ranges setup...

    Current Routing Table, Wireless & VLAN settings are shown in the attached images.

    Thanks in advance or any help!!

    Attached Files:

  2. rs232

    rs232 Network Guru Member

    The info is incomplete. Where (phisically/logically) sits this machine where ping to google fails?
  3. JustinChase

    JustinChase Networkin' Nut Member

    sorry, the machine is a laptop, connected to the LAN1 (br1) VLAN via wifi. My laptop IP is

    I hope that's all the information you need, but if not, please let me know what else you need and I'll get back as fast as I can with the missing information.

    Thank you
  4. JustinChase

    JustinChase Networkin' Nut Member

    Anyone got any ideas? I need to be able to download from the internet using putty.

  5. kthaddock

    kthaddock Network Guru Member

    Seems that your router doesn't see any public ipnumber, probably double NAT problem. (VLAN15)
  6. JustinChase

    JustinChase Networkin' Nut Member

    My router sees outside IP numbers just fine, almost everything is working great; except when I'm connected to my server via putty, and try to update software from within putty, then it cannot get past my router to the outside.

    I don't know what "NAT problem" really means, nor how to determine if it's my problem, nor how to fix it.

    I also don't know what this means, or is trying to tell me - (VLAN15)

    Any suggestions on how to isolate and resolve the issue?
  7. kthaddock

    kthaddock Network Guru Member

    Recording your routing table you don't have public ip on your router, just from modem or second router.
    My suggestion is to set your modem in BRIDGE mode and try agian.
    If it's a second router you have to forward ports are used by your server.
    Then you probably have public ip to your VLAN15.
    Last edited: Apr 27, 2014
  8. Grimson

    Grimson Networkin' Nut Member

    You must describe your configuration in detail. How are you connected to the Internet. Where on the network is your server located. If you have physical access to the server check whether you can ping the wan from the normal console. If you can't reach the wan from the server console, check the network configuration of the server it may be missing the default gateway.
  9. JustinChase

    JustinChase Networkin' Nut Member

    My ISP brings a DSL line to the home into their modem (HUAWEI HG532e), which is also a wireless router. I have the wireless turned off, and every machine in the house connects, wired or wireless, to the router (e3000) directly. The server is set to use a static IP of, and is wired to ports 2 and 3 of the router, which is LAN1(br1). All wireless devices connect to this same LAN1.

    The server is set to use Ethernet bridging with a mode of Balance-(rr). I do this because I can, not for any specific reason. However, it's not seemed to give me any trouble in the past, that I know of.

    I have access to the internet with the server, and all machines connected to the router.

    In fact, I've done a bit more testing, and it seems that I can get internet access from within Putty, I just can't "Ping" an outside IP or address, and a wget command fails to connect to a server. Below is what I get in Putty when I try.

    root@media:~# wget
    --2014-04-27 09:32:12--
    Resolving ( failed: File exists.
    wget: unable to resolve host address âarchive.ubuntu.comâ

    Notice the address has these â characters around it. I get the same characters for all addresses that fail. http or https results are the same. It also reports ... failed: File exists. I have no idea what that means, the file doesn't exist on my server.

    I'm guessing I've got something a bit mis-configured, but I'm no LAN expert, so I appreciate all the help!!
  10. mstombs

    mstombs Network Guru Member

    Your wget commands fail looking up the dns name.
    The first response should be
    I do not follow your vlan configuration and don't like the sound of duplicate links to the modem!
    Double nat + DMZ does work, but it is always better to put ISP modem into a bridge mode and use one router!
  11. JustinChase

    JustinChase Networkin' Nut Member

    Okay, thanks for the feedback. What about my vlan is bad, wrong or confusing? Perhaps I can explain my thinking.

    There are no duplicate links to the modem. The modem is ONLY connected to my (e3000) router with a short cat6 ethernet cable, to the WAN port. I have my server connected to the e3000 on ports 2 and 3, and the server is set for ethernet bonding internally. Basically, my server can use both connections as if there were one 2GB connection. the whole network only sees on MAC for the server.

    I'll look at the ISP modem to see how/if I can put it into bridge mode, and do so if possible.

    Is there anything else I should be doing to try to resolve the DNS lookup failure problem?
  12. Grimson

    Grimson Networkin' Nut Member

    Well, if using wget and ping works when done locally but not over putty I doubt it's related to the router at all. It could simply be a misconfiguration of putty or the ssh daemon.
  13. mstombs

    mstombs Network Guru Member

    I don't know how the router handles the duplicate connection to the server, and I doubt the gigabit link is rate limiting in any case! - I would certainly first test with only one connection. Its possible the LAN works due to the router switch 'hardware' and bridging but routing via the kernel broken. There are things such as 'Spanning Tree Protocol STP' (definitely used to be configurable in Tomato web gui, but I can't see it right now!) and 'RIPv1'/v2 which might help but get it working simplest way!

    I don't see a problem with putty/ssh that seems to work in getting shell access on server, but could be server configuration issue I guess. Do things work using command line from keyboard on server?
  14. JustinChase

    JustinChase Networkin' Nut Member

    I just tested, and yes, I can ping from a cmd window from the windows laptop. wget is a linux command so I cant test it from the windows machine.

    I've not made any changes to the 'stock' putty install, other than setting it to connect to the server via ssh. I tried with a telnet connection, and I have the same problem.

    It seems like it's a problem with DNS translation, as someone above suggested, but I don't know enough about all this to figure out how to resolve it :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice