Cannot recover RT N66U - FIXED

Discussion in 'Tomato Firmware' started by gffmac, Jan 2, 2014.

  1. gffmac

    gffmac Networkin' Nut Member

    I had attempted to flash Victeks build 'tomato-RT-N66U-K26-1.28.9013MIPSR2-64K-RAF-V1.2x.trx'
    via the Asus Firmware restoration program which was going fine until I received an error so fair enough I tried again and it always gets past upload and system recovery in progress to 100% then loses connection in the status. Ive tried flashing the stock firmware back but same thing.

    When the unit is powered off and on it goes straight to firmware recovery mode which I can reach by visiting the routers ip. Ive tried doing an NVram erase from there and also from the wps button (for 30 secs after turning on) Ive tried flashing also via the recovery web config and tried also tftp2.

    Nothing seems to work.

    Ive tried all this on a windows 8 pc and windows 7 laptop with firewalls etc disabled.

    IP set to with subnet and gateway

    After the first two stages of the recovery with the asus firmware restoration I get :
    Failed to connect to the wireless router. Check if the router's power led is blinking which donates that the router is in rescue mode.

    Anyone know anything else I can try? Just bought this and kind of pi**ed off that it seems to be bricked.
  2. Victek

    Victek Network Guru Member

    Do you have TFTP in your windows or TFTP program from Linksys?.. you can download last one from my site (bricked router section).
    Then the procedure is as you mention... but let time enough to finish the recover procedure... I remember when I had RT-N66U to leave for about 5-8 minutes after flashing. Grab a cup of coffee .. it's a question of time and very difficult to get bricked... just patience.
  3. jerrm

    jerrm Network Guru Member

    Is it rebooting on it's own or are you powering off after the 100% notice in the restoration utility. How long are you giving it to reboot?

    For some reason RTN66's can take FOREVER to reboot after using the restoration utility. Try flashing and don't touch it for a good 45 minutes to an hour to see if it reboots on it's own.
  4. gffmac

    gffmac Networkin' Nut Member

    Using tftp2 I get firmware upgraded successfully, then waited about 15mins no power led .. is it meant to reboot on its own when its ready? because it hasnt yet. will leave it for an hour.. like you suggest jerrm. Thx for the replys.
  5. gffmac

    gffmac Networkin' Nut Member

    Right its been 56 mins, 4more wont make a a difference :p
    Router still has no power led and no ping 'Destination host unreachable'.
    Turn off and on = looks like it resets twice and bam! The awesome RAF logo, thank f*ck for that lol

    Thanks for taking the time guys! I thought all was lost!! Now resetting nvram through tomato gui and away I go :p
  6. Victek

    Victek Network Guru Member

    Easy question, why you didn't flash using the GUI? .. You had Asus firmware before?
  7. gffmac

    gffmac Networkin' Nut Member

    Wrong google link I suppose, found a guide and went with it. Would have done that but wasn't sure if I needed a trailed build or something.
  8. jerrm

    jerrm Network Guru Member

    Don't know why they need so long after uploading when using restore. If you flash from Tomato GUI, it goes as fast as any other router.
  9. gffmac

    gffmac Networkin' Nut Member

    Yeh, Ive updated since in tomato and its very fast.
  10. Jaison

    Jaison Networkin' Nut Member

    Used the linksys tftp program. Says firmware upgraded successfully. Currently power led is totally off. How do I know when it's done doing is thing?

    Sent from my Nexus 4 using Tapatalk
  11. Victek

    Victek Network Guru Member

    Get calm .. go to walk and back to the router after ... read it.

    Jaison and koitsu like this.
  12. Jaison

    Jaison Networkin' Nut Member

    Calm I always am. Waited 15 minutes. Powered off and on. Reset twice and I was good to go. Glad I found this thread. No other method was working for me.

    Sent from my Nexus 4 using Tapatalk
  13. shibby20

    shibby20 Network Guru Member

    Vic has right. If you have RT-N66u revB1 then just flash new firmware via asus firmware restoration and dont touch router for even 10-15mins. Just be patience.
    Jaison likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice