Cant access

Discussion in 'Tomato Firmware' started by cowboyup9100, Aug 6, 2013.

  1. cowboyup9100

    cowboyup9100 Reformed Router Member

    Hello all -

    I have a Linksys WRT54G v2 router previously with DDWRT not the latest.

    Anyhow I flashed it Tomato 1.28 WRT54G_WRT54GL.bin and after it said successful and ask me to log in. It wouldn't accept "root" for user or "admin" for password. And of course I tried different variations and my old username and password.

    So I did a reset on the back and although I'm online and everything, I can't access the router's page.

    What did I do wrong?
  2. Victek

    Victek Network Guru Member

    Are you able to ping ? If you upgraded from dd-wrt then credentials are the same as you used in dd-wrt, once you login go to configuration and perform nvram erase.
  3. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    I did the same thing before - forgot to do
    nvram get http_passwd
    before upgrading to Tomato.

    Holding reset button for ~30 seconds at power on will usually do the trick. It should reset the password back to "admin" for web access or "root" otherwise. If that doesn't work, then 30-30-30. If that still doesn't work, reflash dd-wrt through tftp, enter the code above, write it down, reflash Tomato.

    Remember after you successfully flash Tomato to first log in, go to configuration settings and do thorough NVRAM erase.
  4. cowboyup9100

    cowboyup9100 Reformed Router Member


    I already upgraded from DD-WRT to Tomato. It said successful, but was not allowing me to login in.

    I did the 30/30/30 reset to try and reset the router. After I perform that I can't even ping the router @
  5. Monk E. Boy

    Monk E. Boy Network Guru Member

    Yes. The problem is that the format DD-WRT stores its password in is not the same format Tomato uses. As a result your password is some random gobbledigook instead of text.

    You need to use the reset button (as Marcel Tunks explained) to wipe NVRAM back to defaults, at which point the password will revert to admin/admin for the website and root/admin for telnet/ssh/etc.
  6. cowboyup9100

    cowboyup9100 Reformed Router Member

    And like I've said, Ive done the 30/30/30 hard reset and still can't even access the router page to enter anything.
  7. Monk E. Boy

    Monk E. Boy Network Guru Member

    Is the page displaying a password prompt, or is it simply not available?
  8. cowboyup9100

    cowboyup9100 Reformed Router Member

    It takes me to like a Google search result after like a minute. It never prompts for anything.

    As title says I can't access router "" yes even after the hard reset 30/30/30.
  9. Monk E. Boy

    Monk E. Boy Network Guru Member

    Okay, then that's different than the password not being correct. Which would also fall under the category of "can't access router"

    The router isn't responding at all then. I would guess something went wrong during the flash. Does respond to pings? If it does, you could try to tftp a new image to it.

    I would try flashing the official Tomato (from as a starting base, then upgrade to a newer version from there. We know the old version works fine (albeit with bugs and security concerns), but if you get that working then at least you have a good platform to go from. Try upgrading to the new bin and see if the same thing happens. If it does then you know there's a problem with that bin.
  10. mvsgeek

    mvsgeek LI Guru Member

    @ Cowboy :
    In your original post said you're "online and everything". And the fact that you get a Google search page would support that. So my guess is that although the router boots, the httpd daemon isn't starting. Although I don't understand why you can't ping

    Probably a dumb question, but do you have your client set to a static IP? If so, can you telnet to the router? If you can, try starting httpd and then trying the web GUI again. If you can't, I give up:(.
  11. cowboyup9100

    cowboyup9100 Reformed Router Member

    Ok sorry for the mix-up I thought I expressed it clearly. I only added the info about the password not working initially to show what happen during the process.

    Something must have gone wrong. I mean although right now I'm still connected through the router, I guess its just on bypass mode because when I ping the router all I get is request time out.

    So since I'm not very router smarts does this mean its broken, fun over go back to my cheap Tenda router and forget about DD-WRT/Tomato firmwares and adding my VPN info to my routers? :eek:
  12. cowboyup9100

    cowboyup9100 Reformed Router Member

    I don't know what that means if I have my client set to you mean the router? It's set to

    Telnet to router, try starting httpd, and then trying web GUI, if you could give me some instructions on more info on what the means I appreciated because I'm not really comfortable with much of this.

    Oh and by the way thanks for help and responses guys. :cool:
  13. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    After 30-30-30,wait 5 minutes, unplug for 10-20 seconds, plug back in. Wait 5 min and try logging in again with root, password admin.
  14. mvsgeek

    mvsgeek LI Guru Member

    No, I mean set your client's network card IP address to where 2 < xxx < 255 (e.g. rather than rely on DHCP.

    As you point out, it looks like the router is behaving in "bypass" mode although I can't imagine why.
  15. Monk E. Boy

    Monk E. Boy Network Guru Member

    What IP address is assigned to the Ethernet interface, on your system, that's plugged into the router?

    Do you have any other internet-capable connections on the system that's plugged into the router? 3G, neighbors wireless, etc.? This would allow you to resolve a Google search page even if the router is unresponsive.

    Toastman firmwares have DHCP disabled by default, if you haven't manually assigned an IP address to your system's ethernet connection you'll end up with a self-assigned address (169.254.x.x) which won't let you talk to the router.
  16. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Changing to static IP:

    1. Unplug ethernet from computer
    2. If Windows (will be variations, but goes something like this):
    a. Control Panel > Network settings > Right click on the adapter connected to your router (wired preferred over wireless)
    b. Go to Properties > IPv4
    c. Instead of "Automatic" IP address, set to something like
    d. Subnet mask change to
    e. everything else blank
    3. Plug ethernet back into router. Wait a minute. Then try

    Other instructions as recommended in posts above.

    Edited: Thanks Monk E. Boy. Sleep deprived...
  17. Monk E. Boy

    Monk E. Boy Network Guru Member

    Subnet mask is, default gateway would be
    Marcel Tunks likes this.
  18. Monk E. Boy

    Monk E. Boy Network Guru Member

    Happens to all of us. :) Since my stepfather died last week I know how it feels to be sleep deprived...
  19. cowboyup9100

    cowboyup9100 Reformed Router Member

    Sorry, my Internet Connections looks like a mess.


    I have VMWare installed, plus my VPN tap software has something and "WiRED" is my ethernet adapter.

    And maybe the VPN software is screwing up something so I have disabled it for now until I get it all working again.

    Doesn't let me enter a Default Gateway to first must can't be higher than 233.
  20. cowboyup9100

    cowboyup9100 Reformed Router Member

  21. mvsgeek

    mvsgeek LI Guru Member


    Your settings look OK. Try disabling your firewall, or restart the computer in Safe Mode with Networking and try to access

    And before the math purists call me out, I should point out that "2 < xxx < 255" in my prior post should of course have been "1 < xxx < 255":oops:
  22. Monk E. Boy

    Monk E. Boy Network Guru Member

    I would try disabling all your other interfaces too. Try to keep your system simple.

    If the firmware is crashing during boot there should be a short window when the router is booting (right after power is applied) where will respond to pings. The problem is that Vista & up perform connection testing during (and after) that window so you'll never see the router as being pingable.

    The standard trick for WRT54Gs is to have a TFTP program primed and ready to send the file, wait for it to respond to a ping when starting up, then immediately TFTP over the new image. As far as I know this technique isn't possible anymore under Vista, 7, & 8.
  23. cowboyup9100

    cowboyup9100 Reformed Router Member

    Firewall disabled, all other interfaces disabled, try in safemode. It didn't work. It always tells me DHCP is not enabled when I enter the IP, subnet mask, default gateway. Once I enabled DCHP it removes those values and restores the original "Obtain IP automatically".

    I want to try this I read this somewhere else, but I don't understand it, what image? Whats TFTP? I'm on my other router for now. I've given up for today.
  24. Monk E. Boy

    Monk E. Boy Network Guru Member

    Under Windows Vista, 7, or 8 I don't think its possible. Microsoft doesn't let you send anything over TCP/IP until it's "tested" the connection, by which time the router would have already booted and hung. I suppose if you wanted to boot into a LiveCD/LiveUSB Linux environment on your PC you could use that instead, Microsoft's limitations wouldn't apply then.

    TFTP is Trivial File Transfer Protocol, it's a method of sending files over the network w/o any security and minimal overhead. The underlying idea is speed and simplicity. The device/server has to be running a TFTP server, and on the client (your system) you'd need to run a TFTP program to upload a file. The former isn't a problem with WRT54Gs since one of the first things they bring up is a TFTP server. Linksys once upon a time provided a simple Windows TFTP client suitable for uploading their routers.

    Image is just another name for a firmware file. When you upload a .bin file you're basically uploading a copy of someone else's router, an image of that system.

    I would try the modified 30/30/30 reset as previously described by Marcel. WRTs are pretty hardy but they can get into funky states, so its best to be slow and methodical when dealing with them. Someone in this forum recently had a problem with theirs and found that a 35/35/35 worked while a 30/30/30 failed. Another thing to try I suppose.
  25. cowboyup9100

    cowboyup9100 Reformed Router Member

    Okay so I boot with a Linux Live CD, then I install TFTP program and run the service through a Live CD? Then TFTP in the router and upload the .bin file? Where do I get the .bin file that I need to upload. Is there a special place on the router it goes? Just on the root directory?
  26. Inkrypted

    Inkrypted Serious Server Member

    The TFTP Program you mentioned from Linksys can be found here. Flashing/tftp.exe
    The above is for Windows. Many Linux distros already have TFTP.
    Here are the instructions from the Linksys Site.
    • Configure your home box in order to get such adress (some parameter as DHCP IP range addess starting from
    • Reboot the PC to properly gain a new IP adress
    • Check with Ipconfig (on windows XP execute cmd "dos mode" windows and type ipconfig. you will see if you got the right adress)
    • Unplug your PC from your home network and plug the rj45 on one of the yellow rj45 port of the router
    • On your pc launch tftp.
    • Type as a server address (routeur factory default adress)
    • Type the router factory default password "admin"
    • Choose the proper (language dependant) .img file available on your cd (upgrade directory)
    • You will see a progression bar of the download
    • A green spot will appear showing upload is successfull
    • Go to your browser and connect to
    • You get the invite box for password
    I hope you get it working soon.
  27. cowboyup9100

    cowboyup9100 Reformed Router Member

    I'm must be totally stupid everything from the instructions I have no clue how to proceed.
  28. Inkrypted

    Inkrypted Serious Server Member

    No such thing as stupid. Just make sure to unplug your cable or DSL modem from your router but make sure the cable from your computer to one of the 1,2,3,4 port on the router is plugged in. Launch the TFTP.exe program in windows and type in where it says Server Address and admin in the Password box and where it ask you to choose an image file to upload make sure you browse to the firmware you downloaded and choose it and press upload. A green bar will show you the progress and it will say Successful when done. You close out and open a browser and try connecting to again. Good Luck.
  29. cowboyup9100

    cowboyup9100 Reformed Router Member

    Wow, now them are much easier instructions, haha. But last questions and I suppose to do run this program as soon as Windows boots or something.

    I'm on Windows 7.

    I don't ave a image to upload to, don't exactly now which one I need. I'm looking for one with advance OpenVPN options.
  30. leandroong

    leandroong LI Guru Member

    In case you didn't know, there is new driver release for notebook ethernet. Downloading latest driver might help you.
  31. Monk E. Boy

    Monk E. Boy Network Guru Member

    You should start out with a very basic WRT54G/GL image to avoid spinning your wheels. Once you're on Tomato it'll be much easier to move up to a more elaborate firmware.'s firmware would be perfectly fine for a first flash and kicking the tires to make sure the router's OK.
  32. Inkrypted

    Inkrypted Serious Server Member

    I agree you can download that here.
    It will be a .zip file and you will need to extract it.

    No you run the TFTP.exe once you are in Windows and your desktop is fully loaded.
  33. cowboyup9100

    cowboyup9100 Reformed Router Member


    ok so ethernet cable plug into PC and port 1 of router. Ran TFTP program, typed, "admin" found the basic tomato firmware but the program said cannot get a response from server.

    Just like before when we couldn't ping the IP.
  34. Monk E. Boy

    Monk E. Boy Network Guru Member

    Yeah, that's why I suggested using a Linux LiveUSB/LiveCD environment. The problem is I'm not really familiar enough with current environments to give you a step by step walkthrough of what you'd need to do, since you probably haven't been in a LiveUSB/LiveCD environment before (correct me if I'm wrong).

    In broad strokes, with the router off, and your system booted into Linux, cable up ethernet port 1, start pinging, and connect power to the router and see if it ever responds to If it doesn't then the router is bricked. There are methods of getting it unbricked but on a 54GL it involves soldering and software and purchasing specific hardware.
  35. koitsu

    koitsu Network Guru Member

    A large portion of the time the reason the TFTP fails is because the window of opportunity is extremely small -- we're talking literally 2-3 seconds here. I've done TFTP restores/upgrades more times than I can count, and every single time it's "a task", meaning I usually have to power-cycle the device 7 or 8 times + re-launch TFTP at the exact moment where the stars align before the transfer goes through. This is completely, absolutely, entirely 100% normal. We know that boot_wait is enabled on your router because you were using DD-WRT previously, so the issue is what I've described.

    If you run ping (on Linux; if on Windows, you need to use ping -t) like Monk E. Boy said, and you never **ever** get a response (and the Linux machine has a static IP address on the network -- do not use DHCP as mvsgeek said), then that would indicate the router is bricked (either somehow boot_wait got disabled or there is a much worse problem going on, possibly at the hardware level or maybe the CFE is busted), in which case you're SOL. What you should see is ping responses that happen for a short while (maybe 5-6 seconds) and then eventually stop (and/or may start up again).

    Going completely and entirely off of your initial post, the password problem you experienced was because of how DD-WRT stores its passwords (different format (encrypted) than what Tomato uses (plaintext)). A 30/30/30 should have addressed this, so there may be something worse going on. If you can get the TFTP method to work you should be in good shape, but you may need to do the 30/30/30 method again because none of what's been done so far (assuming that first 30/30/30 didn't work) would clear NVRAM.

    I cannot provide any more help past this point.
  36. Monk E. Boy

    Monk E. Boy Network Guru Member

    Windows Vista/7 enjoys fairly long pause immediately after bringing up an interface while it tests it for internet connectivity. While this test is going on pings will fail on that interface since it's not available for applications to use. As a result while the ping -t method works perfectly fine under XP, by default under Vista/7 the same technique is a no-go.

    One of these days it'll annoy me enough to play around in the registry to see if it can be turned off. I fear that it's like IPv6 in Vista+, where turning features off has unintended and weird consequences because the entire Windows programming team never envisioned someone would not let them do whatever they wanted and didn't bother to write any "if this fails let's fail gracefully" code.
  37. cowboyup9100

    cowboyup9100 Reformed Router Member

    Ok, so I have Ubuntu 12.04 installed on my VMWare? Can I do something in their to try getting it working, or must install on my disk first?

    I do want to get confused with the XP/Vista/7 talk because it sounds like it's not very likely that it will work so that was not a solid option in my case.

    I'm looking for a program in Ubuntu for TFTP, I don't find one. So I'm guessing. This is all down by command. I have to get to the bin on their by command.

    Oh crap that can't be easy.
  38. koitsu

    koitsu Network Guru Member

    If you need help with Ubuntu, such as finding a software package (ex. TFTP client), please see their documentation or ask for assistance via a variety of options. There are many TFTP clients for Ubuntu, but you want the bare-bones/stock default one (listed there as "tftp", or if that isn't available, the one called "tftp-hpa").

    Assuming whatever OS you installed on VMware (I am assuming Workstation or ESXi -- I really do not like it when people say "VMware", you do realise VMware is a company and makes 20+ products?) has a working networking layer (static IP address, etc.) and can reach your router (and when its working, the Internet), then you should be able to perform all of the above without any complexity.

    The ping method we've described, which you can run under a *IX machine (Linux, etc.) and then power-cycle the router, is being used to determine if the router during its initial power-on stage actually is answering/alive (it will briefly (3-6 seconds or so) respond to ICMP echo packets (there is a "pre-boot" environment called the CFE which has networking support), then stop for some time (CFE ends / firmware loads from flash)). The purpose of this procedure is to determine if your router is truly bricked or not. The procedure is simple: unplug the router, then on the *IX machine run ping, then plug in the router. If you see, briefly, something like:

    PING ( 56 data bytes
    64 bytes from icmp_seq=19 ttl=64 time=0.366 ms
    64 bytes from icmp_seq=20 ttl=64 time=0.274 ms
    64 bytes from icmp_seq=21 ttl=64 time=0.350 ms
    64 bytes from icmp_seq=22 ttl=64 time=0.294 ms
    Then the router is indeed alive during the pre-boot/CFE phase and therefore TFTP should work during that very short window (again: 3-6 seconds). That's good -- it means the router is most likely not bricked. If you don't see these kind of messages, then the router may indeed be bricked.

    TFTP is a very simple protocol that literally just sends out UDP packets to a destination and hopes for the best -- in this case, you're trying to transfer a firmware image (a file) from the TFTP client (presumably using Ubuntu) to a TFTP server (the router itself, during that small/short window before a firmware is loaded). The TFTP client will tell you if it's successful in sending the file or not (I do not have an example to show you). However some TFTP clients differ in their behaviour (some can let you send a file with one command, others are interactive and require you to do things like tftp, then type binary, then type put firmwarefilename.trx and hope for the best). And again, read my first paragraph here -- it may take you many, many times to get this working.
  39. cowboyup9100

    cowboyup9100 Reformed Router Member

    Sorry I don't know much about Linux or even how to stop a ping..

  40. koitsu

    koitsu Network Guru Member

    Please read what I said in full and follow the directions provided.

    To end/terminate ping, press Control-C on your keyboard.
  41. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    It's alive!

    Following Koitsu's detailed instructions, run the tftp client and turn on the router a bunch of times until it works. Believe it or not, some people prefer tftp because it's the fail safe option - the last stand before screwdrivers and soldering. It may also be a more reliable way to flash firmware than the web GUI.

    Don't get discouraged by the learning curve. In the past few days you've gone from following dd-wrt wiki pages step by step to learning about static ip addresses, cfe, tftp, how to use ping... In a few weeks you'll be learning all about netfilter and other goodies. Router firmware was the gateway to Linux and BSD for many people in this forum.
  42. cowboyup9100

    cowboyup9100 Reformed Router Member

    Don't laugh at my attempt. :eek::p


  43. koitsu

    koitsu Network Guru Member

    The error clearly indicates you don't have WRT54G_WRT54GL.bin on your Ubuntu system in the ~ (home directory).

    I'm sorry but I am not going to teach *IX 101. If someone else wants to help at this point (including how to transfer a file from host to guest in VMware Workstation (again, assumption)), be my guest. I'm opting out at this point. :p
  44. cowboyup9100

    cowboyup9100 Reformed Router Member

    Yes, I'm clearly a beginner. But Inkryped said in XP it should work, so I installed that on my VMware player and presto after four tries no more blinking lights.


    I'm sorry koitsu my Linux terminal knowledge is none, I hope I didn't aggravate anyone in this thread. I thank you all for the help. I will look around in the settings and see what I can do.

    Basically I just want to enter my VPN settings.
  45. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Reminder: once you've successfully flashed a new Tomato version, the first thing you must do is go to the administration tab and do a thorough NVRAM erase. Wait 5 minutes after the NVRAM erase before changing your settings.
  46. Monk E. Boy

    Monk E. Boy Network Guru Member

  47. RMerlin

    RMerlin Network Guru Member

    Whenever I need a TFTP upload, I simply use this - way less typing involved, which in turn works better considering the small time window CFE leaves you to initiate an upload:
    dc361 likes this.
  48. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Nice! Maybe that should be in the Tomato wiki?
  49. cowboyup9100

    cowboyup9100 Reformed Router Member

    Hello, everyone -

    me again. I have some questions now, hopefully I don't upset anyone.

    My router still works. I'm on Tomato v1.28. I'm still successfully able to log in and out without any problems. I've even changed the password.

    Going forward, I would like to upgrade to Victek's RAF 1.28.9013 firmware because I believe it has the proper settings I need to add my VPN scripts from my provider.

    Should I just go over to that thread and ask whats the best way to proceed. Hopefully I can follow the steps very carefully and not SCREW anything up this time. (If the steps allow me to... NooB here :p)

    Best regards,
  50. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Now that Tomato is installed, you can easily use the Web GUI to upgrade firmware:
    1. Do thorough NVRAM erase
    2. Go to Administration > Upgrade
    3. Select your new firmware image
    4. Wait a few minutes
    5. Erase NVRAM again
    6. Enter your settings

    Some people would skip step 1, but I would recommend following all steps.
  51. fubdap

    fubdap LI Guru Member

    I will modify #6 slightly:
    6. Enter your settings manually and not from previously saved config settings.
    Marcel Tunks likes this.
  52. cowboyup9100

    cowboyup9100 Reformed Router Member

    Worked without any issues. But still can't get the right firmware or the VPN people are lying about the settings they need for things to work.
  53. L37clown

    L37clown Reformed Router Member


    I had the same exact starting issue of this thread

    without any updates or changes the webinterface stopped responding
    CANT access webinterface
    CAN ping

    tried with fail:
    restarting several times
    disconnecting all clients
    bunch of other tasks

    issue: need to start webinterface

    summary: telnet into router, start interface
    commands from osx terminal, should be similar in other OSs

    username: root
    password: [customPassword you set for your routers webinterface]
    Web GUI Management
    httpd -h /www
    ctrl + ]
    quit webinterface now works!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice