Can't access LAN when connected with OpenVPN

Discussion in 'Tomato Firmware' started by gfunkdave, May 31, 2014.

  1. gfunkdave

    gfunkdave LI Guru Member

    Using Toastman 1.28.0505 MIPSR2Toastman-RT-N K26 USB VPN. I when I connect to OpenVPN with my iPad (haven't tried with any other device), I can browse the internet just fine. Using IP address checker sites shows I'm coming from my home IP. But I can't access anything on my home LAN while connected to VPN. All connections just time out.

    I am pushing the route to my home network. Below is the log file from my iPad.

    2014-05-31 08:32:21 SSL Handshake: TLSv1.0/TLS-DHE-RSA-WITH-AES-256-CBC-SHA
    2014-05-31 08:32:21 Session is ACTIVE
    2014-05-31 08:32:22 EVENT: GET_CONFIG
    2014-05-31 08:32:22 Sending PUSH_REQUEST to server...
    2014-05-31 08:32:22 OPTIONS:
    0 [redirect-gateway] 
    1 [route] [] [] 
    2 [route] [] [] 
    3 [route] [] [] 
    4 [dhcp-option] [DOMAIN] [elbonia] 
    5 [dhcp-option] [DNS] [] 
    6 [route] [] [] 
    7 [topology] [net30] 
    8 [ping] [30] 
    9 [ping-restart] [120] 
    10 [ifconfig] [] [] 
    2014-05-31 08:32:22 LZO-ASYM init swap=0 asym=0
    2014-05-31 08:32:22 EVENT: ASSIGN_IP
    2014-05-31 08:32:22 Connected via tun
    2014-05-31 08:32:22 EVENT: CONNECTED (207.x.x.x) via /UDPv4 on tun/
    2014-05-31 08:32:22 NET Internet:ReachableViaWiFi/-R t----l-
    My router's LAN IP is, and you can see redirect-gateway and the LAN route entry. It's also always worked fine before.

    Any ideas? Thanks!
  2. gfunkdave

    gfunkdave LI Guru Member

    Update: think I figured it out. The hotel whose wifi I'm using apparently assigns everyone an IP in, which interferes with my LAN of By setting my iPad to a static IP identical to the one the hotel dhcp gave me but with a subnet mask of, I can now connect.

    But dies anyone know why it worked fine when I connected to my router using pptp VPN, just not OpenVPN?
  3. quihong

    quihong Networkin' Nut Member

    Came to ask what openvpn client you're using on the iPad.

    Also would suggest you post, screenshots of your VPN server and client configuration which is always helpful when troubleshooting these type of issues.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice