Can't Access NSLU2 via second computer

Discussion in 'Cisco/Linksys Network Storage Devices' started by Jacksan, Jul 2, 2005.

  1. Jacksan

    Jacksan Guest


    Newbie here, just got the NSLU2 working with my main computer, but I can't get my laptop computer to access it!

    Both computers are running WinXP, I can ping the unit from the laptop, I can also access it via the webbrowser by typing in the IP address, but I can't map the drive from My Computer -> tools. I've tried mapping to the name of the unit, as well as the IP address, still no luck.
    I have a terastation on the network as well, and that mapped without any problems.

    The linksys help line got me as far as confirming that it is definitely on the network, but couldn't help me any further since it was an XP not a Linksys question at that point.

    Any help would be greatly appreciated, I'm about ready to toss the thing!
  2. u3gyxap

    u3gyxap Network Guru Member

    Make sure you have your usernames/passwords matching between PC2 and the NSLU2
  3. wkaml

    wkaml Network Guru Member


    Just had the same problem. One additional thing that you might check before you try my solution that worked for me is to see if the name is in your hosts file. Unter Windows XP you should have a hosts file unter C:\WINDOWS\SYSTEM32\DRIVERS\ETC (%WINDIR%\SYSTEM32\DRIVERS\ETC) that might include the line localhost
    add a new line with the following entry MYNSLU2
    You will replace this IP address with that of your NSLU2 and the NAME with the NAME of your NSLU2.
    In my case you then map
    NET USE U: \\MYNSLU2\sharename password \\MYNSLU\username
    or use the Windows Explorer UI.

    If that all is already setup, I suggest you reboot the NSLU2. It was strange in my case too. I could disconnect and reconnect the share of my NSLU2 from 2 different computers on my LAN but could not do that from another machine. After rebooting the NSLU2 I was able to connect from all 3 machines.
    For some strange reason, the NSLU2 memorizes a connected computer and if that disconnects due to a system crash of the PC and does not disconnect by normal means, the NSLU2 will not allow to reconnect. Only rebooting the NSLU2 will solve that issue in my case.
    Please try rebotting your NSLU2 and let me know if that worked.
    (NSLU2->Administration-> Status->Restart Now)

    This is definitely a NSLU2 issue!

    Hope that helps,
  4. donotdespisethesnake

    donotdespisethesnake Network Guru Member

    I also just had a very similar problem. I had Netware installed (trying to solve some earlier problem), and removing it sprang into life. If you look at the properties for the network connection, it should say "WINS server = x.x.x.x" with the address of the NSLU2. The NSLU2 appears to act as a WINS server

    I think the problem with Netware is that it is not being broadcast over my wireless link, a firewall pb or Netware feature I guess. I tried a wired connection and it connected OK.

    Also check if you have File and Print sharing enabled in Windows firewall, or try with firewall disabled.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice