Can't access router from outside, altough configured correctly

Discussion in 'Tomato Firmware' started by mars, Aug 15, 2009.

  1. mars

    mars Addicted to LI Member


    My router's IP is . I have it configured to allow remote tomato access, and when I access <IP>:8080 it connects correctly.

    But, I have another service running on port 8081 on the router, and THAT I can't configure or access from outside. I tried adding a port forwarding rule to forward 8081 from the outside to 8081 and my router's IP, but still no luck.

    Maybe I'm missing some configuration to allow that ? I have port forwards to some of my PCs (not router itself) and all that works correctly. It's just like the router allows all port forwarding except for it's specific ip (

    Thank you !
  2. mars

    mars Addicted to LI Member

    Got around this by modifying the INPUT chain in iptables, setting the 2 first rules from DROP to ACCEPT. Somehow I'm not very confortable with this (it seems as I'm allowing access to everyone to any place in my router), so if anyone has other solution I'd be grateful !
  3. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    I think all you need to do is add
    iptables -t filter -I INPUT -p <udp or tcp> --dport 8081 -j ACCEPT
    to your firewall script. Also, get rid of your port-forward.

    You don't want to be modifying those rules the way you did.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice