Can't aquire IP address

Discussion in 'Networking Issues' started by bob98, Sep 26, 2005.

  1. bob98

    bob98 Guest

    Hi, I have the Linksys WRT54G. when I first set up my network, things went fine with just the usual hassles. I have a desktop, hard wired to the router and a note book with the wireless connection. This setup has worked for quite a while. Recently, the notebook cant connect with the network. It sees the network and the signal strength is fine. But it is not able to find the IP address. It spends hours and even days trying to "aquire" or "renew" the IP address. I dont know much about this and would appreciate any help you could offer.
  2. dethomas143

    dethomas143 Network Guru Member

    It sounds like a DHCP problem.......

    Have you tried setting a static address on the wireless NIC? If things work after you do that then it is indeed a DHCP issue, otherwise it is probably some kind of communications problem.
  3. howardp6

    howardp6 Network Guru Member

    If you are going to setup a static IP Address, make certain it is outside the range of the DHCP server if enabled on your WRT54G. For example if t your router is giving address from, -150, make the static address from - 99 or higher than, with a mask of, the gateway address is there local address of your router, which is defaulted t0 unless you changed it. From the status screen of your router, copy the DNS server addresses and put those in when setting up the static address. Do you have any encryption? Has any changes been made to the OS in terms of hot fixes or service packs? What wireless NIC are you using? Have you updated the driver recently? Made any changes to the setting on the router?
  4. MaureenMun

    MaureenMun Network Guru Member

    What kind of issues can the Linksys DHCP server have? I've been having this EXACT same problem: laptops trying to connect to my network can see the WAP54G and get a strong signal, but choke trying to obtain an IP address. I put in a static IP address on their laptops, without changing anything on the Linksys WAP, and then it works. This started suddenly, without any changes on any other part of the network. Bob98, did you ever find out what was wrong with your DHCP?
  5. TMAC

    TMAC Network Guru Member

    try changing the channel on the router also try checking on the wireless security on the router...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice