Can't change LAN/Gateway MAC address

Discussion in 'Tomato Firmware' started by eduncan911, Jun 11, 2014.

  1. eduncan911

    eduncan911 Reformed Router Member

    (posted this in Shibby's thread, but it got lost quickly)

    TomatoUSB - Shibby v120 on Cisco E4200

    How do I change the LAN MAC? I can change the WAN, WL0 and WL1, but not the LAN.

    I tried nvram with:

    nvram set et0macaddr=XX:XX:XX:XX:XX:XX
    nvram commit

    But it doesn't stick - either via a soft reboot, or a power cycle. Always reverts back to the "Default" setting.

    I have quite a few virtual machines running on several host servers. They are all configured for "Private" networking (Windows), which FYI is all tied to a LAN MAC address it designates as a "network" in Windows. When the "gatway" MAC changes, it forces all servers to a "public" firewall mode - effectively cutting off all remote access to the server (including RDP!).

    Needless to say, if the MAC address of the gateway changes, it's a PITA to go in and reset all the firewalls and networks for each and every VM and host and desktop. I've had to do it once or twice with the Verizon FiOS router and WRT54G swaps, etc.

    I was able to set the LAN MAC in Tomato.

    Thanks in advance!
    Last edited: Jun 18, 2014
  2. Siff

    Siff Serious Server Member

    Changing the LAN MAC address apparently worked in previous versions:

    So, either there is an issue with your router model, or you haven't done something correctly or there is a bug in 120, or it is a feature :)

    One more thing: I guess you did, but it is worth asking: have you cleared the NVRAM after you flashed Tomato?

    Hope this helps.
  3. eduncan911

    eduncan911 Reformed Router Member

    Yes, I found that post as well - and is exactly what I did. I've been running Tomato and DD-WRT for 7/8 years, so I think I know how to "commit" to nvram. Don't think it was me.

    Guess it is a bug in v120?

    Ha, just noticed I didn't list my router in the OP. It's an E4200. I'll update original post as well.

    Always. 30/30/30 and even did it a 2nd time. My IP segment is completely different from the default 192.168.x.x, that's how I know it resets back to factory - the DHCP given is in teh 192.168.x.x range, before I change it all.
  4. Siff

    Siff Serious Server Member

    Then it looks like it is a bug in 120...

    I have 119 on Asus RT-N66U at home and I'll try changing the LAN MAC for the sake of the experiment (but I don't know when I'll be able to do it) and I'll post the results.
  5. Siff

    Siff Serious Server Member

    I just tried it and it works as expected on Asus RT-N66U running Shibby's Tomato 119 (tomato-K26USB-1.28.RT-N5x-MIPSR2-119-AIO-64K):
    nvram find macaddr
    nvram set et0macaddr=xx:xx:xx:xx:xx:80
    nvram commit
    Commit... done.
    nvram find macaddr
    The change is persistent after reboot and after power-off/power-on.
  6. mstombs

    mstombs Network Guru Member

    If it doesn't work on the E4200 I guess it is possible the Cisco CFE forces the factory default?

    Personally I think the Network config is broken if so difficult to set-up with a box swap, but guess it is security paranoia against introduction of 'man in middle' box? I do remember having similar issue with a Sun server some 15 years ago - in those days the MAC address was stored in an EPROM and we had to swap chips to get an otherwise identical device to work!
  7. Siff

    Siff Serious Server Member

    Yes... I remember that we had to update a software license to the MAC address of a network card instead of the MAC address of the build-in adapter of the server so, when the server crashes (which it of course did) we can continue to use the software on a different machine...

    I think that the issue is with 120, not with your router (BTW, I think that the CFE always sets the MAC addresses), so you might consider trying 119. I'll try 120 myself, but it doesn't look that I'll have a chance to do so this week.
  8. Siff

    Siff Serious Server Member

    I have to take that back! Just tried on RT-N66U with build 120 and the change of the LAN MAC address works like a charm and is persistent.
    Last edited: Jun 29, 2014
  9. eduncan911

    eduncan911 Reformed Router Member

    It may be a v120 + E4200 thang.

    I gave up and just put the router in service, and spent the next several hours hunting and fixing all of the VMs with connectivity issues because of fracking windows default freakout of "I don't know this gateway MAC, it's public and I am locking myself down!" crap.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice