Cant connect APs using WPA/AES

Discussion in 'Tomato Firmware' started by jnappert, Apr 15, 2008.

  1. jnappert

    jnappert LI Guru Member

    I upgraded all of my 7 APs in my WDS System to Tomato 1.18 (nice piece of work!). Since that worked fine as expected i change encryption from WEP to WPA/AES. All APs have a rock solid connection to each other and i can access all of them by connecting with wire.

    But: WIFI connections are simply impossible. All clients see the ssid, they try to connect but while getting an ip, they loose connection and try again. I see this on 4 different notebooks with broadcom and with realtek chipsets. The drivers are the latest i could find. The system is windows xp sp2 with all patches. What can i do sice i like the new "security".
  2. jersully

    jersully LI Guru Member

    Are you using WPA or WPA2? I'm trying to remember what I read on this subject...

    Not to sound stupid, but are your routers in WDS+AP mode? Pure WDS mode allows them to talk only to other WDS devices.
  3. jnappert

    jnappert LI Guru Member

    Since i know, that WPA2 in WDS Mode can be a problem, i run the Nodes in WPA Mode with AES encryption. To be sure i checked it: APs are running in AP+WDS Mode ;-)
  4. HennieM

    HennieM Network Guru Member

    In the wireless driver in XP, delete all your listed wireless networks (or at least your WDS network), and redetect/connect. XP sometimes just can't understand that network X now is WPA, when it used to be WEP.

    Also, if more than one WDS node can connect to another WDS node, make sure you have Spanning Tree Protocol (STP) on on those WDS nodes.
  5. jnappert

    jnappert LI Guru Member

    STP is already activated. But all of the APs do connect to each other, so this isn't the problem. I deleted the existing networks in Windows XP and configured automatic and "by hand" but had no sucess. The network is identified as "WPA" but at the moment the Notebooks should get an IP, they disconnect....

    In the routers log also no IP is assigned.
  6. guillaumy

    guillaumy LI Guru Member

  7. jnappert

    jnappert LI Guru Member

    I already installed this patch as i searched the internet several times for this problem but it didn't solve it...
  8. guillaumy

    guillaumy LI Guru Member

    What is the wireless card / module that you are using?
  9. Rudi1

    Rudi1 Network Guru Member

    WRT54GL could get it to connect to the internet?

    sorry,I post in wrong thread :)
  10. jnappert

    jnappert LI Guru Member

    The wireless cards are build-in solutions with broadcom chipset. But i have the same effect with realtek build-in cards.

    New: The notebooks connect without problem to a fritz box wlan 7170 with WPA/AES encryption!
  11. guillaumy

    guillaumy LI Guru Member

  12. guillaumy

    guillaumy LI Guru Member

    Another thing, since you just changed the security level from WEP to WPA on the same SSID, I remember a little experience I had once.

    Basically I found it helpful to remove and rebuild the specific wireless profile, and here's one way to do that:

    1. Double-click on your wireless icon.

    2. Click "Properties".

    3. Go to the "Wireless Networks" tab. Under the section "Preferred Networks" select the profile with the trouble SSID and REMOVE.

    4. Hit "OK".

    5. Now try to connect to the SSID again. The profile will be rebuilt from scratch.

    I don't know why, but this worked for me at times. My hunch is that there is some quirk in XP rather than the hardware, but your guess is as good as mine.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice