can't connect to WRT54GX

Discussion in 'Cisco/Linksys Wireless Routers' started by bunderan, Oct 17, 2005.

  1. bunderan

    bunderan Network Guru Member

    I've just receive my WRT54GX today. After power on I try to access the configuration page (using cable) and all fine, no changes.

    Whenever I try to connect from my laptop using wireless, Win XP detect the SSID but not able to connect. Tried also with enable WEP security but still no luck.

    Anyone having same problem or did I need to configure something in router? FYI I just need the AP feature, not the router.

    I have try both Mixed or G only with 3 different centrino laptop (Sony, Acer, IBM), still not able to connect... 8O
  2. bunderan

    bunderan Network Guru Member

    Firmware version is 2.00.05 and url contains *.asp, is this means that it doesn't based on linux anymore?
  3. howardp6

    howardp6 Network Guru Member

    Try with no encryption. Do not use a paraphase key generator on any of the PCs if you are using WEP. Make certain the keys specified are exactly the same and are in hexadecimal, since Linksys uses hexadecimal keys. If you have an Intel Proset 2200BG adapter upgrade the driver with the latest generic driver from the Intel website. Older versions of the drivers had problems with Linksys routers. I looked at the GPL code it is still LINUX. If you are using WPA. Download the WPA2 hot fix at: If you are using WPA remove the hotfix, since it causes problems with WEP. I do not know if your wireless NIC can use WPA2, so if you use WPA enable both WPA personal and WPA2 personal on the WRT54GX.
  4. howardp6

    howardp6 Network Guru Member

    I would suggest you upgrade the frimware on the router. Do it only from a PC with a wired connection and only after reseting the setting to factory defaults. Here is the changelog:

    Linksys- A Division of Cisco Systems, Inc.

    Release Date : July 19, 2005
    Current Firmware : 2.00.08
    Product PartNo : WRT54GX ver.2

    Ver #. Date Description
    2.00.8 Jul 19, 2005 1. Fixed where all ports were scanned as closed, not stealth
    2. DMZ LED was not turning on and off when enabled and disabled.
    3. Fixed security hole were the router's web interface can be
    access through
    4. Fixed Static DNS does not work in DHCP and PPPoE mode.
    5. Added TKIP+AES configuratioin for both PSK/Radius webpage.
    6. Added Status Router page will update every 10 seconds.
    7. Fixed Timezone had no effect in PPPoE, unless it was rebooted.
    8. Fixed issue with associating when in a noise environment.

    2.00.05 May 27, 2005 First release

    Check your user guide for Upgrade instructions.
  5. bunderan

    bunderan Network Guru Member

    Thank you sir! :cheer:

    Problem seems in 2200BG driver, just upgrading Linksys firmware did not solve problem, but upgrading intel driver now my problem gone :thumbup:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice