Cant get PSP to connect to my WRT54G router

Discussion in 'Cisco/Linksys Wireless Routers' started by Anonymous, Apr 5, 2005.

  1. Anonymous

    Anonymous Guest

    Ok, I have googled, and searched other forums, still cant get it to work. I have a Linksys WRT54G wireless router. I have entered my 10 digit WEP key several times. I have also disabled WEP in my router, and PSP. MAC filtering is off. I have also set the router to no encryption, and the same for the PSP, no luck. I have tried manual and auto, and followed online guides, nothing seems to work. Its probably me doing something wrong.

    The little green light is on, and I get a 100% signal strength from the test. After I finish the setup, I try to test the connection, and it fails with the code of 80410D09. Ive tried lots of different guides, and nothing is working.

    My firmware says its v2.00.8. I assume this is rather old. Ive tried to read the stickies and find out which I need, but still a little confused. Can someone give me a direct link to the file I need? I am hoping this will help solve the problems, as others with the same router are connecting just fine.

  2. bluedog

    bluedog Network Guru Member

    Don't have one of these so I am not much help..

    Got this off of google:
    For example, my wireless network is set to use shared key security (WEP is enabled). Well, apparently, the PSP requires open network security. The error message that informed me of this was generic and only gave me this code as a specific reason: 80410D09 . Helpful, huh? After I Googled around for that, I fixed it and tried again. New error: 80110482 . WTF? While poking around, I retried the connection and magically it worked. Turns out the error has something to do with not getting a DHCP response (getting an IP address from the router’s DHCP server). I think I may have tried to test it too soon after changing the settings on the router… it was probably still trying to restart.

    Hope it helps, if not send me the psp and I will figure it out for you. :wink:
  3. Tony56

    Tony56 Network Guru Member


    You must enter your WEP key in hex on the WRT5G and use the corresponding ascii characters in entering the WEP key on the PSP. If done correctly the ascii WEP key should be either 5 or 13 characters long depending on if you are using 64 bit or 128 bit encryption.


    I have successfully connected a PSP to the WRT54G using WEP security so I know it can be done.
  4. jagboy

    jagboy Network Guru Member

  5. jdepew

    jdepew Administrator Staff Member Member

    Like you said, your firmware is a tad old... hop on over here - - to pick up the latest Linksys firmware for your router. I would suggest resetting to firmware defaults and setting up your WEP and any other custom settings you had after that.

    I'm not quite sure if the PSP requires UPnP, but this firmware version supports UPnP much better, and may be another good attempt.

    Also, as others have stated make sure that you are entering the hexadecimal version of the WEP key given to you when you set it up to access the AP with the PSP.

    (lots of acronyms, eh?)
  6. Anonymous

    Anonymous Guest

    All fixed..

    Had the same probs..
    Set your device from shared key to open and that will resolve the 80410D09 error...

    DHCP is up to you!!! =P

  7. Anonymous

    Anonymous Guest

    psp problems

    i still dont understand i keep gettin that code too and i have wep and wrt54g please tell me what to do
  8. Anonymous

    Anonymous Guest

    This is weird.

    I have checked and triple checked that I have the PSP's MAC added to my WRT54G's access list.

    I even disabled MAC filtering.

    Have manually given PSP IP address/ GW / SM / DNS

    I've tried disabling WEP and having no security.

    When testing the connection, everything is good except it says Internet connect : Failed.

    I'm very good at configuring my WRT54G. I know what's going on with it. Something different with the PSP that is different than laptops.

    I'd say I've configured no less that 10 laptops to connect to 3 different varieties of wireless Access Points.

    I know how to do MAC filtering. I know how to configure WEP.

    This PSP is a bugger.
  9. Nstern2

    Nstern2 Network Guru Member

    I have the same router and had the same problem as you. I changed the channel of my wifi to 1 and my psp recognized it. But I am using firmware 1.5 on my psp so it might not work on yours.
  10. daskog

    daskog Network Guru Member

    Do you use Thibor of any cind? that could be the issue!?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice