Can't get valid IP address - after working for short time - Charter

Discussion in 'Tomato Firmware' started by glen4cindy, Sep 29, 2010.

  1. glen4cindy

    glen4cindy Addicted to LI Member

    Hello. Been running tomato for at least 3 years now without any issues, and I don't ever want to go back to standard Linksys firmware. I was having some slight issues with my router so I updated it to 1.28, and it worked fine for a few days, until one day I got for an IP address. If I rebooted the cable modem, I would get for about 1 or 2 minutes, and then it would revert to

    I didn't investigate further, and assumed my router had went bad, so I bought another WRT54G v3 on E-Bay and hooked it up, made sure it worked, and was surfing, and using it just fine under Linksys firmware. I might add that I also use OpenDNS, and I don't know if that has any part in this equation or not, but, I am thinking that it might.

    After I made sure the router was working, I loaded 1.28 on there, and began adding my settings as I like them, one of them being OpenDNS servers. Shortly after, I ended up with as my IP address, even after rebooting the cable modem 3x.

    After this happened, I went into the router settings and replicated the MAC address from my PC, reset the DNS to so the router would get it's DNS from Charter, and now, I am surfing just fine, on 1.28 with the "new" router.

    Is it possible that Charter is "blacklisting" my routers MAC due to my using OpenDNS? Since I have replicated my PC's MAC address in the router, I am afraid of setting up the OpenDNS servers again, just in case this is happening. I don't want my PC's NIC to be black listed because if my internet ever goes down, Charter makes me bypass the router and plug directly in to my PC.

    Any idea why I would get all zeros like this?
  2. glen4cindy

    glen4cindy Addicted to LI Member

    To add some more information here, this is most certainly a situation of Charter messing with DNS. Question is, can it be solved?

    I tried about 10 different random MAC addresses with DHCP everything, and still got for an IP address, after rebooting the modem/router/computer each time. It's like the modem was refusing Tomato.....If I cloned the MAC of my computer, I would get an IP, but ONLY if I cloned the IP of my computer.

    I loaded Linksys firmware back on the router and immediately got a valid IP address, with the routers regular MAC address, so it must not be a blacklisted MAC address. I can even add TWO OpenDNS IP's into the DNS fields in the Linksys firmware, but, as soon as I took out Charters 3rd DNS, and replaced it with an OpenDNS address, my IP went to

    Problem, is, the Linksys firmware will not do what I need it to do, but, the modem will not issue an IP to the router with Tomato loaded.

    Someone please help!
  3. FattysGoneWild

    FattysGoneWild LI Guru Member

    I have Charter as well and a fellow 1.28 user myself. Very weird problem you have. I have personally always cloned the mac address with my main pc for cable. Charter and even Linksys advise to do that if you are on cable. How come you do not use Charter's dns? You can block their redirection using dnsmasq. Or maybe you are using Opendns for parental controls? Opendns worked fine for me a few months ago with Charter when trying it. My reply is not much help. But the only other thing I can think of. And it is only on possibility. Charter is blocking people from using 3rd party dns now. But then again. You loaded stock firmware and it worked fine. As for the 3rd dns field. I would not mix and match with Opendns and Charter. Use 1 or the other. Use Tomato to set Opendns to use only the 2 static ip's.
  4. glen4cindy

    glen4cindy Addicted to LI Member

    First, thanks for the reply. As far as cloning the MAC, I have never done that, in the 10 years that I have been using a Linksys router, including the 3 or so years that I have been using Tomato.

    As far as the DNS goes, the Linksys firmware pulled a Charter DNS as the 3rd entry, I didn't put it in there. I didn't want to mix them, and it's when I put an OpenDNS in the 3rd spot in the Linksys firmware, it went back to When I took it out, and let the Linksys firmware pull what it wanted from the modem DHCP, I got my Charter IP back. This was all using the routers MAC address, I was not cloning the PC MAC.

    I can see now that Charter is FORCING their DNS. But, why, when I use a random MAC on the router, using DHCP will it not pull an IP? It will pull and IP only if I clone, but, I have never had to clone before, and I don't have to clone if I use Linksys firmware. Seems to be a Tomato glitch. It did not seem to have this issue with 1.27, but, then, Charter was not forcing DNS when I had 1.27 on there either.

    How would I use DNSMASQ to get around Charter forcing me to use their DNS? How would I set this up in Tomato? I've never used this before. I have also thought of using my 2nd router now that I know what the problem is, letting the first router get the IP with Charter's DNS, and running my network from the 2nd router with OpenDNS as the DNS. Not sure if that would work or not, but, it's a thought. Let the whole network run from the 2nd, and let the first do nothing more than grab the IP from the modem......
  5. Themoose

    Themoose Networkin' Nut Member

    I have the exact, i mean verbatim problem. My issues cropped up this evening. I am desperate for a solution as I am running my crummy netgear in the mean time.
  6. glen4cindy

    glen4cindy Addicted to LI Member

    Well, I may be wrong, so, don't take my word for it, but, I had the SAME problem with 1.28 on TWO different WRT54G routers, each different version numbers.

    I ended up loading up version 1.26 and after rebooting the modem and router and flushing NVRAM, I am up an running great.

    Have a read of my troubles at:

    While I did have an issue with getting after filling in OpenDNS in all 3 static DNS fields in Linksys stock firmware, and then removing the 3rd, and then immediately getting a Charter IP, once I reloaded 1.28 the problem returned.

    I did get things to work by CLONING my PC's MAC, but this caused other problems for me. So, I went to 1.26 and it's working so for now, I'm leaving things the way they are.

    Try this and see what happens for you. I'm not going to say for sure it's a 1.28 firmware bug, but, I don't know what could cause these symptoms on TWO different pieces of hardware.

    Good luck. Please post your results back here and let me know what works out for you. That thread is 3 pages long, but, in the end, I found my answer.
  7. Themoose

    Themoose Networkin' Nut Member

    I have not messed around with any of my dns settings since loading up 1.28, and things crapped out on me tonite. Should i need to add dns entries? If so which ones and how do i go about doing such

    I am by no means an expert but i just resorted to my netgear for now until I can really mess around with my linksys. I also recall having this happen about a year ago as well with charter.
  8. glen4cindy

    glen4cindy Addicted to LI Member

    Forget the DNS part, just load up 1.26, or maybe go for 1.27. See what that does, but, be sure the clear NVRAM before and after you flash.

    I only use the DNS because I like the filtering of OpenDNS, you don't have to worry about that part, just take what DHCP gives you. Be sure to power cycle the modem when you switch routers.
  9. Themoose

    Themoose Networkin' Nut Member

    Flashed to 1.26 and it's back up and running. Very odd stuff. I have not configured anything from the stock firmware defaults other then w/l security related items... Do i really need to flash NVRAM twice?
  10. glen4cindy

    glen4cindy Addicted to LI Member

    Well, I've went without doing it before, but, they always recommend doing it to make sure clearing everything from the NVRAM before and after flashing to make sure no stray peices of the previous firmware remain.

    You said you didn't have any settings, but, if you did, you would have noticed that even after flashing things like your WiFi settings will remain and other settings will still be there.

    I cleared NVRAM after, and since I had flashed stock Linksys firmware before, I did a factory reset.

    Glad it's working for you again. This certainly points to a firmware issue, we now have 3 devices that have had probelms with 1.28. Interesting.
  11. Themoose

    Themoose Networkin' Nut Member

    Well victory has been short lived. I was having wireless drops constantly, went and power
    cycle everything and I can get an IP again. Grrrrrrrr
  12. TexasFlood

    TexasFlood Network Guru Member

    Couple of suggestions based on my past experience and forgive me if these have already been mentioned but I did not see them in a quick review. Note that this is not based on recent experience as my config is working fine so I haven't had to mess with it. Also note that I have Comcast cable not Charter.

    1) I can't recall exactly which firmware this applies to but think Tomato has been one of them. If I change the WAN MAC, I can't get an IP on the new MAC without rebooting or power cycling my cable modem. If I switch back to the old MAC it works again. After a cycle, whatever MAC is set will work.

    2) Certain Comcast system config changes pooch my network until I power off my cable modem, several minutes to be sure it works. This doesn't happen often but does happen.
  13. glen4cindy

    glen4cindy Addicted to LI Member

    Wow. Sorry to hear that. I've been rock solid since I've flashed mine to the 1.26. I'm sure you power cycled your modem since you got an IP and were working, but, if you were having that many issues, especially after flashing, maybe it wasn't a firmware issue in your case. You may have some hardware issues going on.
  14. Themoose

    Themoose Networkin' Nut Member

    Ok this router is possessed. I power cycled everything again. This time let the cable modem
    come up first, then I plugged in the router. It has been up for a day now. I will see how long it lasts maybe even load up 1.28
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice