Can't get WOL to work...

Discussion in 'Tomato Firmware' started by dtamonis, Mar 17, 2007.

  1. dtamonis

    dtamonis LI Guru Member


    WOL worked earlier (tried only once, but it was successful) and now it does not. I don't know if this has something to do with Tomato, but that successful try was before installing it. I searched this forum and followed instructions given by dg7raj in this thread. First I forwarded port 9, then copied and pasted the given line in Administration/Scripts/Firewall. There already was a script there, so I just pasted the line below it, is it OK? And I removed the # because, as I understand, this is the comment symbol. Finally, in Static DHCP I added the MAC address of my computer's NIC and my computer's IP address, which is static. I left Hostname blank.

    After rebooting, my computer does apear in the WOL page, MAC and IP addreses are shown correctly, but status is '-'. There's also FF:FF:FF:FF:FF:FF at IP and its status is Active (In ARP). When I click on the line, nothing happens. When I try to wake up the computer with AMD's Magic Packet utility, nothing happens as well. And with this utility I previously woke up the computer.

    EDIT: this probably isn't important, but I was logged in through HTTPS (just to mimick connection via the internet, my goal is to be able to wake the home PC up from elsewhere).

    BIOS has WOL enabled, LED on router stays on after turning off the computer (and sometimes blinks).

    Any ideas? I only use Tomato only for two days, but I already like it very much (except SVG graphics with which Netscape 7.2 doesn't want to be friends), and I'm very reluctant to revert to original firmware just to test WOL. My computer likes to hang sometimes, so I'm afraid of bricking the router.
  2. dtamonis

    dtamonis LI Guru Member

    No ideas? I've solved everything to have the ability to remote control my home computer, except this Wake On Lan problem. How about that: if someone helps me nail down the problem, I'll throw a few bucks to this site :)
  3. bokh

    bokh Network Guru Member

    Maybe a complete power-cycle of all connected electronics in your network might work... And I don't mean that like power off / power on, but more like if a fuse has been blown.
    If you got your equipment connected to a single power-socket (like my stuff), pull it out.
    I had some weird issue before with very low NIC-speeds, but when I was electrocuted while fixing my DVD-player and a fuse blew :rofl:, things were fine afterward.

    Since even the AMD-utility fails to wake up anything, I guess it's not Tomato-related.
    FYI: WOL is (was?) working here out-of-the-box, though I haven't used it since Tomato v1.02 or so. There's no need to add extra forwarded ports AFAIK, at least I never used them.

    Oh and why don't you start using Firefox? It has SVG inside, is free and is far superior to NS!
  4. dtamonis

    dtamonis LI Guru Member

    Guess what? It worked!!! When you gave this idea, I also disconnected and reconnected the LAN cables, plus power cables. And BAM, a miracle :) I kept my promise and threw 5 bucks to this site, so you are the real donator in this case ;)

    Oh, that's another topic :) Just because I use NS since version 2 (and I strongly depend on habits, I also still use Win98 by the way), because it's a browser, a mail client and an HTML editor in one and because I don't like a few cosmetic things in FF which would really annoy me. Did I say anything about habits? Hey, even graphical smilies are turned off :)

    Anyway, thanks again.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice