Can't install Tomato on refurbished WRT54GL v1.1 (from Linksys firmware 1.00.9)

Discussion in 'Tomato Firmware' started by kolight, Jul 7, 2011.

  1. kolight

    kolight Networkin' Nut Member

    Hi all,
    I just received my WRT54GL v1.1 router ( to replace my Asus 520GU that died this weekend. I thought I would have Tomato running in a few minutes after reading the readme but I'm not so lucky. When I try to upgrade to the tomato 1.28 firmware from the Linksys Web Gui, I get a quick "Upgrade are failed" message. I then checked that I really got a WRT54GL v1.1 and it looks like it (model number under the router is WRT54GL 1.1 and the serial number starts with CL7C). I still have some doubts though because the front of the router has the name WRT54G (no trailing L) and the Linksys firmware displays the router name as WRT54G. Still, it's supposed to be a WRT54GL 1.1 otherwise I'm returning it because it's not the model I ordered.

    I thought the upgrade to Tomato might be failing because of the very old firmware that came with the router (1.00.9) so I tried installing the latest Linksys firmware (4.30.15) from the Web GUI. This produces the the same error (Upgrade are failed). This seems odd to me because I would assume this to be a straightforward case. Could it be that there's no direct upgrade path from 1.00.9 (I'm still amazed to have such an old firmware version by default)? Or is it possible that my serial numbers and models are wrong and I'm really here with a WRT54G?

    Does someone have any idea?
  2. Shovon

    Shovon Networkin' Nut Member

    It's pretty inexpensive rouer, don't know why u choose refurbished one instead of buying a new one. Anyway, did u try reset ur router to factory defaults b4 flashing? Also please right click on downloaded firmware file and then click on "unblock" button (if any). Most probably ur router's mainboard isn't actually "GL" version.

    Please download this pdf book, open ur router's cover, then compare ur mainboard with book's pictures to make sure actually which version u've got in it. Then download firmware accordingly.
  3. eahm

    eahm LI Guru Member

    Do what Shovon said then try the following steps.

    Have you tried via TFTP?

    TFTP app:

    Latest original firmware:

    Tomato firmware/s (the one I use with that router):
    w/ Kernel 2.4:
    w/ Kernel 2.6:

    Try this way:

    Start tftp.exe.
    Enter as the address in the top box of tftp.exe.
    Password: admin
    Select the Tomato or the Original firmware.
    Set retries to 99.
    Power cycle the router.
    Count to 2.
    Hit upgrade.
    Once the upgrade is done wait FIVE FULL minutes then power cycle the router.
  4. WRobertE

    WRobertE Addicted to LI Member

    You mentioned a couple of times that the error message said "Upgrade are failed". Is this the EXACT message? I can't believe a legitimate Linksys router would include an error message that was so grammatically incorrect.

    Instead of a refurbished unit, this sounds like a knock-off or some kind of clone rather than a real WRT54G/WRT54GL. I'd send it back and get a refund and get the RT-N16 instead. It's a little more expensive but it'll be a much better value over the long run.
  5. eahm

    eahm LI Guru Member

    That's a really good observation. I am 100% with him, if the error message is that one, return it.
  6. GhaladReam

    GhaladReam Network Guru Member

    "Upgrade are failed" is actually a legitimate message that is displayed on legit Linksys firmwares. I've seen it in firmwares i've downloaded from the official linksys website, and also from brand new units fresh out of the box & shrink wrap. They just never bothered to fix the grammar.

    Also, firmare version 1.00.9 is from a WRT54G v5+ VxWorks router. It looks like something happened at the factory and you got shipped something like a v5 or v6, which absolutely can't take Tomato. I'd return it.

    The only other thing I can suggest, is get VxWorksKiller and flash DD-WRT Micro to the unit to get it back to Linux, then try to flash tomato. It's possible that the factory accidently flashed a VxWorks firmare to the WRT54GL.
  7. Toastman

    Toastman Super Moderator Staff Member Member

    As GhaladReam says, sounds like you've accidentally been sent a 54G v5 - which is junk.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice