Can't make WRT54G work with Counter-Strike:Source! (Newb)

Discussion in 'Cisco/Linksys Wireless Routers' started by timo1023, Apr 16, 2006.

  1. timo1023

    timo1023 LI Guru Member


    I found this site through Google and it looks like a godsend for me. Ok, here it goes. I have tried everything in the world to get CS:Source to work for me. When I try to join a game, I get the message "unable to connect to steam servers" or something to the same extent. So, I followed the link to their support page.
    It looked helpful and I followed almost all of it. I determined that it is not a problem with firewall because when I disable firewall, the problem is still there. I port forwarded the required ports and disabled uPnP.

    I don't really have much experience with routers, so please treat me like a newb. Maybe I need a new/different firmware?

    Thanks so much,
  2. CTroxtell22

    CTroxtell22 LI Guru Member

  3. timo1023

    timo1023 LI Guru Member

    I have a v2 WRT54G, and I have already upgraded to the latest Linksys firmware. The problem is, the firmware for v2's is fairly old, and the problem still persists.
  4. Thibor

    Thibor Super Moderator Staff Member Member

    the latest firmware's from linksys(4.20.8) are suitable for versions 1-3
  5. Toxic

    Toxic Administrator Staff Member

    did you post forward to the correct IP address? if you port forwad at all you really should be using static IPs for your PC's this stops the ip addressing being incorrect. DHCP will automatically assign an IP address starting at the lowest starting IP upwards. and depending on when your computer is turned on against other computers, you will get an IP according to when you have turned it on.
  6. timo1023

    timo1023 LI Guru Member

    1. When I tried to update with latest firmware, it said that the update was unsucessful.

    [EDIT: This is the firmware currently on my WRT54G

    2. I don't have the option to port forward to a certain IP. All I did was go to "Applications and Gaming -> Port Range Forward" and open the ports.

    [EDIT 2: Ahh, gotcha. I already have the ports set up towards my computer's IP address (found by typing "ipconfig /all" into cmd on my computer). [/EDIT]
  7. timo1023

    timo1023 LI Guru Member

    Bump, still looking for a solution...
  8. Toxic

    Toxic Administrator Staff Member

    try setting the PC your playing on into DMZ

    if still no go, start lowering the firewall settings.

    just to see if it is definately the router.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice