Can't ping or access anything over VPN (except the VPN server)

Discussion in 'Tomato Firmware' started by danimaltron, Jun 6, 2012.

  1. danimaltron

    danimaltron Networkin' Nut Member

    I have a home and office network. Each are on different subnets: (home) and (work).

    At work, there is a Mac server with VPN service running amongst other things. It hands out IPs in the range.

    Both networks use an Asus RT-N16 router with Tomato installed. Previously the office used DD-WRT, and this same config worked perfectly. I recently installed Tomato at the office, and now am having issues even though I used the same basic config after installing Tomato.

    The problem is:

    I can connect to the Mac VPN just fine, and access all services that are hosted on the same server that the VPN service is running on. I can ping it, etc.

    But when connected, I cannot ping any other device on the work network (from home), access the work router's GUI in my browser, etc. Previously, this worked with DD-WRT.

    For my VPN client, I checked the option "send all traffic over VPN" and this seems to make everything work. I can access internet and ping/access all devices on the work network.
    But, I don't want this selected all the time. I only want traffic for the 192.168.2.x network to go over VPN.

    I'm not sure why this worked in DD-WRT but not Tomato, but I would like to fix it as I prefer Tomato for everything else. It seems there is some sort of routing issue, but not sure how to fix.

    Any ideas? Thanks for your help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice