Can't SSH In - password doesn't work?

Discussion in 'Tomato Firmware' started by victorhooi, Jan 17, 2011.

  1. victorhooi

    victorhooi Addicted to LI Member


    I have a WRT54G v1.1 router (4Mb flash).

    I previously had Gargoyle on it, as I wanted to use the per-IP quota feature. However, I couldn't seem to get this to work:

    Anyhow, they I thought I'd try Tomato. I noticed that Tomato-USB claimed to have quota support. I tried installing "tomato-ND-1.28.8754-Std.trx" on my box, which seemed to half-brick my router. I had to use TFTP to get it up again (I ran into an issue because I didn't know at first TFTP images had to be less than 3Mb).

    I then installed Tomato 1.28, and thought I'd try following the IPTables Bandwith Monitor guide (

    However, I can't seem to SSH into my box.

    I've enabled the SSH daemon on startup, and it's started. I can SSH in, and get a login prompt. I've tried with both the username "root" and "admin, and using my password, as well as the default Tomato password ("admin"), nothing seems to work.

    Same on Telnet as well.

    My normal password works fine for the web interface - yet doesn't for SSH. The only real change I've made i setting up PPPoE, and changing the router's IP to

    Any ideas?

  2. victorhooi

    victorhooi Addicted to LI Member


    Ok, weird, I created a new key using PuttyGen, added that to Pageant, and then if I login as "root", it works using that key...

    Are there any caveats/tips with SSH access on Tomato?

  3. mstombs

    mstombs Network Guru Member

    ssh works fine with username "root". Did you reset to defaults after loading Tomato?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice