Can't unbrick wrt54g v5

Discussion in 'Cisco/Linksys Wireless Routers' started by jmoschetti45, Jan 16, 2007.

  1. jmoschetti45

    jmoschetti45 Guest

    A friend of mine gave me hers to try to fix it. The web interface was pretty much dead (most of the pages didnt load, and you couldnt update the firmware), so I tried the pin 16 trick, and now all that happens is the power led blinks, and ethernet 1 2 3 4 and internet stay illuminated, and I can't connect to it. Suggestions?
  2. uniquestar

    uniquestar Guest

    I just managed to unbrick my WRT54G v5 after a couple of days.

    It took me a few attempts, and I don't know exactly how I did it, but I can give you a few tips.

    I used the Linksys tftp program, and the dd-wrt v23 SP2 micro generic firmware as I couldn't get it to boot properly with the VxWorks.

    to be able to ping the router, and therefore get tftp to connect, I had to short pin 16 to the ground on the aerial, and press the reset button before powering it up, after doing this a couple of times, the dd-wrt firmware took hold, and the router worked fine.
  3. jeloxi

    jeloxi Network Guru Member

    I have a v5 too with the same problem. I managed to open my unit up. But I am not sure on the shorting process. Is there a tutorial somewhere?
  4. Jim565656

    Jim565656 LI Guru Member

    Same here every LED is dark except for the power LED its blinking.
  5. burma69

    burma69 Guest

    I did the same thing as uniquestar and it helped! :)

    After a few power disruptions my WRT54GS was bricked. The 2 leds (that were on when disaster occured) were lit up no mater what i did. No ethernet ports worked. Nothing helped (router was unpingable), so I almost told him goodbye (and bought WRT54GL :) )

    Then I just
    * unplugged the power from router
    * grounded pin 16 (shortening 15 and 16 didn't help)
    * plugged the power cord
    * ungrounded pin 16 a few seconds later

    At this moment router became pingable even though power led was blinking continuosly (all other leds were off except the one responsible for the ethernet port I connected to my notebook). The trick was that original Linksys firmware didn't work (I have once flashed with dd-wrt). Fortunately, my router accepted any file as a firmare, so I just flahed it via tftp with dd-wrt micro firmwae again and everything worked.

    So now I have two WRT54 :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice