Can't upgrade firmware

Discussion in 'Cisco/Linksys Network Storage Devices' started by jschall, Feb 21, 2006.

  1. jschall

    jschall Network Guru Member

    OK, so I have to upgrade my NSLU2 from R24 to R63.

    I browse to the NSLU2_V23R63.bin file, press the "Start Upgrade" button and...

    Error message - "Upgrade: No enough free space"

    What now?

    - Jeff
  2. jschall

    jschall Network Guru Member

    OK, I had to use the "erase all" utility, which is included in the R63 download, and it first erases the eprom then installs R63

    - Jeff

    JTHSPACE Network Guru Member

    Hi, just got an NSLU2 and got the same error message. I searched on the web and found this site and this post which is exactly the same problem.

    I tried the eraseall utility and when run, it lists the lan ports and firewire ports but that is all - what do I do to get it to erase the rom in the NSLU2 and burn the new one (Version 63).

    Thanks for any pointers on this one.

  4. d__l

    d__l Network Guru Member

    It isn't detecting the NSLU2 on your network.

    Do you have anything such as a software firewall that would block it from the NSLU2? Can you ping the NSLU2 on your network?

    Do you have multiple NICs in your computer and are possibly choosing the wrong one in EraseAll?

    JTHSPACE Network Guru Member

    OK, being new to this . . . .

    Network neiighbourhood can see the router and the drive attached to it (Can access setup thru IE & Firefox)

    Pinged (its IP address) and all sent / all received / none lost.

    I have a Gigabyte NIC and a 10/100 NIC, the 10/100 is connected to my Router (Belkin Wireless Router). My PC is on port one via a Cat 5 and the NSLU2 is on port 4, obviously with a cat 5 cable as well.

    I have tried running RMDRV but no luck, no effect.

    Thanks for the help given, I really appreciate it.


  6. d__l

    d__l Network Guru Member

    So what happens in EraseALL when you select the 10/100 NIC and click the OK button on that screen? Does the program not show the next screen for you to browse to your NSLU2 target or does the program not find the NSLU2?

    JTHSPACE Network Guru Member


    It says

    Could not get system information correctly. Please exit Upgrade utility and execute RmDrv.exe which locate in the same directory with upgrade utility then run upgrade utility again.

    If you run RmDrv ad then run Upgade utility, says the same thing again.


    JTHSPACE Network Guru Member

    OK, after the umteenth time, it work! I didnt do anything different, so dont know why it decided to be kind. :cheer:

    Many thanks for the assistance which is really helpful.

    Now to get remote access working!

    Thanks again

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice