Can't upload firmware

Discussion in 'Tomato Firmware' started by merrick2, Jun 14, 2008.

  1. merrick2

    merrick2 Addicted to LI Member

    I have a WRT54GS V1 with V4.71.1 frimware. I've been trying to upgrade the firmware to Tomato, but every time I go into the administation section and attempt to upgrade, the system starts to flash, and after 3 or for seconds, I'll get the message "Firmware Are Failed". The router is attached directly to my computer. Any suggestions on how to resolve this?
  2. roadkill

    roadkill Super Moderator Staff Member Member

    try to update to DD-WRT Micro first
  3. merrick2

    merrick2 Addicted to LI Member

    Thanks for the reply. I did try DD-WRT first, in several different forms, including the micro version. I got the same results every time.
  4. fyellin

    fyellin LI Guru Member

    I agree with roadkill.

    Some linksys firmware wouldn't allow you to install firmware that was bigger than 2meg, even if it had sufficient NVRAM. For my WRT54GL, Linksys actually offered a firmware patch, which would then allow you to install larger firmwares.

    1. Download the current linksys firmware, just so you'll have a backup
    2. Install small firmware that allows you install large firmware
    3. Install large firmware
  5. merrick2

    merrick2 Addicted to LI Member

    I have the version 1 of the Wrt54GS, which is supposed to have more memory to allow for larger firmware. I've tried uploading the DD-WRT Mini version of the newest release 24, which is only 2800kb. Still won't finish uploading.
  6. LLigetfa

    LLigetfa LI Guru Member

    RK said micro, not mini.
    In post #3 you said you tried micro but in post #5 you said mini. Which is it?
  7. merrick2

    merrick2 Addicted to LI Member

    Sorry for the confusion. I've actually tried them both, and they both fail in the same way-When I use IE7, I get a failed message immediately. If I use Firefox, it takes about 30 seconds to get the failed message. I've even tired downloading tftp.exe and loading all of the different firmware-with tftp.exe, I do get a success message but when I do a hard reboot, the original linksys firmware comes up. I've upgraded this router in the past without a hitch. Is it possible that I need to do something different because the router isn't on my network? It's just attached to my laptop without an internet connection and with the wireless disabled. I've also tried changing the laptop's IP to a static Ip from DHCP-same result. I appreciate everyone's input. Any other suggestions?
  8. mstombs

    mstombs Network Guru Member

  9. rizsher

    rizsher Network Guru Member

    Wouldnt using tftp be the way to go then?
  10. merrick2

    merrick2 Addicted to LI Member

    I've tried Thibor as well. No luck-I'm thinking that it's a problem with the linksys firmware. I've been trying to find a previous version of the firmware without success. Is my router somehow frozen? Is there another way to do a hard reset?
  11. szfong

    szfong Network Guru Member

    This has happened to me in the past, give yourself a static ip in same subnet as router for net card directly connected to router, disable wireless or other net cards on your Windows XP/Vista system (i'm assumming here). Log onto web gui upgrade, then upgrade. Make sure your directly connected to your computer and NOT through another switch/router/etc. Connect to one of the LAN port, just to be sure hehe ;) Good Luck

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice